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Introduction

You’ve probably used Google to search the Web—who hasn’t? Google is so ubiquitous
that it’s even become a verb (you can look it up in Webster’s), as in, “I googled the
girlfriend I dumped in high school; now she’s CEO of SuperMegaCorp.” But Google
is way more than a search engine. The full list of services it offers is almost as mind-
boggling as the number of lightning-fast searches it conducts each day. The next time
you’re on Google’s home page (http://www.google.com), click “more”→“even more” to
see the whole smorgasbord: from maps to a checkout service for online retailers to
photo albums and YouTube—and that’s just for starters.

The biggest recent news from Google, though, is that it’s putting programs online—
the kind you used to have to install on your computer. They include applications for
word processing; working with spreadsheets; creating presentations; reading, writing,
and storing your email; and scheduling appointments and meetings. Google’s brought
communication, productivity, and collaboration tools right to your Web browser.

Last but certainly not least, the vast majority of Google’s programs are free. Yup, you
read that right: You can get word processing, spreadsheets, email, chat, a Web-page
builder, and more, and it won’t cost you a dime. Sound interesting? Read on to learn
more.

NOTE
In this book, the term app (with a lowercase a), means an individual Google product,
like Google Calendar or Gmail. “App” is an inescapable bit of geek shorthand for
“application”—a word that itself is synonymous with “program.”

Google Apps (with a capital A), on the other hand, refers to a bunch of integrated
Google products (including some of the aforementioned apps), all wrapped into a
highly customizable package that Google hopes companies will sign up for as an
alternative to Microsoft’s Office suite of programs. Chapters 2–9 cover individual
apps, while Chapters 10–13 cover the Google Apps packages for organizations.

This is just the short version of the individual apps vs. Google Apps conundrum;
page xx tackles this slightly perplexing naming choice in more detail.

xiii
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Welcome to the World of Web-based Applications
What are Web-based applications? Simply put, they’re programs you access over the
Internet. You point your Web browser to the place where the application lives online,
and then work with it in the same way you’d work with a program that lives on your
computer.

Google’s online offerings mean, for example, that you don’t have to install a word
processing program on your computer. Instead, you can fire up your Web browser,
point it to http://docs.google.com, sign up for a free account, and start creating your first
document in mere seconds. You don’t have to remember to save your work—Google
does that for you automatically—so you can focus on the task at hand. Google stores
your files on its computers (you get lots of free storage space), so your saved documents
are safe even if your computer melts down. And you can work on those documents
from pretty much any computer with an Internet connection: at work, at home, a
friend’s place, the library, wherever. You can even use Google Docs while you’re offline
—when you’re flying, for example—so you don’t have to be connected to the Internet
in order to do work (“Editing Documents Offline” on page 79 explains how this
works.)

It’s Good to Be Web-based
The most obvious advantage of Google’s Web-based products and services is that
they’re free, and who doesn’t like free? But there’s a whole bunch of other reasons for
using Web-based programs:

• Portability. When a program lives on your computer, you can use the program
only on that particular computer. So if you work on your desktop computer in the
afternoon and then want to work on your laptop that evening, you have to re-
member to transfer the files, or you’re out of luck. With Google apps, you don’t
install anything on your computer, so you can access your applications—and your
data—from any computer that can connect to the Internet.

• Mobility. Web-based applications also work with mobile devices, so you can get
to your information from your Blackberry, iPhone, or any souped-up cellphone.
Once you start using Google Docs (Chapters 2–4), you’re free to roam around the
planet without fear of being away from your files.

• Collaboration. Only you can access a document that lives on your computer’s
hard drive. If you want to share it, you have to email it or print it out. When a
document lives on the Web, though, you can share it with lots of people at once.
With Google Docs, you can invite coworkers to collaborate on a document with
you, and you can all work on the same document, at the same time (see “Collab-
orating with Others” on page 93 for more on this mind-blowing feature). No
more emailing spreadsheets around and getting confused about which version is
most current, or waiting for somebody to check a report back into SharePoint so
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you can have your turn with it. You’re all free to work on the same word processing
document, spreadsheet, or presentation whenever you want.

• Integration. Individual Google programs and services can talk to other popular
programs. For example, Google Docs lets you import and export Excel and Open-
Office Calc spreadsheets. And if your company is thinking of making the switch
to Google Apps (see Chapter 10), integration with your existing IT infrastructure
is definitely possible (not a no-brainer, to be sure, but well within reach of any firm
that has one tech-savvy person—and this book). For example, you can migrate
email from your current mail server into Google Apps Email while preserving mes-
sages’ date information, read/unread status, and the filing system people have used
to organize their messages.

• Updates and bug fixes. Do you dread having to download and install program
updates and patches because of the havoc they sometimes wreak on your system?
Well, say goodbye to that sinking feeling. Since Google applications are on the
Web, Google automatically takes care of updates and bug fixes for you.

NOTE
Since Google apps are Web-based, Google can easily update and improve them—
which it does all the time. That means you don’t have to wait for a new edition to
come out to take advantage of new features. It also means that what you see on your
computer screen may be different from the images in this book. Google makes so
many changes, it’s impossible to keep up!

• Search. Not surprisingly, Google’s Web-based services have some of the same
searching power as its famous find-anything-on-the-Web engine. That makes it
easy for you to search your documents, email, and more. For example, Gmail pro-
vides so much storage space (page 229) that you may never have to delete another
email—and Gmail search makes it a snap to find any email in that haystack of
messages.

• Central administration. If you own or manage a domain (the address people use
to find your Web site, such as myvastdomain.com or ourcompany.com or statecol-
lege.edu), then you can create a Google Apps account, which, as Chapter 10
explains, brings together all Google’s programs in one place for your organization.
Google Apps can be helpful for any collection of workers, no matter how big or
small. With a few clicks, a Google Apps administrator can set sharing policies
across the whole domain, for example. So you can decide whether to let people in
your firm share their documents and calendar info with people outside the domain
(that is, the general public).

• Working online or offline. In March 2008, Google rolled out a new feature:
the ability to work offline in Google Docs. Before that, one of the main complaints
about Docs was that you had to be connected to the Internet to use it. You could
export files to another application, like Word or Excel, to work on them, but then
you’d have to remember to import the files to Docs again. But now you can work
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with Docs online or off, without having to export anything. This is great if, say,
you travel on business and need to work while you’re on a plane and don’t have
an Internet connection. The work you do offline gets uploaded automatically next
time you connect to the Internet. That way, any file in Docs is always the most
recent one. (You can revert to an older version if you want, but that’s another story
—one told on page 102.)

• Security. You might be thinking, “Okay, Web applications sound great so far—
but what about security?” The idea of switching to Web-based programs makes
some people nervous. After all, when you store documents and information on
your computer’s hard disk or your company’s servers, at least you know where it
is. What happens to files and data you store in Google apps?

Your data doesn’t simply sit on some computer at Google’s headquarters. Google
operates a grid of servers in many locations around the world. So instead of storing
your data in one place, it distributes your information across this grid, making it
harder for hackers and other nasty types to get their mitts on your info. Compare
that strategy to keeping everything on your own computer: What happens if some-
body steals your laptop? Even if the thief can’t crack the password and get your
data, you still don’t have access to your files. Same goes if you drop your laptop in
the pool.

NOTE
The practice of using Web-based applications and storing data in a “cloud” of net-
worked servers is called cloud computing.

Google takes data security very seriously. It has full-time security teams whose job
it is to repel malicious beasties like viruses, worms, and spam. Google’s spam pro-
tection, for example, runs rings around some of the other Web-based email
services. Google uses a combination of sophisticated filters and user reporting to
keep spam out of your inbox. It’s not perfect, but it’s darn good—especially when
you consider that spam makes up about 90 percent of all the email whizzing around
cyberspace.

Most Google apps also support SSL (secure sockets layer), which encrypts data to
keep it secure. You know you’re in a secure mode when the URL in your Web
browser’s address bar starts with https:// instead of the usual http:// (think of that
added “s” as standing for “security”). Whenever you sign into your Google Account
(which is how you access all of Google’s offerings—see Chapter 1), you do so
through a secure connection—one that starts with https://—so no one can eaves-
drop on your user name and password.
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TIP
If you’re worried about the security of the data you transmit from your computer
into the Google cloud, you can make sure you connection is secure. Just type
https:// in front of the URL of the Google application you’re using. For example,
connect to Gmail via https://mail.google.com or to Docs via https://docs.google.com.
The tradeoff? Performance is slightly slower when your apps are piped over an SSL
connection.

• Privacy. Privacy’s another issue related to security. You may have heard that Goo-
gle scans incoming email, looking for keywords, so it can display ads targeted to
the email’s content. Is that a violation of privacy? Read the box on page 233 to
decide. If privacy concerns you, take the time to read and understand Google’s 
privacy policy. The box on page 38 gives the highlights, but you can read the
whole thing at http://www.google.com/intl/en/privacypolicy.html.

• Cost. When it comes to individual applications, you can’t beat Google’s price:
They’re free. Compare that to the cost of any program you install on your computer
(which doesn’t have all the benefits of Web-based applications).

If you’re an IT manager (or you play one at your company) and want to sign up
for a Google Apps account, you have these choices (explained in more detail in
Chapter 10):

— Standard Edition is free.

— Premier Edition costs $50 per year, per user. This edition offers some benefits
that Standard Edition doesn’t have, such as email migration and 25 GB of email
storage for each user.

— Education Edition is also free. It offers many of the benefits of the Premier
Edition, but is available only to educational institutions (who have a domain
name ending in .edu) and nonprofits with federal 501 (c)(3) status.

TIP
For a comparison of the different editions of Google Apps for organizations, see the
box on page 484.

What You Get with Google Apps
So what is Google Apps? A lot of people use the term loosely, meaning just about any
Web-based program Google offers. But, technically speaking, they’re wrong. Google
Apps (see Figure 1) is actually a specific collection of Google products and services that
the company offers to other organizations. Here’s a breakdown of what you get if you
sign up for Google Apps:

• Google Docs (Chapters 2–4). Create, edit, and share documents online—and
work on them when you’re offline, too. Docs lets you create and work with word
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processor documents, spreadsheets, and slideshow-style presentations. You can
do so much with Docs that this book devotes three chapters to it: one for each kind
of document.

NOTE
As the Note on page xiii explains, this book uses the term apps to describe these
individual Google services, which are available to anyone, even those whose firms
haven’t signed up for Google Apps.

• Gmail (a.k.a. Google Apps Email—Chapter 5). Google’s Web-based email
program offers oodles of storage space, labels to keep your messages organized,
and the ability to search and filter your email.

• Google Talk (Chapter 6). Talk is Google’s instant-messaging service. You can
chat with friends and colleagues, see who’s online, and invite the whole gang to a
chat as a group.

• Google Calendar (Chapter 7). Keep yourself on schedule with this event-
management application. You can create multiple calendars, schedule events (you
can invite others to join you), and share your calendars with friends and family,
colleagues—or the whole world.

• Page Creator (Chapter 9). Design your own Web pages and post them online—
for free—with Page Creator, Google’s Web page editor.

Figure 1. On the Google Apps home page, you can create a Google Apps account for your
organization.
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• Control Panel (Chapter 10). The Control Panel is where Google Apps adminis-
trators customize all the programs their firms use, and manage individual employee
accounts.

• Start Page (Chapter 11). Google Apps administrators can design a custom home
page for everyone in their organizations with Start Page. For example, you can put
your company’s logo at the top, include announcements, and insert gadgets (mini-
applications you can embed on a Web page) to give users one-click access to their
Google apps. Various gadgets let folks keep an eye on their Gmail inboxes, access
collections of important documents, check appointments, and chat with cowork-
ers. And people can customize their own Start Pages to suit their working styles.

NOTE
Start Page is similar to iGoogle (Chapter 8), Google’s customizable search page that’s
available to the general public (page 515 lays out the differences between iGoogle
and Start Page).

• Google Sites (Chapter 12). Google Sites lets you create a collaborative Web site
that a bunch of people can work on—add content to, edit, and so on—at the same
time.

NOTE
Unlike the other apps in this list, which have versions anyone can sign up for (no
need for a Google Apps account), Google Sites is available only through a Google
Apps account.

More Google Stuff
Doesn’t Google offer other applications and services, too? What are they?

Google offers a ton of products and services, from Alerts to YouTube to Blogger to Web
Accelerator. To see them all, go to www.google.com (http://www.google.com) and click
“more”→“even more”. Some of these services, like searching, you can just go ahead and
use without logging into anything; others require a Google Account (Chapter 1 tells
you all about that).

Here’s a list of some popular and useful Google services (none of which are covered in
this book, in the interest of keeping this volume under 5,000 pages):

• Blogger (http://www.blogger.com). Keep an online journal or sound off on politics,
entertainment, or social issues. A blog (short for Web log) is a Web page that
contains regularly updated posts about whatever’s on the blogger’s mind.

• Google Earth (http://earth.google.com). Google Earth is a virtual globe that uses
satellite images and maps to give you a bird’s-eye view of the world in 3-D.
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• Google Groups (http://groups.google.com). On this site, you can read, create, and
participate in online discussion groups. (You’ll find Google Groups dedicated to
discussing all the Google apps.)

• Orkut (http://www.orkut.com). This social networking site is Google’s answer to
MySpace and Facebook. Mainly unheard of in America, it’s wildly popular in
Brazil.

• Google Reader (http://www.google.com/reader). Google reader helps you stay up-
to-the-minute with your favorite blogs and news sites, bringing them all together
on a single page.

• Picasa (http://picasa.google.com). Store, organize, and share digital photos on the
Web with Picasa. Many Google apps let you easily insert a picture—or even a
slideshow—from Picasa.

• SketchUp (http://sketchup.google.com). SketchUp lets you create 3-D models, and
then put them in Google Earth.

• Google Notebook (http://www.google.com/notebook). With Google Notebook,
you can save, organize, and share clips—snippets of interesting Web sites—in an
online notebook as you surf the Web.

• YouTube (http://www.youtube.com). This is the Web’s most popular place to
post, watch, organize, and discuss video clips. You can embed YouTube videos in
Google Sites (page 613).

Want to see what Google’s working on for the future? Check out Google Labs at http://
labs.google.com, Google’s “technology playground.” It’s a place to get a glimpse at up-
and-coming Google products and services that aren’t quite fully cooked.

NOTE
A lot of the products Google offers, including many of the applications covered in
this book, have the word “beta” next to their logos. Normally, programs still in the
beta (testing) stage aren’t released to the public. But Google has a different philoso-
phy: They like to release programs they’re still working on, so people can try them
out and suggest improvements. Google is still actively changing many of the appli-
cations described here, so don’t be surprised if a program looks and acts a bit
differently than what you read in this book.

Individual Applications Versus a Google Apps Account
The hardest thing you ever face about Google Apps could be the decision of what to
sign up for. Should you just use several of the individual applications or the whole
shebang of a Google Apps account? The following scenarios may help you decide:

• You don’t own a domain name—www.MyGreatCompany.com or www.Sa-
vingTheWorld.org—and you don’t want one. You need to be a moderately tech
savvy individual who owns or manages a domain name (and its collection of related
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Web addresses) to create a Google Apps account. Sign up for some individual apps
if you don’t fall into this category.

• Your boss told you you’re switching to Google Apps. If you got a memo saying
everyone will be using Gmail, Google Docs, and Google Calendar from now on,
then your organization has probably already set up a Google Apps account for you,
so you don’t have to choose. All you have to do is sign in and start using the
individual applications. (Read Chapters 2–9 so you can beat everyone else out of
the starting gate.)

• You want to use a Google application (or two or three) for personal stuff. If
you just want to use Google’s services for personal stuff, you don’t need the cen-
tralized domain administration you get with Google Apps. Simply pick and choose
the applications you want, and sign up for them individually. (Start by creating a
free Google Account—Chapter 1 tells you how.)

NOTE
If your company uses Google Apps, you can still create your own Google Account
with a unique user name and password. That way, you can use your company’s
Google Apps account for work, and your personal Google Account for fun.

• You want to use Web-based applications for your business. Google Apps of-
fers businesses a boatload of benefits: a network without the costs of setting it up
and maintaining it, centralized management of all your applications, shared con-
tact lists, and, of course, the applications themselves. Icing on the cake is that all
these offerings get listed at a custom Web address reflecting your organization’s
domain name, such as sites.yourcompany.com for Google Sites or mail.yourcol-
lege.edu for student and staff email.

• You want to create a Web site for a group. Say you want to create a Web site
for your neighborhood association. With a Google Apps account, not only can you
create a Web site, you can also give email accounts to key organizers, and let ev-
eryone create and share documents related to the group’s business—from monthly
meeting agendas to the annual block party. Sign up for Google Apps Standard
Edition (page 484), and you get all that (and more) for free—you just pay for
registering a domain name (page 491), which costs you about 10 bucks a year.

• You’re a student with an email address ending in .edu. Sign up for Google
Apps Team Edition (for free), and you can collaborate with others your school.
The box on page 497 tells you all about Team Edition.

Google Apps and Your Business
With Google Apps, your company can spend less time and less money managing IT
services. Google takes care of all the hassles of handling email, worrying about security,
and holding spam at bay. Google’s own 10,000-plus employees rely on Google Apps
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to keep their business running. And if it’s good enough for Google, it might be good
enough for your firm, too.

Google Apps comes in two main flavors: the Standard Edition and the Premier Edition.
Both offer the same set of applications for your users. The box on page 484 breaks
down the nitty-gritty differences between these two editions, but here’s what it boils
down to:

• Standard Edition. This edition of Google Apps is free. You get all the apps, 6 GB
of storage per person, a control center for administrators, work-anywhere mobility,
and the great collaboration tools that make Google Apps so impressive.

• Premier Edition. This edition of Google Apps costs $50 per user per year. When
you think of what your organization can save in time, licensing fees, hardware and
software maintenance and upgrades, it’s a great deal. Premier Edition offers all the
goodies that come with Standard Edition, plus some extras. Here are the highlights:
25 GB of email storage per person, email migration from your current system, free
phone support, APIs to integrate Google Apps with your current system (including
single sign-on and user provisioning), email policy management and message re-
covery. (See Chapter 12 for the lowdown on all that geekery.)

Not sure? You can try out Premier Edition with a 30-day free trial. If you decide it’s not
what you need, switch over to Standard Edition before the 30 days are up.

What You Need to Get Started
Getting started is easy. Google has designed its applications to be both accessible and
easy to use. It takes only a few seconds to sign up and start using your first program.
You just need a Web browser (the more recent, the better) and an Internet connection.
(Different apps have different browser requirements, so those get covered in the rele-
vant chapters.) Read on to learn the basics you need to set things up.

For Individual Apps: A Google Account
If you’re going to sign up for a few individual applications—or even a whole bunch—
you need a Google Account. Some applications create a Google Account for you as part
of the sign-up process, but it’s a good idea to start by signing up for a Google Account,
because it gives you access to all the apps. Point your Web browser to www.goo-
gle.com/accounts (http://www.google.com/accounts), and then turn to Chapter 1 to sign
up.

For Google Apps for Your Organization: A Google Apps Account
If you’re a domain administrator (that is, you manage the domain name your organi-
zation owns) and you want to use Google Apps for your organization, first you have to
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create a Google Apps account for your domain (see Chapter 10). From there, you can
create accounts for your users, and customize your domain’s apps the way you want
them, as explained in Chapter 11 and Chapter 13.

Browser Requirements
To sign up for a Google Account, your browser has to meet these minimum require-
ments:

• Internet Explorer 5.5 or higher for Windows

• Netscape 7.1 or higher for Windows, Mac, or Linux

• Mozilla 1.4 or higher for Windows, Mac, or Linux

• Firefox 0.8 or higher for Windows, Mac, or Linux

• Safari 1.2.1 or higher for Mac

Each Google app has its own browser requirements, so some of the browsers in this
list may not work with a particular application. Check the chapter devoted to the app
you want to use for more detailed browser requirements.

TIP
To find out which version of a Web browser you’re using, open your browser and,
on its menu bar, click Help→About. (Except for Safari, where you need to click Sa-
fari→About Safari.)

If you’ve got the right browser, you’re nine-tenths of the way there. Just a few other
things to check:

• Make sure you’ve got JavaScript turned on in your browser. JavaScript lets
your browser run programming code that makes Web pages more interactive. (If
you’re not sure whether your browser has JavaScript turned on—most of them do
—see the box on page xxiv.)

• Make sure that your Web browser accepts cookies. We’re not talking chocolate
chip or oatmeal here. Cookies are small text files that Web sites download onto
your computer; they help customize your visits to the sites. (The box on
page xxiv tells you how to set your browser to accept cookies.)

NOTE
If you’re a Mac fan, Google apps work best if you use Mozilla/Firefox as your Web
browser. Not all apps work with Safari or the Mac version of Internet Explorer.
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U P  T O  S P E E D

When Java(Script) and Cookies Don’t Mean a Coffee Break
To use Google apps, you need to have both JavaScript and cookies (page xxiii) enabled
in your Web browser. Your browser probably came with both activated, but it doesn’t
hurt to double-check.

To flick on JavaScript in Internet Explorer version 5.5 or higher, follow these steps:

1. Select Tools→Internet Options.

The Internet Options box opens.

2. Click the Security tab. In the “Security level for this zone” section, click the Custom
Level button.

A Security Settings box opens. This box has a long list of options.

3. Scroll down the list to the Scripting section. Under “Active scripting”, make sure
that Enable is turned on. If it’s not, turn it on. Click OK.

If you changed “Active scripting” from Disable or Prompt to Enable, Internet Ex-
plorer asks if you really want to change its security settings. (If you didn’t make
any changes, you don’t see this confirmation box.)

4. Click Yes.

IE takes you back to the Internet Options box. Click OK to close the box, and then
return to what you were doing. Now you’ve got JavaScript working for you.

For browsers based on Mozilla (these include Firefox 1.6+ and Netscape 7.1+),
you enable or disable JavaScript starting with Edit on the menu bar:

1. Select Edit→Preferences.

The Preferences box opens.

2. In the left-hand Category menu, next to Advanced, click the + sign, and then click
Scripts & Plug-ins.

The Scripts & Plug-ins pane appears.

3. Under “Enable JavaScript for”, make sure that the checkbox next to Navigator is
turned on. If it isn’t, click the box to insert a checkmark, and then click OK.

Congratulations—you’ve enabled JavaScript.

Now for the cookies. Internet Explorer 5 handles these a little differently from IE
6. If you’re working with IE 5.5, follow steps 1 and 2 above for opening the Internet
Explorer Security Settings box. In the Security Settings list (step 3), scroll down to
Cookies. For “Allow cookies that are stored on your computer,” make sure Enable
is turned on. Then continue with step 4.

For IE 6 or later, here’s how to turn on cookies:

1. Select Tools→Internet Options.

The Internet Options box appears.

2. Click the Privacy tab. In the middle of the box, you see a slider that corresponds
to your browser’s cookie settings. Make sure that the slider’s at Medium; if it’s
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not, move the slider to the Medium setting. (This setting lets your computer accept
cookies from Google apps while protecting it from third-party cookies, which
marketers often use to collect information about your Web-surfing habits. Third-
party cookies arrive at your computer from some Web site other than the one
you’re viewing.) Click OK.

IE saves your settings, and then returns you to the Web page you were looking at.

In Mozilla/Firefox, you manage cookies using the aptly named Cookie Manager.
And you do so in one easy step: Surf on over to the app you want. In Mozilla, select
Tools→Cookie Manager→“Allow Cookies from this Site”.

Last but not least: Safari. Go to Safari→Preferences, and then click the Security tab.
Turn on the checkbox next to “Enable JavaScript” and, in the “Accept cookies” section,
select the radio button next to “Only from sites you navigate to”. That’s it. Easy, huh?

About this Book
This book is designed for both the people who use Google’s applications and the ad-
ministrators who manage a Google Apps account. So the first nine chapters tell you
how to set up a personal Google Account (Chapter 1) and get the most out of each app:

• Google Docs:

— Word processing (Chapter 2)

— Spreadsheets (Chapter 3)

— Presentations (Chapter 4)

• Gmail (Chapter 5)

• Google Talk (Chapter 6)

• Google Calendar (Chapter 7)

• iGoogle (Chapter 8)

• Page Creator (Chapter 9)

Whether you’re using these applications for personal projects or through an organiza-
tion’s Google Apps account, you can dip in anywhere and get up to speed fast. Each
chapter offers tips and tricks to get you working in no time.

Chapter 10 through Chapter 12 are all about Google Apps accounts: how to get signed
up and set up (Chapter 10), and how to do the day-to-day administrative tasks that go
with managing a domain (Chapter 11).

Google Sites, a relatively new addition to Google Apps, is available only through Google
Apps accounts, so that’s covered in the later part of the book (Chapter 12), as well.
Whether you’re an admin or a regular user, Chapter 12 tells you how to create, build,
and share a site with others in your organization.
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Chapter 13 talks about stuff you can add to Google Apps to customize it and make it
do more. Whether you’re a business looking to tailor Google Apps to your organization
or a just-for-fun user who wants to write a cool new gadget (page 417), this chapter
gives you the info you need to get started.

Finally, an appendix lists keyboard shortcuts that can help you work with Google apps
faster and more efficiently.

The Very Basics
You’ll find very little jargon or nerd terminology in this book. You will, however, run
across a few terms and concepts that you’ll encounter frequently in your computing life:

• Clicking. This book gives you three kinds of instructions that require you to use
your computer’s mouse or trackpad. To click means to point the arrow cursor at
something on the screen and then—without moving the cursor at all—to press and
release the clicker button on the left side of the mouse (or laptop trackpad). To
right-click means to point the cursor and click the button on the right side of the
mouse (or trackpad); Mac users with only one mouse button can replicate this
maneuver by hitting the Control key while they’re clicking. And to drag means to
move the cursor while pressing the button continuously.

• Menus. The menus are the words at the top of your browser: File, Edit, and so on.
You also find menus within some of the Google applications—they typically ap-
pear near the top of your screen. Click one to make a list of commands appear, as
though they’re written on a window shade you’ve just pulled down.

Some people click and release the mouse button to open a menu, and then, after
reading the menu command choices, click again on the one they want. Other peo-
ple like to hold down the mouse button continuously after the initial click on the
menu title, drag down the list to the desired command, and only then release the
mouse button. Either method works fine.

• Keyboard shortcuts. Every time you take your hand off the keyboard to move the
mouse, you lose time and potentially disrupt your workflow. That’s why many
experienced computer fans use keystroke combinations instead of menu commands
whenever possible. Ctrl+B (⌘-B on a Mac), for example, is a keyboard shortcut for
boldface type in most word processing programs.

When you see a shortcut like Ctrl+Shift (⌘-Shift) (which lets you select a range of
options from a list), it’s telling you to hold down the Ctrl or ⌘ key, and, while it’s
down, press the Shift key, and then release both keys.

About→These→Arrows
Throughout this book, and throughout the Missing Manual series, you’ll find sentences
like this one: “Select File→Export→.csv.” That’s shorthand for a much longer

xxvi | Introduction



instruction that directs you to open three nested commands in sequence, like this: “In
your browser, you’ll find a menu item called File. Click that. On the File menu is an
option called Export; click it to open it. On that menu is yet another option called
“.csv”. Click it to open that, too.” This kind of arrow shorthand helps to simplify the
business of choosing commands in menus, as shown in Figure 2.

About MissingManuals.com
At the Missing Manuals Web site, you’ll find articles, tips, and updates to this book.
In fact, you’re invited and encouraged to submit such corrections and updates yourself.
In an effort to keep the book as up-to-date and accurate as possible, each time we
publish new editions of this book, we’ll make any confirmed corrections you’ve sug-
gested. We’ll also note such changes on the Web site. (Click the book’s name, and then
click the Errata link, to see the changes.)

In the meantime, we’d love to hear your own suggestions for new books in the Missing
Manual line. There’s a place for that on the Web site, too, as well as a place to sign up
for free email notification of new titles in the series.

Figure 2. In this book, arrow notations help to simplify folder and menu instructions. For example,
“Select File→Export→.csv” is a more compact way of explaining the actions shown here than saying,
“From the File menu, select Export. From the submenu that appears, choose .csv.”
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While you’re online, you can also register this book at www.oreilly.com (http://
www.oreilly.com) (you can jump directly to the registration page by going here: http://
tinyurl.com/yo82k3). Registering means we can send you updates about this book, in-
cluding any additions or Web-only offerings.

Safari-Enabled
When you see a Safari®-enabled icon on the cover of your favorite technology book,
that means the book is available online through the O’Reilly Network Safari Bookshelf.

Safari offers a solution that’s better than e-Books. It’s a virtual library that lets you easily
search thousands of top tech books, cut and paste code samples, download chapters,
and find quick answers when you need the most accurate, current information. Try it
free at http://safari.oreilly.com.
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PART I

Docs: Google's Productivity Suite

• Chapter 1, Getting Started with Google Apps

• Chapter 2, Word Processing with Google Docs

• Chapter 3, Working with Docs Spreadsheets

• Chapter 4, Creating Slideshow Presentations





CHAPTER 1

Getting Started with Google Apps

A Google Account is your passport to the Google apps universe. It gives you a way to
sign in just once and access all of Google’s goodies. It’s also where you add new pro-
grams, change your name or password, and do other across-the-board management.
And here’s the best part: A Google Account is free. As in totally, completely, won’t-
cost-you-a-dime free.

If you’ve created an account for any Google offering—like Gmail, Google Docs, or
Google Calendar—you’ve already got a Google Account. So you can skip the section
on signing up and turn to page 9 to learn more about what you can do with your
account.

On the other hand, maybe you’ve made it well into the 21st Century without a Google
Account, thank you very much. If that’s the case, your time has come: You need an
account to use Gmail, Google Docs, Google Calendar, and many other Google tools.
In addition, when you’re signed into your Google Account, you can customize your
apps, check out recommendations made just for you, and get even better search results.
This chapter shows you how to get started.

NOTE
The bulk of this chapter addresses the boring but necessary sign-up procedures re-
quired to uncork the Google apps magic. If you’ve already got a Google Account, or
consider account sign-up guidance a crutch needed only by lesser mortals, feel free
to skip ahead to Chapter 2, where the heart of the Google apps coverage begins.

Signing Up for a Google Account
It takes only a couple of minutes—you can pop a celebratory pizza in the microwave
and be done before the timer dings. Then, as you munch on a slice or two, you just
have to pick which programs you want to use, and add a bit of personal info.
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NOTE
If you use Google Apps through your organization—for example, if you sign into
Gmail with a user name that looks like myname@mycompany.com—you don’t need
to create a separate Google Account. Your organization creates and manages your
apps through its own Web site. (See Chapter 10 for more information about Google
Apps for organizations.)

Start by going to Google’s home page (http://www.google.com) and, in the upper-right
corner, click the link that says, “Sign in”. Alternatively, you can go straight to the Google
Accounts sign-in page at http://www.google.com/accounts.

Whichever route you take, the Google Accounts sign-in page looks like Figure 1-1.
After you’ve opened your account, you’ll see this page again whenever you want to sign
in and use your Google services. For now, though, click the right-hand “Create an
account now” link, and you’re taken to the page shown in Figure 1-2.

Figure 1-1. Clicking the “Sign in” link on Google’s home page takes you here. The left-hand side of
the page tempts you with various programs you can use once you sign up. The right-hand side is where
you’ll sign into the Google Account you’re about to create. To get started, click “Create an account
now” (circled).
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TIP
If you have questions about Google Accounts before (or even after) you sign up, more
help awaits at www.google.com/support/accounts (http://www.google.com/support/
accounts).

Google’s sign-up form is simple; you can fill it out and start using your new Google
Account in mere seconds. Here’s what’s on it:

• Your current email address. Type in the email address you use right now, like
johndoe@yahoo.com or janesmith@mycompany.com. (After you’ve read Chap-
ter 5, you’ll probably want to switch to Gmail, but you can open a Google Account
using any working email address.)

Figure 1-2. Here’s the page you fill out to create a new account. It asks for pretty basic info: You
supply an email address, a password, and your country, and then fill out the spam-preventing word
verification box (you can’t see it here) and agree to Google’s terms of service (see the box on
page 38).
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• Choose a password. Your Google Account password has to be at least eight
characters long and can contain letters, numbers, and symbols. See the box below
for tips on creating a good password.

• Re-enter password. Nothing is more annoying than locking yourself out because
you entered a typo when creating your password—and now you have no clue what
the password is. To make sure that doesn’t happen, retype your password here
(don’t copy and paste it from the box above—that’ll just duplicate any typos).

W O R D  T O  T H E  W I S E

Password Primer
Since your Google Account is the central sign-in for all your Google apps (meaning you
use the same user name and password for everything), you want to make sure that your
password is extra secure so no one can get into your email, calendar, and personal
documents in one fell swoop. So put a bit of thought into selecting your password. Here
are some ways to make your password tough to crack:

• Go for a little variety. You probably already have a bunch of different passwords
for a bunch of different purposes: email, online shopping, sites like Facebook, and
so on. Instead of recycling one of those passwords, create a brand-new one just for
your Google Account. That way, if somebody learns your Facebook password, for
example, your Google Account is still secure.

• Avoid the obvious. Don’t make your user name (page 10) double as your pass-
word. Similarly, don’t use googleapps, googleaccount, or password as your pass-
word. Those words might be easy for you to remember, but they’re just as easy for
someone else to guess.

• Think outside the dictionary. Don’t use a word that appears in the dictionary
(English or any other language). Instead, use a combination of letters, numbers,
and symbols. One way to create a password that’s easy for you to remember but
hard for someone else to guess is to substitute numbers or symbols for letters they
resemble. For example, instead of stanford, try st@nf0rd. And, for heaven’s sake,
don’t use the word “password” in any form.

• Combine upper- and lowercase letters. When it comes to your password, Goo-
gle distinguishes between capital letters and lowercase ones. Use this to your
advantage: go with LuCKygiRl instead of luckygirl.

• Go big. Google requires that your password be at least eight characters long—and
that’s a good start. The longer a password is, the harder it is to guess. So add a few
more characters beyond the minimum eight to make your password even more
secure.
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• Remember me on this computer. If you’re setting up your account on a computer
nobody else uses, turn on this checkbox to save a little sign-in time. Google re-
sponds by automatically filling in your login info every time you visit the sign-in
screen. But if you’re on a shared computer (at a public library, for example), leave
this box turned off so no one else can get into your account.

• Enable Web History. When you’re signed in to your Google Account, Web His-
tory keeps track of your searches as you wander around the Web. When you sign
up, Google turns it on by default, and that means you can take a look back at sites
you’ve visited, search them, and get personalized Search results based on your
history. Since you can access your Web History from any computer with an Internet
connection, it’s like having a permanently handy record of all the searches you’ve
ever done. The box on page 8 has more about Web History to help you decide
whether you want it in your Google Account.

• Location. From the drop-down list, choose your country.

• Word verification. You may have seen similar combinations of wavy, skewed
letters (and sometimes numbers) on other Web pages. Word verification makes
sure you’re a real, live person, not an automated “bot” that crawls the Web and
signs up for accounts to use for spamming and other nefarious purposes. Take a
look at those wavy letters, filter them through your human brain, and type them
into the box (capitalization doesn’t matter).

• Terms of Service. You’ve got to agree to Google’s terms of service if you want to
open an account. Give them a quick read, or check out the box on page 38 for
the highlights.

When you’ve filled everything out, give the page a quick once-over to make sure it all
looks good. Then click “I accept. Create my account.” Google sends you a verification
email like the one in Figure 1-3. Click the link in the email and your account is up and
running. (If clicking the link doesn’t do anything, copy the link and paste it into your
browser’s address bar.) Your browser opens a page that says Google has verified your
account. From here, click the link to go to your brand-new Google Account.

NOTE
Don’t reply to the verification email. If you do, your email will get lost in cyberspace,
since nobody at Google looks at or replies to these verification emails. Instead, look
for answers at the Google Accounts Help page: www.google.com/support/ac-
counts (http://www.google.com/support/accounts). Better yet, keep reading this book.
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F R E Q U E N T L Y  A S K E D  Q U E S T I O N

Google Web History
What exactly is Web History—and do I want to be a part of it?

When you sign up for a Google Account, the registration form gives you the option to
turn off Google Web History. Google obviously likes Web History—it’s automatically
turned on. But what is Web History? And will you like it as much as Google does?

When you’re signed into your Google Account, Web History tracks your searches as
you zoom around the Web. By tracking and remembering what you searched, Web
History lets you easily find Web pages you’ve visited. You can also search across sites
in your Web History, for those times when you just know you saw a great recipe for
hazelnut torte but can’t for the life of you remember where. Web History also uses this
track record to personalize your Google search results. Based on the searches you’ve
done, Google returns results that will most likely interest you. So if you go to a lot of
cooking sites, for example, recipes will get ranked higher in your search results than
news stories.

The info stored in your Web History record offers a nice trend tracker when it comes
to your own Web usage. For example, Web History highlights the sites you visit most
often and makes it easy to view your own personal top searches.

Figure 1-3. Google sends you a verification email like this one to make sure you’re not a spam bot.
To complete the sign-up process, click the link (circled), or copy and paste it into your Web browser’s
address bar. Make sure you do one or the other—Google won’t set up your account until you verify
your email address.
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So what’s the catch? Maybe there isn’t one—it all depends on how jealously you guard
your privacy. To track your Web History, Google stores all that information on its own
computers. Google insists it takes your privacy seriously: The only way to view your
Web History is to sign into your account. You can also temporarily stop tracking your
online movements by pausing your Web History (from your Google Account page,
select Web History→Pause), and you can remove sites and searches from this digital
popcorn trail by going to Web History→Remove items.

In sum, Web History can be a handy tool. But if you’re uncomfortable having Google
follow you around the Web, you probably shouldn’t turn it on. If Web History is turned
on, and you decide you want to make it history, then follow the steps for deleting a
Google app on page 18.

If the verification email doesn’t show up (it can take mere seconds, but give it at least 
15 minutes before going to Plan B), you’ve got a few options:

• Check your spam folder. Whatever your email provider calls it—Spam, Junk,
Bulk Mail—it’s possible your Google Accounts verification email landed there by
mistake.

• Tell your spam filter Google’s cool. If the verification email isn’t in your spam
folder, it may have been blocked by your overzealous spam filter. To make sure
the verification email gets through, add this address to your address book:
accounts-noreply@google.com.

• Request another verification email. If you can’t find the verification anywhere
in your email program, point your browser to www.google.com/accounts (http://
www.google.com/accounts) and try to sign in anyway. The Account Verification
Page appears, where you see a message like this: “To have the verification email
resent, click here.” Click the link to have Google send another verification email.

• Start from square one. Everyone makes mistakes. You may have mistyped your
email address when you signed up. Try again, following the instructions on
page 4. (And this time, triple-check to make sure you haven’t made any typos on
the Create an Account page.)

You’re All Signed Up—Now What?
You can sign into your new Google Account by going to Google’s home page and
clicking the upper-right “Sign in” link, or by going to www.google.com/accounts
(http://www.google.com/accounts). Just enter the email address you used to create the
account, along with your password, and then click the “Sign in” button.
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NOTE
If you already have Gmail, you can sign into your Google Account with your Gmail 
user name, which is the part of your Gmail address that comes before @gmail.com.
So if your Gmail address is janedoe@gmail.com, your user name is janedoe.

The first time you sign in, you see a page that looks something like Figure 1-4.

At the top of the page, Google displays the email address or user name you used to sign
in. (You can change your email address or user name by editing your personal infor-
mation; see page 11.)

Figure 1-4. Your Google Account page is split into three sections. On the left, Personal Information
lets you view and edit the info associated with your account (flip to page 12 for the lowdown on
managing these details). On the right, under the “My services” heading, Google shows which programs
you’re currently signed up for. Below that, under “Try something new”, is a list of other Google
products you can sign up for—just click a link to get started. The links in the upper-right (circled) let
you jump to different parts of your account, get help, or sign out.
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NOTE
You can have more than one Google Account—for example, maybe you want one
Gmail address for work and another for personal stuff—but Google lets you sign into
only one account at a time.

The links in the top-right part of the page help you find your way around your Google
Account:

• Google Home. Click this link to go to the familiar Google search page (www.goo-
gle.com).

• Help. Lost? Confused? Got a quick question? Clicking Help takes you to the Goo-
gle Accounts Help page, which covers all the ins and outs of using your account.

NOTE
Where the Help link takes you depends on the Google app you’re using when you
click it. If you’re using Gmail, for example, it takes you to the Gmail Help page. To
get to Google Accounts Help, click the Help link while you’re on the page pictured
in Figure 1-4, or go to www.google.com/support/accounts (http://www.google.com/
support/accounts).

• My Account. Clicking this link brings you back to the page shown in Figure 1-4.

• Sign Out. When you’re ready to say buh-bye to Google apps, click this link.

The rest of your Google Account page is divided into three sections:

• Personal information. Here’s the info you gave Google when signing up for your
account. To manage these details—to change your name, say—click the Edit link.
You also get links for changing your email address and password.

• My services. This section lists Google apps for which you’re currently signed up.
Click the name of any program to launch it, or click Edit to delete a program
(page 18) or close your account (page 18).

• Try something new. In this section, Google tempts you with any offerings you
haven’t signed up for—yet. If you’re ready to take the plunge, click the name of
whatever you’re interested in. Click the More link to see the whole smorgasbord
of Google products and services you can choose among.

T R O U B L E S H O O T I N G  M O M E N T

Help—I Can’t Get into My Account!
Since your Google Account is the central sign-in for all the Google apps you use, if
you’re shut out of your Google Account, you’re shut out of everything. If you’re having
trouble signing in, click the “I cannot access my account” link at the bottom of the sign-
in box to get help. On the page that appears, click one of these links:
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• I forgot my password. When you click this link, Google asks for the email address
you signed up with (or your Gmail user name, if you have one, in case you supplied
the optional secondary email address when you signed up for Gmail). Google
shoots off an email to that address with a link you can click to reset your password.

• I forgot my username. If you’re a Gmail user, Google asks for the secondary email
address you provided when creating your Gmail account; it then sends you a re-
minder email. (Providing a secondary address is optional when creating an ac-
count, so if you didn’t provide one, you’re out of luck.)

Maybe you have multiple email accounts and can’t remember which one you used.
Click the “I forgot my password” link, and then try providing all your email addresses,
one by one. Then check each email account—one of them should have the email that
lets you reset your password.

Managing Your Google Account
Sooner or later you’re going to want to modify your Google Account settings—do
things like add a back-up email address, specify your time zone, start using a new
program, and so on. This section tells you how to manage your account so it meets
your needs.

Edit Your Account Information
As you probably noticed when signing up, Google doesn’t ask for a lot of personal info
to create an account. But what if you want your account to be a little more personalized?
Say you prefer to be greeted by name (rather than by email address) on your Google
Account page. No problem. Just head over to “Personal information” section of the
Google Account page (Figure 1-4) and click its Edit link. The page shown in Fig-
ure 1-5 appears.

Edit personal information

Things change with time: A wedding or divorce changes your name, or you move to a
different Zip code, time zone, or even country. Use this section to add or change any
of the following (optional) settings:

• First name

• Last name

• Nickname

• Zip code

• Country
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• Time zone (The drop-down menu here shows time zones based on your location.
To change the list to show all the world’s time zones, turn on the “Display all
timezones” checkbox.)

Associate email addresses with your account

You need just one email address to open your Google Account, but you can associate
other addresses with it, too. This can come in handy, for instance, when someone
invites you to an event they’ve created on their Google Calendar (Chapter 7)—which-
ever email address the other person uses for the invitation (maybe they’ve got that old
alumni address you occasionally use), you can respond.

When you type an address into the “Add an additional email address” text box, and
then click Save, Google fires off a verification email. As soon as you click the verification
link, Google adds the address to your account.

Figure 1-5. Use this form to change the personal info in your Google Account. All the stuff gathered
here is optional—you don’t have to add your name, but your Google apps might feel more like “yours”
if you do.
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NOTE
If you’ve got a separate Gmail account, you can’t add that address to this Google
Account. Why not? That Gmail address already has a Google Account of its own, as
the Note on page 14 explains.

If you change your mind and want to remove an additional email address from your
Google account, just come back to this page, find the account you want to ax, and then
click its Remove link.

NOTE
The email address you provided when you opened your Google Account is the ac-
count’s primary email address. If you need to change your primary email address,
check out the next section.

Change your email address

To change your primary email address, start on your Google Account page (www.goo-
gle.com/accounts (http://www.google.com/accounts)). In the “Personal information”
section, click the “Change email” link.

NOTE
If you originally opened your Google Account by signing up for Gmail (instead of,
say, following the instructions in “Signing Up” on page 3), you don’t see a “Change
email” link, because you automatically get a Google Account with your Gmail ac-
count. However, if you want to get rid of Gmail (see page 18 for how to delete an
application) without having to set up all your other apps from square one, you can
associate your Google Account with a different email address, and then delete Gmail,
leaving your other apps untouched.

Google takes you to the page shown in Figure 1-6, which is actually a little confusing.
It shows your account’s primary email address in the box labeled “Your current email
address”. So far, so good. But this is also the box where you type the email address
you’re changing to, even though nothing on the page indicates that. In the box below
it, type your Google Account password, and then click “Save email address”.

Google sends you a verification email to the address you entered. Zip over to your other
email account and check your inbox. Open the verification email, click the link in it,
and you’re done.

When Google sends the verification email to your new address, it also sends a notifi-
cation to your old address, a nice security feature that helps prevent someone from
hijacking your account. If you are indeed changing your primary email address, just
ignore the notification. If, however, the notification arrives out of the blue, click the

14 | Chapter 1: Getting Started with Google Apps

http://www.google.com/accounts
http://www.google.com/accounts
http://www.google.com/accounts


link it contains. That takes you to the Google Accounts Help center, where you can fill
out a form to contact Google and get the problem straightened out.

After you’ve changed the primary email address, use the new address as your user name
the next time you sign in. Google doesn’t recognize the old one anymore.

Change your password

Security experts recommend changing your password every once in a while to make
sure no one else gets their mitts on it. If you’re the type who actually follows that (sound)
advice, head to your Google Account page (www.google.com/accounts (http://
www.google.com/accounts)) and click the “Change password” link. Google opens the
“Change password” page, shown in Figure 1-7.

On the “Change password” page, in the “Current password” box, type your current
password (the one you’re getting rid of). Below it, in the “New password” box, type
your shiny new password. To guard against typos, type it again in the “Confirm new
password” box. Click Save, and your new password takes effect. Don’t forget it! (But
if you do, check out the box on page 11.)

TIP
For suggestions on what makes a good password, see the box on page 6.

Type in your NEW email
address here

Figure 1-6. On the “Edit email address” page, the address you currently use to sign into your Google
Account appears in the box. Replace that address with the new one, and then, in the Password box,
type your Google Account password (not the password for the email address you entered).
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For Gmail users: Change your security question

If you started using Gmail before you discovered you even had a Google Account, you
don’t see a “Change email” link in the “Personal information” section. Gmail users
can’t change the primary email address for their Google Accounts. Instead, you see a
“Change security question” link; it’s your way of protecting yourself when you acci-
dentally blog about, say, your first teacher’s name. Clicking the link takes you to the
page shown in Figure 1-8.

Google uses your security question to verify your identity if you forget your Gmail
password. To change your security question, type your password in the box that asks
for it. Click the Security Question drop-down menu to see a list of Google’s suggested
questions. (You can also write your own; select “Write your own question from the
list” and Google adds another text box where you can type your question.) Next, answer
the question so Google can check it against future attempts. If you want to add a sec-
ondary email address to your Google Account (helpful if you forget your user name),
you can also do that here. When you’re done, click Save.

Add a Google App
If you’ve created your account by following the instructions on page 3 (as opposed to
creating the account by default when you signed up Gmail or Google Calendar), you
may not have any programs in your account to start with. No problem: Your account
page gives you easy access to Google’s offerings. They appear in the “Try something

Figure 1-7. As you type your new password, Google gauges its strength for you (circled) by testing it
against known password-stealing strategies (like entering every word in the dictionary, for instance).
The stronger the password, the more secure your Google Account.
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new” section of your Google Account page (www.google.com/accounts (http://
www.google.com/accounts)).

Don’t see the program you want? At the bottom-right of the page, click the More link
to see the full list. You have literally dozens to choose from, some of which you’re
probably already familiar with: Google Maps, Google News, Google Earth, YouTube,
Picasa (a photo-editing and sharing site), and many more.

To start using a program, click the name of the item you want. You may have to provide
Google with a little info—like a user name and security question/answer if you want
to sign up for Gmail—but this takes only a minute or two.

F R E Q U E N T L Y  A S K E D  Q U E S T I O N

Your Google Account and Gmail
I signed up for a Google Account. Does that mean I have Gmail, too?

Not necessarily. If you opened a Gmail account before you had a Google Account,
Google automatically provides you with a Google Account—you can sign into it at
www.google.com/accounts (http://www.google.com/accounts) or reach it through the
Accounts tab of Gmail’s Settings page (Settings→Accounts tab→“Google Account set-
tings”). But the process doesn’t work the other way around: When you open a new
Google Account, you don’t automatically get a Gmail address—but that’s easy to fix.

Just sign into your Google Account page at http://www.google.com/accounts, and then,
in the “Try something new” section, click Gmail. (If you don’t see it there, click More,
and then, on the page that opens, look for the Gmail link. Or just head straight to http://
www.gmail.com.)

Figure 1-8. When you sign up for Gmail, you have to provide a security question and answer. If you
want, you can change those here.
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Gmail asks you to answer a couple of questions before it creates your new account—
a name to go in front of @gmail.com, a security question, and so on. When you open
a new Gmail account in this manner, your Gmail address becomes the account’s pri-
mary email address, and the email address you originally used to open the account
becomes a secondary address.

Launch a Google App
When you start using Google apps, you’ll probably go directly to the home page of the
program you want to use, like http://docs.google.com for Google Docs,
www.gmail.com (http://www.gmail.com) for Gmail, and so on. But if you’re on your
Google Account page (www.google.com/accounts (http://www.google.com/accounts))
and you want to leap from there to one of your apps, just look in the “My services”
section. Find the program you want to use, click its name, and off you go.

Delete a Google App
Once you have a Google Account, it’s so easy to add programs that you’re likely to try
out a whole bunch. If you find that, later on, one or two of them don’t meet your needs
or you don’t use them all that much, it’s easy to prune things down with just a click or
two. You can delete Gmail, Browser Sync, Web History, Orkut, and Google Video from
your Google Account.

First, go to your Google Account page and click the Edit link next to “My services”;
the page shown in Figure 1-9 appears.

Each item in the “Delete a Service” section is a link. Find whatever you want to get rid
of, and click its name.

The page you see next is tailored to the particular program you chose to delete, but
whichever page you see, it has two main purposes:

• To explain any consequences of deleting the service (for example, if you delete
Gmail, you’ll no longer be able to use it, duh, to send and receive email, and all
your mail will be permanently deleted).

• To get confirmation from you that, yes, you really want to delete the service.

Close Your Google Account
Google apps are so well designed, simple to use, and convenient to access that you
probably won’t ever want to get rid of your Google Account. But if for some reason
that time does come, vaporizing your account (and all your apps with it) starts with a
visit to the Google Account page (www.google.com/accounts (http://www.google.com/
accounts)).
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In your “My services” section, click the Edit link, and then click “Close account and
delete all services and info associated with it”. Google makes that link extra descriptive
so you know exactly what’ll happen if you choose to proceed to the next page, Delete
Google Account (Figure 1-10).

Google wants to make really, really sure you don’t accidentally delete a Google app.
So on the Delete Google Account page, it lists all the services associated with your
account. You have to look at them all and turn on each checkbox, one by one, before
you can delete the account.

NOTE
Closing your account just means that you won’t be able to use the Google goodies
listed on the Delete Google Account page—stuff that requires an account. But you
can still read Google News, watch YouTube videos, check out Google Maps, and so
on.

Google also wants to make sure you understand that, if you owe Google money, can-
celing the account doesn’t cancel your debt. (Most Google apps are free. But you can,
for example, buy extra storage space for Gmail.)

If you’re still sure you want to delete your account, enter your password into the “Cur-
rent password” box. Then turn on the two checkboxes that confirm you want to delete
the account and that, if you owe Google money, you’ll still pay. (If you don’t owe
Google any money—and chances are you don’t—you still need to turn on that

Figure 1-9. If you want to delete an application from your account, select from the “Delete a Service”
list. If you want to close your Google Account (and all your Google apps), click the bottom link.
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checkbox to cancel the account.) Finally, click the Delete Google Account button.
That’s it—your Google Account is history.

The Google Toolbar
Even though you don’t need a Google Account to download the Google Toolbar, it’s
good to learn about it early on because the Toolbar can supercharge your account and
make managing it a breeze. The Google Toolbar, shown in Figure 1-11, is a customiz-
able toolbar that rides piggyback on a Web browser and puts your favorite Google apps
—and more—right at your fingertips.

There are several different versions of the Toolbar floating around. The version you
have depends on the browser you use, and when you installed the Toolbar. Versions
covered here include Toolbar 4 and 5 for Internet Explorer, and Toolbar 2 and 3 for
Firefox.

Figure 1-10. To make sure you know what you’re losing when you close your Google Account, Google
lists everything associated with your account. If you want to preserve one or two items on the list,
click Cancel and see the previous section to learn how to delete individual programs without closing
your account.
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NOTE
Google Toolbar has oodles of features, some of which aren’t covered here. Because
this book is about Google apps, this section focuses on the parts of the Toolbar you
can use to make working with Google apps faster, easier, and more efficient; specif-
ically, using the Toolbar with Gmail, Google Docs, Google Calendar, and your
Google Account. To find out everything you can do with the Toolbar, visit http://
www.google.com/support/toolbar.

Before you get started, make sure you have the right equipment for using the Toolbar.
Here’s what you need:

• To use Google Toolbar with Firefox:

— Operating system: Windows 2000 or XP, Mac OS X version 10.2 or higher, or
Linux.

— Web browser: Firefox version 1.5 or higher.

• To use Google Toolbar with Internet Explorer:

— Operating system: Windows 2000, XP, or Vista.

— Web browser: Internet Explorer version 6.0 or higher.

TIP
Sorry Mac fans: The Google Toolbar doesn’t work with Safari. To get Firefox, or to
upgrade to the latest and greatest version, go to www.firefox.com (http://www.fire
fox.com), and then click the big green Download Firefox–Free button. To install or
upgrade Internet Explorer, surf over to Microsoft’s Download Center at www.mi-
crosoft.com/downloads (http://www.microsoft.com/downloads).

Google Toolbar

Figure 1-11. Your Web browser tucks the Google Toolbar right below the address bar.
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Downloading and Installing the Toolbar
Getting Google Toolbar onto your computer takes only a few minutes. From your
Google Account page (www.google.com/accounts (http://www.google.com/accounts)),
look for Google Toolbar under “Try something new”. If you don’t see it there, click
the More link, and then, on the page that opens, click Toolbar. Alternatively, point
your Web browser to http://toolbar.google.com.

If you’re not on your Google Account page (or if you haven’t opened a Google Account
yet), go to the Google home page (www.google.com (http://www.google.com)), click
the “more” link at the top of the page, and then click “even more”. On the page that
opens, scroll down till you see the Toolbar link, and then click it.

NOTE
This section describes the steps for downloading the Toolbar to use with Firefox. If
you’re downloading the Toolbar for Internet Explorer, the process is similar.

The Google Toolbar page (Figure 1-12) is where you download the Toolbar to your
computer. Just follow these steps:

1. Click the big, blue Download Google Toolbar button—you can’t miss it.

Google shows you the Toolbar privacy policy. Read the box on page 38 for the
highlights, so you know what you’re agreeing to.

2. If you’re fine with the terms, click “Agree and Install”.

Your computer may open a window telling you that a Web site is trying to down-
load software to your computer, and asking for your okay.

3. Click Install.

Your computer downloads the files you need to install the Toolbar.

4. After the download is complete, quit your Web browser, and then launch it again.

When your browser reopens, you see the welcome message shown in Figure 1-13.

TIP
If your browser doesn’t work quite right after you reopen it, restart your computer,
and then fire up your Web browser again.

5. You have some decisions to make before you start using the Toolbar. In the wel-
come message window, you can adjust these settings:

• Select your search site. Choose the country you reside in. This tells Google
which of its dozens of international search sites you want to use.
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• Use Google as my default search engine. If you want Google to be your de-
fault search engine, leave this checkbox turned on. If you prefer another search
engine, turn it off.

• Allow downloads from Google. Leaving this checkbox turned on means that
Google will periodically (and automatically) update your new Toolbar. If you
want the latest and greatest improvements to the Toolbar without having to lift
a finger, leave it on. If you’d prefer not to have Google mess around with your
Toolbar without your knowledge, turn it off.

• Enable/Disable PageRank and Enhanced Safe Browsing. The PageRank 
button gauges a Web page’s popularity, based on things like how many other
pages link to it. When you enable PageRank, the Toolbar sends the Web ad-
dresses of pages you visit back to Google, so that Google can rank them for you.
Similarly, Enhanced Safe Browsing warns you about iffy Web pages—again, by
sending Web addresses to Google so it can check them out. (Google may log
suspicious Web addresses.) Some people are uncomfortable sending this infor-
mation to Google; if you’re one of them, turn on the “Disable PageRank and
Enhanced Safe Browsing” radio button. If you want to use these services with
the Toolbar, turn on the Enable radio button.

Figure 1-12. Google’s Toolbar page gives you an idea of what you can do with the Toolbar. Click
the “View all features” link (circled) to find out some of the cool things the Toolbar can do: Send
Web pages to your friends, show how Google ranks the page you’re viewing, block pop-ups, and
more. If you’re ready to take the plunge, click Download Google Toolbar.
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• Usage statistics. If you turn on this checkbox, then you automatically share
certain info with Google: whether the Toolbar installed successfully, how well
the Toolbar works as you use it, and how often you use the buttons on the
Toolbar. Google doesn’t collect your name, your email address, or the addresses
of Web pages you look at. Again, though, some folks like to maximize their
privacy. If you don’t feel like sharing information about how you use the Tool-
bar, leave this checkbox turned off.

When you’ve made your choices, click Finish.

You can start using the Toolbar right away. Read on to learn how you can customize
it to include the buttons you use most.

Customize the Toolbar
Now that you’ve installed Google Toolbar, you can use it to make your Web browsing
speedier. This section gives you an overview of what’s on the Toolbar and how you can
tweak it to work harder for you.

Figure 1-13. After you’ve successfully downloaded and installed the Toolbar, you see this box
the first time you restart your Web browser. Take the time to read it, because it explains how
Google may use the info it collects as you surf the Web with your new Toolbar.
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TIP
To learn all the ins and outs of what the Toolbar can do, visit Google’s Toolbar Help
Center at http://www.google.com/support/toolbar. Once there, click the tab for the
browser you use: Internet Explorer or Firefox.

What’s on the Toolbar

The Google Toolbar arrives in your browser with a standard set of buttons (Fig-
ure 1-14). These might vary a bit, depending on your Web browser and the selections
you made in the welcome message window (Figure 1-13).

NOTE
The Google Toolbars for Firefox and Internet Explorer are slightly different, with
different sets of standard buttons. Figure 1-11 shows Toolbar 5 installed in Internet
Explorer 6, so you can compare it with the Firefox version shown in Figure 1-14.
Some of the differences: the Google Toolbar for IE has a pop-up blocker/unblocker,
a spell checker, and a button that shows CNN news headlines among the standard
buttons it displays.

Here’s a brief rundown of the standard buttons for Firefox and what they do:

• Enhanced Search box. Why “enhanced”? Two reasons: As you type in a search
term, Google guesses what you might be looking for and offers suggestions (it also
remembers what you’ve typed, in case you want to find that term again). And when
you click the Search button’s down arrow, you have your choice of where to search.

Enhanced search box Resize search box

Google News

Find/manage bookmarks
Add bookmark

Spell checking

Autolink
Subscribe to the contents
of this page

Autofill Send contents of this
page to Gmail/Blogger

Highlight

Add buttons

Click to see more buttons

Change
settings

Figure 1-14. The standard buttons on the Google Toolbar for Firefox. If you’ve installed the Toolbar
for Internet Explorer, it looks slightly different.
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Select a search type, and the icon on the Search button changes to show which of
these you’re using:

— Google Search

— Search within a particular country

— Search within the current Web site only

— I’m feeling lucky (takes you straight to Google’s top result for your term)

— Search Google Images

— Search Google Groups

— Search Google News

— Search Froogle (now called Google Product Search—less witty, perhaps, but
certainly more descriptive) to compare prices on items you want to buy.

— Search Google Maps

— Search your Google Bookmarks

— Search the Google Button Gallery. (Find new buttons to add to your Toolbar,
in categories such as News, Tools, and Fun & Games. For example, you can
add a button that shows you the current top stories on CNN and takes you to
CNN.com (http://www.cnn.com) with one click.)

— Search your Gmail account

• Resize Search box. Click this line and hold down your mouse button, and then
drag it to the left or right to make the Search box smaller or larger.

TIP
Making the Search box a little smaller lets the Toolbar display more buttons.

• Google News. Click this button, and your browser whisks you straight to Google
News, where you can read current headlines and search for news articles.

• Gmail. Get one-click access to your Gmail inbox, as well as notification of new
messages (page 32 tells you all about using this button).

• Free online dictionary. Need to look up a word? Highlight the word, and then
click the button that looks like a blue book. You whiz right over to dictionary.ref-
erence.com (http://dictionary.reference.com) to find out what it means.

• Add buttons. As page 28 explains, you can customize your Toolbar by adding
and removing buttons. Click this button to see a list of Google-suggested buttons,
such as Google Blog Search and a Dictionary button, to make your surfing even
more efficient.

• Bookmark this page. Click the star to add the current Web page to your Google
Bookmarks (a list of shortcuts to favorite Web sites). Google Bookmarks stores
your bookmarks in your Google Account, not in your browser, so you can access
them from anywhere you have an Internet connection. Sign into your Google
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Account. If you have Web History (page 8) turned on, then Google stores your
bookmarks there. You can also add a Bookmarks gadget to your iGoogle page
(Chapter 8).

TIP
The Bookmark button also lets you import your existing Firefox bookmarks or IE
favorites all with one click, so you can keep track of them in your Google Account,
not just in your Web browser.

• Find/manage Google Bookmarks. Use this button to add or remove a book-
mark, organize existing bookmarks, or import bookmarks from your Web browser.

NOTE
You need to be signed in to your Google Account to use Google Bookmarks. (You
can sign in right from the Toolbar.)

• AutoLink. This button recognizes and links to certain kinds of information, such
as street addresses, package tracking numbers, and publishers’ ISBN numbers (for
books). For example, if you’re looking at a restaurant’s Web page, AutoLink de-
tects its address and creates a link to a map page, showing you exactly where the
restaurant is.

• AutoFill. This button can save you some typing when you fill out forms on the
Web. If you click this button, up pops a form where you fill in personal info like
your name, address, and phone number. Then, when you visit a Web page that
has a form asking for this information, one click of this button fills it in for you.

TIP
For step-by-step instructions on using AutoFill, visit the Google Toolbar Help Center:
www.google.com/support/toolbar (http://www.google.com/support/toolbar).

• Send to. When you click this button, Google sends the page—or the part of the
page you’ve selected by dragging your cursor—to one of these three places (you
choose):

— Gmail. Use Gmail to send the page or selection to yourself or someone else.

— Blogger. If you have a Blogger account, this button sends the page or selection
to that account, using it as the start of a new blog entry.

— SMS. This option sends the page or selection as a text message to the cellphone
number you specify.

• Highlighting. When you use the Toolbar to do a search, click this button, and
Google highlights your search term wherever it appears on the page. Click the
button again to turn highlighting off.
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• More arrow. If you have a lot of buttons on your Toolbar, some may be hidden
(you can fit only so many buttons across the width of a computer screen). Click
this arrow to see any buttons not currently on display.

• Settings. Click this button to sign into or out of your Google Account, add or
remove buttons (see the next section), change the Toolbar’s layout, report a sus-
picious Web site, or get help using the Toolbar.

Add a button

Google’s Button Gallery contains dozens of buttons you can use to customize your
Toolbar. To add a new button, click Add Buttons (shown in Figure 1-14) or the down
arrow next to it. Clicking the down arrow presents a short list of Google-related buttons
you can add (Google Blog Search or Stock Search, for instance). Clicking the button
itself takes you to the Google Toolbar Button Gallery, shown in Figure 1-15. In the
Button Gallery, you can browse within categories or search for a specific word or phrase.
When you find a button you want to add, simply click “Add to Toolbar”—it’s that easy.

Browse button categories here.

Figure 1-15. The Button Gallery offers a wealth of specialized toolbar buttons for every interest. To
browse within a category, choose one from the left-hand menu. Or use the Search box (circled) to find
buttons related to a particular word or phrase (like career or travel). The top five most-added buttons
appear in the box on the right. When you find a button you want to add to your Toolbar, click its
“Add to Toolbar” button (also circled).
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TIP
When you select a button from the Button Gallery to add to your Toolbar, Google
flags any potential privacy concerns you should be aware of. For example, a button
might send information about your search to Google. If a button’s a little too nosy
for your liking, don’t add it.

Move a button

You can move buttons around on the Toolbar, if you like. Go to the Buttons tab of the
Toolbar Options box (Settings→Options→Buttons), shown in Figure 1-16. In the “Cus-
tom buttons” section, click to select the button you want to move, and then click the
Move Up or Move Down buttons to rearrange your Toolbar. (If the Move Up or Move
Down button stays grayed-out, it means you can’t move the button you’ve chosen in
that direction.) When you’ve moved the buttons to where you want them, click OK.

Figure 1-16. The top part of the Google Toolbar Options box shows a set of Google buttons you can
add to (or remove from) your Toolbar. The bottom part shows custom buttons. If a checkbox is turned
on, the button’s on your Toolbar; turn on checkboxes for any buttons you want to add. To move a
button, click it in the “Custom Buttons” window, and then use the lower-right Move Up/Move Down
buttons (circled). If you decide you want your buttons the way they were when you downloaded the
Toolbar, click Restore Defaults (also circled).
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NOTE
If you’re using Toolbar 5 and Internet Explorer, instead of Settings→Options, use the
Toolbar Options button (which looks like a little wrench) to open the Toolbar
Options box.

Remove a button

As you adorn your Toolbar with custom buttons, you may find there are some buttons
you don’t use a whole lot. You can most quickly remove a button from your Google
Toolbar by right-clicking (control-clicking on a Mac) the Toolbar, and then selecting
Customize to open the Customize Toolbar dialog box.

What you do next depends on whether you use Firefox or Internet Explorer. In Firefox,
drag buttons off the Toolbar and into the Customize Toolbar dialog box (you may have
to move the box so you can see your whole Toolbar). In Internet Explorer, select a
button in the dialog box, and then click Remove to take it off the Toolbar.

Alternatively, you can remove a button from the Toolbar via the Toolbar’s own settings.
To get rid of a button that way, follow these steps:

1. On the far right of the Toolbar, click Settings→Options. (If you use Toolbar 5 for
Internet Explorer, click the Toolbar Options button.)

Google opens the Google Toolbar Options box.

2. Click the Buttons tab.

The Buttons tab (Figure 1-16) shows all the buttons you currently have on your
Toolbar. If a button’s checkbox is turned on, it’s on the Toolbar.

3. Turn off the checkbox next to any button you want to get rid of (you can always
come back to this box and turn it on again later). Click OK.

The button disappears from your Toolbar.

Delete a button

When you follow the steps for removing a button, the Google Toolbar doesn’t display
the button any more, but the button is still hanging around so you can turn it back on.
To delete a custom button from the Toolbar entirely, head to the Buttons tab of the
Toolbar Options box (Settings→Options→Button tab). Next, select the button you
want to delete by clicking its name. Then click the right-hand Remove button, and the
button is gone, gone, gone.

If you have a change of heart and want the button back, simply follow the steps to add
a button (page 28).
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Using the Google Toolbar with Google Apps
As you browse the Button Gallery, you probably notice a number of buttons related to
Google apps. Added to your Toolbar, these buttons let you navigate to any Google app
with just a click—and do a whole lot more. This section describes some ways to use
the Toolbar with Google apps.

Google Accounts

Wherever you are on the Web, you can sign into your Google Account through the
Toolbar. Click the far-right Settings button→Sign In, and enter your email address (or
Gmail user name) and password. If you’re signed in, then the Settings button lets you
sign out (Settings→Sign Out).

Google Docs

If you use the Firefox version of Google Toolbar, you can use the Docs feature to open
files in Google Docs (Chapter 2 and Chapter 3). With this feature turned on, if you’re
on a Web page and you click a link to open a file, then it opens in Google Docs. Dragging
a file icon—like a Word document’s piece of paper icon—into a browser window also
opens that file in Google Docs. (If you use Windows, double-clicking the icon in Win-
dows Explorer does the same thing.)

NOTE
The Docs feature doesn’t add a button to your Toolbar. Instead, it works quietly
behind the scenes, so you can easily open files in Google Docs.

You turn on the Docs feature from the Features tab of the Toolbar Options box (Set-
tings→Options→Features, or Toolbar Options→Features if you use Toolbar 5 for
Internet Explorer), shown in Figure 1-17.

To start using the Docs feature, turn on the Docs & Spreadsheets checkbox. If you want
to specify which files open in Google Docs, click the File Settings button to open the
Files Settings box, shown in Figure 1-18. Google Docs can open files with any of these
extensions: .doc, .xls, .sxw, .odt, .ods, .rtf, and .csv. (These formats are common word
processing and spreadsheet formats.) Turn off the checkboxes next to any file types
you don’t want to open in Google Docs, and specify how you want to open them. You
can:

• Drag a file’s icon into your browser.

• Click a link to a file on a Web page.

• Double-click a file icon. (This works only in Windows.)

When you’ve got things how you want them, click OK, and then, in the Toolbar Op-
tions box, click OK again.
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Gmail

If you use Gmail, the Toolbar can keep you up to speed with what’s in your inbox as
you surf the Web. Here’s what the Toolbar’s Gmail button lets you do:

• Get notified of new Gmail messages. The Gmail button gives you a peek into
your Gmail inbox without having to leave the Web page you’re on. When you’re
surfing the Web and you get a new email, the Gmail button lets you know by
changing its icon from a closed envelope to an open one. Click the button’s down
arrow to see a list of the unread messages in your inbox, as shown in Figure 1-19.
Select a message to open it in a new window. From there, you can reply to the
message or go to your Gmail inbox.

• Send emails from Gmail. Say you’re looking at a Web page, and you click an
“Email us” link—but your browser opens an email program that’s not Gmail to

Figure 1-17. Turn on the Docs & Spreadsheets checkbox (circled) to make documents open in Google
Docs. To fine-tune this feature, click the File Settings button.
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send the message. You can set your Gmail Toolbar so that mailto links automati-
cally open Gmail. In Firefox, head to the Toolbar Options box’s More tab
(Settings→Options→More), shown in Figure 1-20. In the Page Tools section, turn
on the “Send with Gmail” checkbox, and then click OK to make it official. (If you’re
using Toolbar 5 for Internet Explorer, click the wrench icon to open the Options

Figure 1-18. The File Settings box lets you control which kinds of files Google Docs opens
automatically, and what steps you need to take to open those files.

Gmail button Unread Inbox messages

Figure 1-19. The Gmail button gives you one-click access to your Gmail account. Click the Gmail
icon to go to Gmail, or click the button’s down arrow to see the subject lines of any unread
messages in your inbox. If you want to read a message on the list, click it, and Google opens it
in a new window.
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window. From there, click the Tools tab, turn on the “Send to” checkbox, and then
click Save.) Now, when you click a mailto link, a Gmail window opens so you can
compose your message.

Google Calendar

If you use Google Calendar (Chapter 7) to keep your crazy schedule running smoothly,
you can work with Calendar straight from the Google Toolbar. Go to the Button Gallery
(page 28), search for Google Calendar to find the button—Figure 1-21 shows what it
looks like—and then add it to the Toolbar (see page 28). After you’ve got the button
on your Toolbar, click it to go straight to Google Calendar. (If you’re not already signed
in to your Google Account, you can sign in on the way.)

You can do a few other nifty things with the Google Calendar button on your Toolbar:

• See upcoming events. Click the button’s drop-down arrow to see a list of the next
10 events on your calendar (see Figure 1-21). Click an event to see or edit its details.

• Add an event to your calendar. Type the details of an event (date, time, occasion,
and so on) into the Toolbar’s Search box, and then click the Google Calendar

Figure 1-20. Make Gmail the automatic choice for sending emails by turning on the “Send with Gmail”
checkbox (circled).
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button. You’re whisked off to the form for creating a new Calendar event
(page 354), with the info you typed already filled in.

• Use a Web site to create a new event on your calendar. When you add the
Calendar button to your Toolbar, you can get a head start in creating events for
your Calendar. Say you’re looking at the Web site of a conference you plan to
attend. You can copy info straight from the site, and use it to create an event in
your calendar. Select the text you want to use, and then right-click (if you’re on a
Mac with a one-button mouse, control-click). From the shortcut menu (shown in
Figure 1-22), choose “Send to”→Google Calendar. Your browser takes you right
to Google Calendar’s form for creating a new event (page 354), with the text you
selected already filled in. Edit the info (if necessary), and then click Save Changes
to put the event on your calendar.

Removing the Google Toolbar
Some people have so many toolbars cluttering up their browsers that there’s hardly any
room left for Web pages. If you find the Google Toolbar useful but don’t want it at the
top of your screen all the time, you have a couple of options: You can hide the Toolbar
or edit it to make it more compact. Or, if you’ve given the Toolbar a test drive and you
decide it’s not for you, you can easily uninstall it.

Hide the Toolbar

You can hide the Toolbar so it doesn’t show up in your Web browser, and then pull it
up whenever you need it. To hide a toolbar in Firefox or Internet Explorer 6 or earlier,
select View→Toolbars to see a list of toolbars in your browser. If there’s a checkmark
next to Google Toolbar, the Toolbar is visible. Select Google Toolbar to remove the

Google Calendar button

Figure 1-21. Click the Google Calendar button’s drop-down arrow to see upcoming events (up to 10)
scheduled in the Calendar. Click an event to edit it in Google Calendar.
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checkmark and hide the Toolbar. When you want to show the Toolbar again, just
repeat the process to toggle the Toolbar back on: View→Toolbars→Google Toolbar.

NOTE
If you use Internet Explorer 7, there’s no menu bar from which to select View. Instead,
use the right-hand Tools button (Tools→Toolbars→Google Toolbar) to hide or show
the Toolbar.

Edit the Toolbar’s layout

The Toolbar Options box lets you tweak the layout of your Toolbar to save space. On
the Toolbar, click Settings→Options→Layouts tab to open the dialog box shown in
Figure 1-23. (If you’re using Toolbar 5 for Internet Explorer 7, click the Toolbar Options
button—the one that looks like a wrench—and then Layouts.)

In the Layouts tab, you can make the Toolbar more compact by turning on “Replace
[Firefox/Internet Explorer] search box and hide Toolbar” (the exact wording depends
on you browser). This option gives you the power of Google-enhanced searching with-
out all those other buttons crowding your screen. When you need one of those buttons,
just click the drop-down arrow next to the G beside the Google search box. In the menu
that pops up, click Show Google Toolbar.

Select text related to an event…
… then right-click to send the info to
Google Calendar.

Figure 1-22. Save yourself some typing (and make sure you get the details right) by sending info from
a Web page straight to Google Calendar.
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If you decide you want to restore the full Toolbar, go back to the Layouts tab and turn
on the “Classic Toolbar layout” radio button.

Uninstall the Toolbar

If you want to remove the Toolbar from your computer, you can take one of several
routes:

• Uninstall using the Toolbar itself. This method should work no matter what
browser or operating system you use. Go to Settings→Help→Uninstall. (If you’re
using Toolbar 5 for Internet Explorer, click the arrow on the Toolbar Options
button, and then Uninstall.) A new window opens, warning you that you’re about
to remove the Toolbar from your computer for good. The window has a text box
where you can tell the folks at Google why you decided not to stick with the Toolbar
(it’s optional). Click “Uninstall the Google Toolbar”, and it’s gone.

• Uninstall using Firefox. If you use Firefox as your browser, you can use Firefox’s
uninstall procedure to get rid of the Toolbar. Open a Firefox browser window, and
then click Tools→“Add ons” (for Firefox 2) or Extensions (for earlier versions of
Firefox). A window opens, showing programs you’ve added to Firefox. Select
“Google Toolbar for Firefox,” and then click the Uninstall button. Close Firefox
(if you have multiple windows open, then make sure you close them all); the next
time you fire it up, the Google Toolbar will be gone.

• Uninstall using the Windows Control Panel. To uninstall Google Toolbar’s
Internet Explorer version using the Control Panel, select Start→Settings→Control
Panel. In the Control Panel window, double-click “Add or Remove Programs”.

Figure 1-23. The Layouts tab is where you decide how much of the Google Toolbar to show or hide.
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Windows opens the “Add or Remove Programs” window and fills it with a list of
programs you have installed on your computer. Find and select “Google Toolbar
for IE”, and then click the Remove button.

U P  T O  S P E E D

The Legal Lowdown
Whenever you download software or sign up for a service, you’re responsible for un-
derstanding the terms and policies you’re agreeing to. That might sound like a lecture
from your dad, but it’s true. When you create your Google Account, you may be excited
to get started using everything it offers, but it’s worth taking a few minutes to under-
stand what you’re agreeing to.

You can read Google’s Terms of Service (ToS) and Privacy Policy by clicking the ap-
propriate link at the bottom of your Google Account page. This box describes some of
the highlights—to get the full scoop, go to www.google.com/accounts/tos (http://
www.google.com/accounts/tos) to read Google’s Terms of Service, or go to www.goo-
gle.com/privacypolicy.html (http://www.google.com/privacypolicy.html) for its privacy
policy.

Google’s Terms of Service emphasize the following points (remember—you agree to
all of them when you open your account):

• Opening a Google Account and using the services Google provides is a legal agree-
ment between you and Google, a contract in which you agree to abide by the terms
Google specifies. Bad online behavior (basically, anything that violates the ToS)
will get you kicked off Google.

• You’re responsible not only for your behavior when you use your Google Account
(and any associated services) but also for any content you upload. Google takes
no responsibility for your content, so if you upload iffy or illegal content, like
plagiarized text or child pornography, it’s your problem, not Google’s.

• Google reserves the right to change or even discontinue any service it offers. In
addition, it makes no promises about the availability or reliability of its services.
(Generally, Google’s availability and reliability are both outstanding, but if some-
thing goes wrong and you can’t access your Google Account, you can’t sue.)

• You agree not to copy, sell, or redistribute any Google service—unless you some-
how manage to get Google’s permission to do so. Also, if you gain access to any
confidential Google info, you agree not to divulge it.

• You can end your legal agreement with Google at any time by closing your Google
Account (and all its related services).

Google’s privacy policy centers on these issues:

• Google collects information from you in three ways:

— Personal info you provide when you sign up for a Google account or service.

— Information about Web pages you visit, which it does using cookies. A cookie
is a small file that holds a string of characters and is created on your computer
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when you visit a Web site. When you return to that Web site again, the cookie
lets the site recognize your browser. Cookies often store user preferences and
other info about you.

— Information that Google gathers automatically when you visit Google or one
of its services’ sites. This includes the Web address you visit, your IP address
(your computer’s address on the Internet), the type of browser you’re using,
and the date and time.

• Google uses the information it collects:

— To provide you with customized content.

— For its own analysis and research, to improve the services it offers.

— To share with third parties. If Google shares your info with third parties, it
generally groups lots of people’s info together and doesn’t identify you person-
ally. Google sometimes uses third parties to process personal information, but
does so only if the third party complies with Google’s privacy policy.

— In very rare circumstances (like if you’ve broken a law or are threatening Goo-
gle’s security), Google may turn over your personal info to a third party, such
as police investigating a crime.

• You can decide not to divulge personal information, but that might mean you can’t
use a particular service.

• You can disable cookies in your Web browser, but if you do, some Google pages
or services may not work properly.

Google is very up front about privacy issues. For services where privacy is a concern,
such as Web History (page 8) or the Google Toolbar (page 20), Google puts a link to
a specialized Privacy page right from that service’s Help page. So if you have any ques-
tions about, say, Google Calendar, you can get specific answers.
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CHAPTER 2

Word Processing with Google Docs

Ask people who work with Google Docs what they love about it (besides the price),
and two words will crop up pretty fast: “accessibility” and “collaboration.”

In Google Docs—a Microsoft Office–like collection of word processing, spreadsheet,
and slideshow presentation tools—your documents are stored on Google’s computers,
so you can access them from anywhere with an Internet connection. No more smacking
your forehead because the report or spreadsheet you meant to bring home is sitting on
your office computer’s hard drive, or worrying about where you might’ve lost that
keychain-sized flash drive that holds all your important files. No matter where you are,
as long as you can get online, you can edit, format, save, and otherwise work on all the
files in your Google Docs account. You can even edit word processed documents off-
line, and upload them automatically the next time you connect to the Internet.

But what makes Google Docs truly revolutionary is the way it lets you collaborate with
others on a single document in real time. No more sitting around twiddling your
thumbs, waiting for your turn as a file gets passed from person to person for editing
and revisions. With Google Docs, up to 10 people can edit the same document simul-
taneously, redefining the whole concept of working together.

NOTE
Because there’s just so darn much you can do with Google Docs, this book devotes
three chapters to it. This chapter explains how to get your Google Docs account up
and running, and then discusses word processing. Chapter 3 covers spreadsheets,
and Chapter 4 looks at presentations, a relatively new addition to the Google Docs
arsenal.

Before You Start: Browser Requirements
Google Docs works on Windows, Macintosh, and Linux computers. To make sure
Google Docs works the way it’s supposed to on your computer, use one of these Web
browsers:
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• Internet Explorer 6 or higher for Windows

• Firefox 1.07 or higher (At this writing, Google Docs doesn’t work with the beta
version of Firefox 3 that’s available for testers.)

• Mozilla 1.7.12 or higher

• Netscape 7.2 or higher

If you use one of the following browsers, you’ll probably run into trouble trying to use
Google Docs (or it may not work at all):

• Safari

• Internet Explorer on a Mac

• Opera

• Netscape 4

TIP
Not sure what version your Web browser is? Open the browser, and then click
Help→About to find out. You can download the latest version of Firefox at www.fire-
fox.com (http://www.firefox.com); for Internet Explorer, go to www.microsoft.com/
ie (http://www.microsoft.com/ie). Both browsers are free.

Welcome to Google Docs: A Quick Tour
If you’re the proud owner of a Google Account, you can add Docs to your Google
empire in a jiffy. Go to the Google Docs sign-in page (www.docs.google.com (http://
www.docs.google.com)), and then enter your Google Account user name and password.
Google adds Docs to your account, and takes you straight to the Google Docs work-
space (Figure 2-1). (If you don’t yet have an account, flip back to Chapter 1 for full
details on how to sign up.)

TIP
If you’re signed into your Google Account page (www.google.com/accounts (http://
www.google.com/accounts)), then you can add Docs from there. Look for Docs in the
“Try something new” section. (If you don’t see it, click the More link, and then, on
the page that opens, find Docs.) Click the Docs link and you’re off to the races.

If You’re Invited to Collaborate
You can get invited to view or collaborate on a document even if you haven’t signed
up for Google Docs. If you get an email from Google telling you that someone’s inviting
you to share a document, then click the link in the message.
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If you have a Google Account and you’re already signed in, then Google opens a new
window displaying the document you’ve been invited to share, and you can get to work
on it right away.

If you’re not signed into your Google Account, or if you don’t yet have one, a new
browser window opens, showing a version of the shared document that you can read
but not edit. At the top of the page, you see links where you can sign into your account
or create one:

• Sign in. Click this link to sign into your Google Account. When you do, Google
takes you to your Google Account page. From here, you can click the Docs link to
go to the Google Docs home page, where the shared document is already in your
Docs list.

• Create an account. Click this link, and then follow the instructions for creating
a Google Account on page 3. Google also asks for your first and last names so it
can create your Docs account. When you’ve verified your email address (page 7),
Google creates your account and takes you to your new Google Account page.
Click Docs, and the shared document is sitting there in your Docs list, waiting to
greet you. Click it to get to work.

When you create or upload new documents,
they appear in a list here.

Figure 2-1. The first time you sign into your Google Docs account, you see a page like this one. From
here, you can create a new file or upload an existing one from your computer. The circled buttons get
you started working with documents. When you create or upload a document, it appears in the Docs
list in the center of the page.
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NOTE
What you can do with an invitation depends on the kind of invite you receive. If your
pal asks you to collaborate on a Google doc, then you need a Google Account to jump
in and start editing. If you’re invited just to view a Google doc, then you can see it
even if you don’t have a Google Account (page 93 explains the difference between
collaborating and viewing privileges).

The Google Docs Home Page
When you sign into Google Docs, you land on a page like the one back in Figure 2-1,
where you can manage all your Google Docs files. Once you’ve added a few files, the
Docs home page lists them in the center of the page, as you can see in Figure 2-2. Click
a file’s name to open it in a new window.

Your Docs list occupies the biggest part of the Google Docs home page. The list shows
the most recent files at the top—if you open a file, edit it a bit, and then save it, that
file jumps to the top of the list. But you can order the list in other ways, too, which
might help you find a document even faster. Click the bar just above the Docs list to
sort files in any of the following ways:

These buttons let you work with one or more files in the Docs list.

This menu specifies what to
show in the Docs list.

The Docs list shows your
Google Docs files.

Figure 2-2. On the Google Docs home page, you create or upload new files, and manage existing ones.
The choice you make in the left-hand menu controls which files appear in the Docs list (all your docs,
just your spreadsheets, and so on), while the buttons across the top let you manage your files by doing
things like uploading, sharing, and deleting. Click a file’s name to read or edit it in a new window.
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• Starred documents. You can assign stars to flag important files (details on
page 107). Click the little star button to group starred and unstarred items sepa-
rately. If the arrow is pointing down, then Google lists all starred items at the top;
unstarred items follow. If you want to reverse the order, then click the star again.

• Name. Click Name to display files in alphabetical order. If the Name arrow is
pointing up, files are from A–Z; if the arrow’s pointing down, they’re listed from
Z–A.

• Folders/Sharing. In Docs, folders are a lot like the folders you create in Windows
or on a Mac to hold your files. Because Docs files live on the Web, though, folders
don’t contain the actual documents; they hold links to documents—click a link to
open a document. This column shows two things: whether a folder holds a docu-
ment, and whether you’re sharing the document with someone else. (If it’s a shared
file, the column shows the name of the person you’re sharing with; if it’s yours
alone, the column just says “me”.) Click Folders/Sharing to sort shared documents
alphabetically by the document owners’ names. (A document owner is usually the
person who created the document—but not always; see page 78.)

TIP
To see all the files in a particular folder, choose the folder from the left-hand menu
(you might have to click the + sign next to “All folders” to expand that section). This
changes the Docs list to show only files in that folder. Then you can sort those files
as you like.

• Date. Click Date to display your documents by the date you (or someone you’re
sharing the file with) last opened the file. If the arrow points down, the most recent
files appear on top; an up arrow means the oldest files are on top.

The menu bar above the Docs list is your command center for managing Google Docs
files. You can do a lot here:

• Create a new document. Click the New button to whip up a new file. When you
do, a drop-down file-type list appears:

— Document. See page 51 for more about creating documents.

— Spreadsheet. Chapter 3 has the skinny on creating and working with spread-
sheets.

— Presentation. Chapter 4 covers slideshow-style presentations.

— Folder. Google Docs lets you create folders to store and organize related docu-
ments. See page 105 for tips on keeping your Docs organized.

• Upload an existing document. Click the Upload button to transfer a document
from your computer to Google Docs (page 52 has step-by-step instructions).

• Share a document. Turn on the checkbox next to a particular document’s name,
and then click Share to invite somebody else to collaborate on it (or just view it
without making changes); page 86 explains the details of sharing documents.
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• Move a document. If you’ve created folders to organize your documents, you can
put a document into a folder. Select the file you want to move by turning on its
checkbox, click the Move button, and then select the folder where you want to put
the file.

NOTE
Google Docs documents live on the Web; each one has its own unique address. So
when you move a document to a folder, what you’re actually doing is creating a link
to the document and storing that link in the folder. Moving a document places a
copy of a document’s link in the folder you choose; it doesn’t remove the link to that
document from your Docs list. If you don’t want to see a document in the Docs list,
hide it (see page 107).

• Hide a document. You can hide documents so they don’t appear in your Docs
list. This can be helpful, for example, when you have a document you’re not actively
working on but don’t want to trash. Select the file (or files) you want to hide, and
then click the Hide button to make it (or them) disappear. For more on hiding files
(and finding them again), see page 107.

• Delete a document. To move a document to the Trash folder, select it by turning
on its checkbox, and then click this button. See page 77 for the ins and outs of
deleting Google Docs files.

• Rename a document. To give a file a different name, turn on the checkbox next
to the file you want to rename, and then click the Rename button. The file’s name
turns into a text box where you can type a new name.

• More actions. When you turn on a file’s checkbox, and then click “More actions”,
a list appears so you can select what you want to do with the file. What’s on the
list depends on the kind of file you’ve chosen. For word processing documents,
here are your choices:

— Manage sharing. Select this action to open a window that shows you current
sharing info—who’s got permission to view and collaborate on this document,
if anyone—and lets you set sharing permissions, and invite others to share the
document. See page 86 to read all about sharing your documents.

— Publish. You can also share a document by publishing it, either as a Web page
or a blog entry; page 88 explains how to publish documents you create in Docs.

— Preview. Select this option to see how your document will look when it’s pub-
lished on the Web (page 88).

— Revisions. Each time you make a change to a file (or even just open it to take
a look), Docs saves a separate version of it. Choose this item to see a list of all
the different versions, which you can view or compare (as page 102 explains).

— Save as [file type]. You’ve got a bunch of options when you want to save a
document outside Google Docs: HTML, Word (.doc), OpenOffice (.odt),
PDF (viewable in Adobe Reader—page 76), RTF (rich text format, which

46 | Chapter 2: Word Processing with Google Docs



preserves formatting you’ve added), and plain-vanilla Text (which doesn’t pre-
serve formatting). When you select one of these options, Docs downloads the
file to your computer in the format you chose.

As you create or add new documents, the Docs list can get pretty long. To limit what
the list displays, make a selection from the left-hand menu:

• All items. The usual setting, showing you all items in your Docs list. Click the +
sign next to “All items” to select a smaller grouping of your files:

— Created by me. Shows all files that you’ve created in—or uploaded to—Google
Docs.

— Opened by me. Shows files you’ve viewed.

— Starred. You can flag important files with a star. If you choose this option, then
your main Docs list displays only the starred files in your Google Docs account
(whether you marked them that way or a sharing partner did).

— Hidden. If you’ve hidden a file (page 107), view it by choosing this option.

— Trash. When you delete a file, it lands in this folder. If you accidentally delete
a file, then you can find it here, and undelete it (see page 77).

• All folders. If you’ve created any folders (page 107) to help organize your docu-
ments, they appear in this section (you may have to click the + sign to see them).

• Items by type. Google Docs handles documents, spreadsheets, and presentations.
You can display only those files belonging to a particular type by making a choice
here (click the + sign to see the different file types).

• Shared with. If you’re collaborating with people on a document (page 86), you
can find their names here (you might need to click the + sign to see them). So, for
example, if you’re looking for a report you’re working on with Debbie, select Deb-
bie’s name. The Docs list displays only those documents that you and Debbie share.

Customize Your Setup with Google Docs Settings
Once you open your Google Docs account, you can start creating or uploading docu-
ments. But it’s worth taking a minute to check out your account settings. For example,
make sure Docs knows what time zone you’re in—especially important if you’re col-
laborating with others spread across the country or around the world.

Start by clicking the upper-right Settings link (next to the email address associated with
your account). This gets you to the page shown in Figure 2-3.

The General Tab
Here’s a potpourri of miscellaneous settings you can adjust to make Google Docs even
easier to work with:
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• Language. This setting doesn’t translate your docs from, say, English to Turkish
or Swedish or Chinese (or vice versa). Instead, it controls how Google Docs talks
to you. In other words, it tells Google Docs which language to use for all the but-
tons, commands, and menu items it displays. You’ve got a couple dozen languages
to choose from.

• Your current time zone. Choose a time zone from the list. If you’re using Google
Docs on the road, then you can change time zones as you travel.

• Right-to-left. If you write documents in Hebrew or Arabic, you know that people
read and write those languages from right to left, instead of the left-to-right flow
of words that English and many other languages use. Turning on this checkbox
gets you a right-to-left button in your document composition window, which you
can click to make text start at the right side of the page, moving left as you type.

• Display name. When you collaborate with others on a document, this setting
determines how your name appears to them.

• Blog settings. Google Docs, it turns out, is also a great blog editing tool. But before
you can edit your blog posts, you need to let Google know about some of your
blog’s settings. Start by clicking the “edit info...” link. This takes you to the Blog
Site Settings window shown in Figure 2-4, which asks for your blog’s address and

Figure 2-3. Click the Settings link (circled) to jump to the Settings page’s General tab, where you can
adjust things like the language Google uses to communicate with you (as well as the flavor of your
built-in dictionary), your time zone, and how your name appears to collaborators.

48 | Chapter 2: Word Processing with Google Docs



login info. Optionally, you can include the document’s title as the name of your
blog post, if your blogging service can handle this feature (not all of them can—
check with your blogging service to find out).

TIP
To learn how to publish documents on your blog, flip ahead to page 90.

• Old Writely Documents. Before Google Docs, there was Writely, an online word
processing program that hit the Web in 2005. In 2006, Google bought the company
that created Writely, and combined its word processor with Google’s own online
spreadsheet program. If you used Writely before Google bought it, you may have
some old Writely documents hanging around. In that case, click the “move old
documents” link. Google guides you through a two-step process that brings docu-
ments from your old Writely account over to your new Google Docs account.

• Google Account settings. Click the link here to open a new window showing
your Google Account page (page 10). You can change your password or manage
your Google Account without leaving Google Docs. How’s that for convenient?

When your settings are all set, remember to click Save to make ’em stick.

Figure 2-4. Google Docs give you an easy way to compose and publish entries on your blog. If
you use a service like Blogger or Live Journal, choose it from the Provider drop-down list. If you
host your own blog or use a blog service not on the list, then turn on the “My own server/custom”
radio button, and the section expands so you can give Google the server’s Web address. To make
it so you can post to your blog from Google Docs, give Google your login information and the
title of your blog. Click the Test button (circled) to see if Google can find your blog with the
settings you’ve provided.
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The RSS Feeds Tab
Depending on whom you ask, RSS stands for rich site summary or really simple syndi-
cation—take your pick. Whichever you prefer, RSS feeds let you subscribe to your
favorite Web sites (news sites, blogs, and so on), alerting you when new content ap-
pears, and providing links to the full story or blog post.

Most people use RSS to keep up with the mountains of online reading that interests
them. But Google Docs has its own special RSS twist, and a mighty helpful one if you
spend lots of time collaborating with others: You can subscribe to a feed that lets you
know when a shared document has been edited. To flick this tool on, head to the RSS
Feeds tab (Settings→RSS Feeds), shown in Figure 2-5. After you’ve adjusted the settings
here, you can subscribe to feeds for individual Google documents (see page 101).

Google gives you a few different ways to work with RSS feeds:

• Private documents in public feeds. This is where you turn on RSS feeds for your
documents. When your do so, others can see your documents’ titles, as well as
who made changes and when. It also means you can subscribe to a Google Docs
feed (page 101) right on your Firefox Bookmarks toolbar or in your Internet Ex-
plorer Feeds. To turn on RSS feeds, click the “change setting” link. A confirmation

Figure 2-5. Looking for a great change notification tool? Activate RSS feeds for your Google Docs by
clicking the “change setting” link (circled), and then confirm that you want to allow feeds. Then click
the Save button at the bottom of the page (also circled).
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dialog box pops up; click OK. (If you change your mind and want to turn off RSS
feeds, come back to this page, click “change settings” again, and then OK, to toggle
feeds off.)

• Active Documents. Click the “view feed” link in this section to see a list of recent
changes to your docs.

• Individual Documents. There’s nothing for you to do in this section. It just ex-
plains how to see an individual document’s feed. (Read all about that on
page 101.)

• Tagged Documents. In summer 2007, Google Docs replaced tags (kinda like
Gmail’s labels [page 262]) with folders as a way to organize your documents. As
of this writing, this section hadn’t quite caught up with the change.

If you change any settings on this page, remember to click the Save button when you’re
done.

Getting Your Docs into Google
At last, you’re ready to create and save your first document. And if you’ve got existing
documents sitting on your computer that you’re eager to move into Google Docs, this
section shows you how to do that, too.

Creating a New Document
To create a brand-new document in Google Docs, start on the main Google Docs page
shown back in Figure 2-1. Above the Docs list, on the left side of the blue bar, click
New→Document. A new window like the one in Figure 2-6 opens. This is the Google
Docs text editor, your home base for creating and editing word processing documents.
All you have to do is start typing.

Formatting toolbar

Figure 2-6. The Google Docs text editor is where you work on your documents-in-progress. The
formatting buttons in the toolbar let you format your text as you write. Use the right-hand Share
button to invite others to collaborate on your document or publish it as a Web page or blog post.
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TIP
See the section “Working with Text” (page 58) to learn about formatting your
whole document and formatting smaller chunks of text as you type.

Importing an Existing Document
Chances are you’ve got some documents you’d like to transfer from your computer to
Google Docs. You’ve got a few different ways to do that, all explained in the following
sections (including details on what types of documents Google Docs can work with).
Once they’re there, you can work with those files from any computer that’s got an
Internet connection.

Use the Google Docs home page

The Google Docs home page (shown back in Figure 2-2) has an Upload button above
the Docs list, in the blue bar. Click it to open the “Upload a File” page shown in
Figure 2-7.

It takes just a few steps to upload your document:

Figure 2-7. Use the top half of this page to upload a document by telling Google Docs where to find
it on your computer or the Web. If you’d rather email the document to your Google Docs account,
use the ginormous email address in the bottom half of the page. When you email a document, you can
send it either as text inside the email or as an attachment.
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1. Tell Docs where to find the file you want to upload.

If the file is on your computer, click Browse, locate the file, and then click Open.
If the file lives somewhere on the Internet, then enter its Web address. (The surest
way to do this is to open a browser window that contains the document, copy the
URL, and then paste it into Docs.)

2. Give your file a name (optional).

If you want to call the file something different from its current file name, then type
the new name here.

TIP
You can always change a file’s name from the Docs list. Select the file, click Rename,
and then type in the new name.

3. Click Upload File.

Google Docs uploads your file, and adds it to your Docs list.

There are some limitations to uploading documents into your Docs account:

• The file must be 500 KB or smaller. If it’s bigger than that, break it up into several
smaller files and upload those.

• The file must be one of these types: text (.txt), rich text (.rtf), HTML (.html
or .htm), Microsoft Word (.doc), OpenOffice (.odt), or StarOffice (.sxw).

Email a document to Google Docs

Emailing files is a fast, simple way to get documents into your Docs account. When
you click the Upload button to get to the page shown in Figure 2-7, the bottom half of
the page displays an email address that’s just for your account.

The email address Google assigns your Docs account is about a zillion characters long,
which makes it hard for others to guess—but also impossible for you to remember. The
simplest thing to do is add the address to your Gmail Contacts list (page 273). That
way, Gmail memorizes the address for you, making it easy to find and preventing some
serious brain strain. (Gmail can handle attachments up to 20 MB in size.)

Send an email to that address, and Docs creates a document from the email—whether
your text is in the body of the email or in an attached document. To upload several
documents at once, attach them all to one email, and Docs creates a separate file for
each attachment. Docs can handle up to 10 attachments at a time.

NOTE
An attached document trumps text in the body of an email—if you send an email
that contains both, then Docs adds only the attachment to your Docs list.
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When Docs receives an emailed file, you get a confirmation email in return, letting you
know the document made it. (Docs sends this confirmation to your registered email
account—see page 5.) If you don’t get a confirmation, Docs didn’t get the file, so try
sending it again.

Upload in bulk

At this writing, Google Docs doesn’t offer any way for you to move a big group of
documents from your computer to your Docs account. You can only upload as many
documents as you can attach to a single email, as explained above, which can be time-
consuming—especially if you have hundreds of files you want to get into Google Docs.

A couple of third-party developers have come up with ways to solve this problem:

• Document List Uploader. This little program lets you transfer multiple files to
Google Docs all at once. Select your files, and then drag them into the Uploader.
Uploader takes over from there, getting your files into Google Docs. You can
download the Windows-only Document List Uploader for free by going to http://
google-gdata.googlecode.com/files/DocListUploader-1.1.exe.

• DocSyncer. This is a terrific idea that, at this writing, is still undergoing testing.
Not only does DocSyncer upload in bulk to your Google Docs account, it keeps
Google Docs in sync with your word processor. So when you’re working on a
document, for example, DocSyncer watches your documents for changes and
makes sure your word processor and your Google docs are in sync—automatically.
It also lets you view all previous versions of a document and backs up your work
automatically. And you can double-click a file on your Desktop and open it in
Google Docs. To find out more, visit http://www.docsyncer.com.

Saving a Document
One of the great things about using Google Docs is that you may never again have to
worry about saving a document. Google saves your work automatically every couple
of minutes, and stores each saved version in the Revisions list (page 102). And if you
click the Docs Home link or sign out of Google Docs, then Docs saves your work before
it does anything else. Docs is fanatical about capturing and storing every change you
make.

If you want, you can save even more often than Docs already does. You have four ways
to save a document:

• Click the upper-left Save button (the one with a picture of a floppy disk).

• Also in the upper left, select File→Save.

• Click the upper-right Save button.

• If you’re done with the document for now, in the upper right, click “Save & close”.
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Docs saves the file, and adds this version to its Revisions list (page 102). You can also
save a copy of your document or download it to your computer, as explained next.

Saving a copy

You can save an exact copy of a presentation as a new file, which can be helpful if, for
example, you want to use a document’s format or outline as a starting point for a new
document. Or you might want to save your own, private snapshot of a shared
document.

To save a copy, open the document you want to copy, and then click File→“Save as
new copy”. If you’re not sharing this document with anyone, then Docs creates a copy
of the document with the name “Copy of document title“. So if your document’s name
is Budget, for example, the new version is called “Copy of Budget”. Docs opens the
copy in a new window, where you can save it or work on it.

When you click File→“Save as new copy” for a document that’s shared, Docs pops up
a dialog box asking whether you want to copy the collaborators, too. Copying collab-
orators means that everyone who can see or work with the current document has the
same privileges for the new copy. If that’s what you want, then click OK. If you want
the new copy to be just for you, click Cancel. When you click Cancel, Google copies
the document, but not the sharers.

Downloading a document

If you want to save a copy of a document on your computer, then you need to down-
load it, where you can open it in another program like Microsoft Word and save it to
your hard drive or a portable storage device. You might do this if you want to open the
document in Word and use Word’s formatting features (many of which aren’t offered
in Google Docs—see page 56) to get it looking just right before you print or email it.

To export a document from Google Docs, click File. From the list that appears, select
“Download file as”. Another menu flies out; choose the kind of file you want to save
as. For example, if you normally use OpenOffice Writer as your word processor, then
choose “Download file as”→OpenOffice. Figure 2-8 shows your options.

After you’ve selected the type of file you want to download, a window opens asking
what you want to do with the file. You can save it on your computer or open it with
the appropriate program. Make your choice, and then click OK. Your computer saves
or opens the file. Now you can work on the file even when your computer isn’t con-
nected to the Internet. If you make changes, don’t forget to upload the new version
back to Docs (see page 52).
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Ready, Set, Write: Working with Documents
Once you’ve stocked Google Docs with some documents—whether by uploading or
creating them from scratch—you can get to work writing and editing. This section
covers just about everything you might want to do with your documents—from for-
matting to working with tables, to printing and deleting.

NOTE
When you’re done working on a document and want to return to the Docs list, you’ll
probably click the upper-right Docs Home link—and then wonder what happened
to Google Docs. Clicking Docs Home saves the document, and closes the text editor
window. The Docs home page is still there, it’s just in a different window. This be-
havior can be disconcerting at first, especially if you tend to have a lot of windows
open at once.

Formatting a Document
Even the most ardent Google Docs lover will probably get kinda quiet if you ask about
Docs’ formatting capabilities. Despite all the things Docs does so well—from access to
storage to searching to collaboration—it doesn’t offer all the formatting bells and

Figure 2-8. When you want to download a document to your computer, use the File menu’s “Download
file as” section to choose your format.
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whistles that you get with, say, Microsoft Word. On the other hand, it’s free and it gets
the job done, offering all the basics and a bit more. Despite some limitations, you can
still produce professional-looking documents with Google Docs. This section explains
your formatting options.

TIP
If Docs doesn’t offer formatting that you need, such as a particular font, export the
document (page 55), and use a program like Word to apply the formatting. Make the
document as fancy as you like, and then print out or email the formatted version.

To apply formatting like line spacing or a font style to an entire document, follow these
steps:

1. Create a new document or open one from the Docs list. Select Edit→“Document
styles”.

Docs opens the Document Styles box, shown in Figure 2-9.

2. If you want the document to stick with the formatting and styles Docs normally
uses, turn on the “Turn Off All Styles” radio button.

This box shows you how the
formatting you’ve chosen will
look in your document.

Figure 2-9. To apply formatting to your whole document, use the Document Styles box. The
Preview window gives you a glimpse of what your changes will look like. If you’re writing in 
Hebrew or Arabic, turn on the Right-to-left checkbox. To apply your formatting choices to new
documents, turn on the “Make these the default settings for all new documents” checkbox
(circled).
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If you’d rather make your own formatting choices, then turn on the “Use my font
and line spacing settings, below” radio button. Then you can select a font style and
size, line spacing, and background color (if you want one). In the right-hand box,
Google previews how your formatting will look. If you want to apply these settings
to any documents you create from here on out, turn on the “Make these the default
settings for all new documents” checkbox.

3. When everything looks good, click OK.

Docs applies your formatting to the current document.

Working with Text
As you write, you’ll probably want to add a little emphasis here, break out a list there.
You do this using Docs’ formatting toolbar: a bunch of buttons on the gray bar directly
above the space where you type. Here’s what each one does:

• Save. The Save button looks like one of those old-fashioned floppy disks that went
the way of the cassette tape. Google automatically saves a version of your document
every few minutes. If you want to save more often than that, then click this button
once in a while.

• Print. This button saves the current document, and sends it to your printer. (For
more on printing documents, see page 75.)

• Undo/Redo. The Undo button, which looks like a curved arrow pointing left,
reverses whatever you just did in the text editor. If you typed something, then the
Undo button makes that text disappear. If you italicized a word, then Undo takes
the italics away. The Redo button, a curved arrow that points right, restores what-
ever you just undid with Undo.

TIP
Don’t worry if you can’t remember which button is Undo and which is Redo. For a 
quick reminder, hover your cursor over the button in question. After about a second,
a little label pops up telling you what the button does. (This trick works for any of
the buttons on this bar.)

• Font style. Click this drop-down list to choose from about a dozen different fonts
—from Serif (which looks a lot like Times New Roman) and Sans Serif (which
looks like Arial) to Verdana and Garamond.

• Font size. Google Docs gives you a fairly narrow range of font sizes to choose from
—from 8 points to 36 points.

• Bold. This button bolds any text you’ve selected or are typing.

• Italic. Italicizes the selected text.

• Underlining. This button—you guessed it!—underlines text.
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• Change font color. Click this button, and then choose from a few dozen different
colors. (To change the color of your document’s background, use the Document
Styles box [page 57].)

• Highlighting. To add highlighting, select the text you want to highlight, and then
click this button and choose a highlight color. (To remove highlighting, change the
highlight color to white, or use the “Remove formatting” button, described a few
items down this list.)

• Link. You can add a hyperlink to your document using the Insert button
(page 60), but this button gives you a quicker, easier way. Select the text you
want to turn into a hyperlink, click this button, and then tell Google where to link
to. (For more on inserting hyperlinks, see page 64.)

• Numbered list. Creates a list that starts at 1 and adds a new number each time
you make a new paragraph.

• Bulleted list. Adds bullets in front of the text you’ve selected (or are about to type).

• Increase/Decrease indent. Clicking these buttons makes the selected text jump
farther away from or closer to the left margin, respectively.

• Alignment. These three buttons tell Docs how to arrange your text on the page—
left-justified (a straight margin on the left), centered, or right-justified (a straight
margin on the right). The tiny lines on these buttons are meant to give you an idea
of how your text will look formatted each way.

• Remove formatting. If you don’t like the way your text looks after you’ve for-
matted it, select the text and then click this button, which looks like an italic letter
T with an x at the bottom. This button can remove lots of formatting at once: If
you’ve gotten a little overemphatic by typing a sentence in bold, italic, underlined,
red, 36-point font, one click of this button scrubs all that formatting away.

• Check Spelling. Click this button to have Docs give your document the once-over
for spelling mistakes and typos. Docs highlights all the iffy words it finds. Click a
highlighted word to get spelling suggestions or to add the word to the Docs dic-
tionary so it doesn’t get marked as misspelled. (To turn off the highlighting after
you’ve reviewed a spell check, click the Check Spelling button again.)

Working with Lists
Lists help you make an argument point by point or lay out the steps of a process. To
create a list in Docs, you just click the button for the kind of list you want: bulleted or
numbered. Docs applies that formatting to any text you selected or to what you type
after you’ve clicked the button.

After you’ve created a list, you can change the style of its bullets or numbers. Just right-
click the list (control-click on a Mac), and a menu appears. Select “Change list”, and
pick the bullet or numbering style you want (each kind of list gives you several options).
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For a numbered list, Change List also lets you pick a number other than 1 to start with
—a nice feature if you’ve interrupted a numbered list with a figure or tip.

If you’re looking at a list and decide you need to rearrange the items—what you put as
step 3 is really step 2, for example—select the list item you want to move, and then
right-click (control-click). From the pop-up menu, select “Move list item up” or “Move
list item down”, and Docs does just that.

Inserting Pictures, Tables, Headers, and More
The Insert button (Figure 2-10), sitting in the blue bar above the formatting buttons,
lets you spiff up your documents by adding a slew of things that go beyond plain old
text—images, hyperlinks, comments, tables, text separators, special characters, page
breaks for printing, headers and footers, and bookmarks. This section teaches you all
the neat stuff you can do with these tools.

TIP
You can also find most of the Insert menu’s options on the menu that appears when
you right-click (control-click) in a document.

Figure 2-10. Using the Insert menu’s options, you can take your document beyond the basics by adding
images, links, tables, special characters, and more.
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Insert an image

If a picture is worth a thousand words, you can save yourself a lot of typing by adding 
some images to your document. When you want to insert a picture, click to put the
cursor where you want the image to be, and then click Insert→Image. (You can also
right-click anywhere in your document—control-click on a Mac—and, from the menu
that appears, choose Insert Image.) Docs opens the Insert Image box, shown in Fig-
ure 2-11.

TIP
Attention keyboard shortcut lovers: Google Docs comes loaded with these timesa-
vers; see page 673 for a list.

In the Insert Image box, start by picking a picture. Tell Docs where to find the image,
whether it’s stored on your computer or displayed on a Web page. After you’ve chosen
your image, click Insert to put it in your document, or, next to “More image options”,
click the + sign to play with the following settings:

• Size. You can insert the image at its original size or, from this drop-down list,
choose from thumbnail-size (up to 160 pixels wide) to humungous (up to 1600
pixels wide).

Figure 2-11. When you insert an image, you can tweak its settings before you put it in your document.
(Here you see the choices you get when you expand the “More image options” section by clicking its
+ sign. Click the – sign to hide these options.)

Ready, Set, Write: Working with Documents | 61



W O R K A R O U N D  W O R K S H O P

Putting a Chart in a Document
There’s nothing like a few pie charts or bar graphs to liven up a report. Chapter 3
tells you all about using spreadsheets in Google Docs, including how to create a chart
from data in a spreadsheet (page 156). Once you’ve created your lovely chart, though,
how can you show it off in a document?

You can’t import a chart directly into a Docs document from a Docs spreadsheet. But
don’t despair—you can get your chart into your document by treating it as an image.
Then, you simply insert the chart into your document just as you would a photo, a
logo, or any other image. This takes a few steps, but the results are definitely worth the
effort.

First, create your document (page 51) and your chart—flip to page 156 and follow the
steps for creating a chart from spreadsheet data. (Keep a finger on this page to mark
your place. You’ll be back in a minute or two.) When you’ve created a shiny new chart,
follow these steps to insert it into your document:

1. Click your chart to select it, and then click its upper-left Chart link. From the menu
that appears, select “Save image”.

2. A window appears, asking whether you want to open the image or save it to your
computer. You want to save it, so turn on the “Save to Disk” radio button, and
then click OK.

Your computer downloads the image and saves it (with a catchy, Docs-assigned
name like image.png) to your computer’s desktop. PNG stands for portable net-
work graphics; it’s a popular file format used mostly on the Web.

3. Open your document, click the spot where you want the chart to appear, and then
click Insert→Image.

The Insert Image box (Figure 2-11) opens.

4. Click Browse, and then find your chart (look for the .png file extension). Click
Open to get the file into the Insert Image box, and then click Insert.

Docs inserts the chart into your document. From there, you can resize it by dragging
its handles (the white squares). You can’t edit the chart in your document—that’s
because it’s a picture of your chart, rather than the chart itself. If you need to make
changes to it, go back to your spreadsheet to edit it (page 158), and then follow these
steps again to get the revised chart into your document.

TIP
You don’t have to adjust the image’s size in the Insert Image box. After you’ve inserted
the picture, you can resize it right in your document. It’s easy—just click the image
and drag the little white squares that appear around its border (see Figure 2-12). Click
the Undo button if you don’t like how your resizing looks.
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• Position. Your choices are left-aligned (lined up with the page’s left margin), cen-
tered, or right-aligned (lined up with the right margin).

• Wrap text around image. Turn on this checkbox if you want the image to appear
within a paragraph.

• Clicking this image links to the original image file. If you add an image that
lives on the Web by giving Docs its URL, then viewers can right-click (control-
click) the image to open it in a new window, if you turn on this checkbox.

When you’ve chosen your settings, click Insert to place the image in your document,
as shown in Figure 2-12. (If you want to change your setting choices, right-click [con-
trol-click] on the image in your document, and then, from the menu that pops up,
choose “Change image”.) Once an image is in a document, you can resize it. You can
also select the image, and then copy and paste it into another location or document.

Figure 2-12. Click the picture to bring up resizing handles (the little white squares). Hover your cursor
over a handle until it turns into a double-headed arrow (circled), and then drag the handle to resize
the image. If you don’t like the new size, simply click the Undo button (page 58).
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Insert a link

Since the documents you create, edit, and store in Google Docs are actual Web pages,
you can easily include hyperlinks in them. When you’re working on a document, select
the text you want to link. Then, you have three ways to insert the link:

• In the middle of the toolbar, click the Link button.

• Click Insert→Link. (It’s next to a little picture of some links of chain—get it?)

• Right-click (control-click) the selected text, and then, from the menu that appears,
choose Insert Link.

Whichever method you use, the Insert Link box shown in Figure 2-13 opens. Here’s
what you can do in that box:

• Link To. This section has two parts:

— Tell Docs what kind of link to insert:

— URL. Link to a Web page. (URL stands for “Uniform Resource Locator,”
which is just a fancy term for a Web address.)

— Document. Link to another document in Google Docs (you can’t link to a
document on your computer).

— Bookmark. Link to a place within your document. (See page 68 for more
about bookmarks.)

This text box changes,
depending on which radio
button you turned on
above.

The text you selected in
your document
automatically appears
here.

If you want a message to
appear when the cursor
hovers over a link, type it
here.

Figure 2-13. In the top half of the Insert Link box, tell Docs what kind of link you want and where to
link to. In the bottom half, Docs automatically fills in the text you selected in your document. If you
didn’t select any text, then type new text here. Docs adds it to your document. Next, if you want, type
a flyover message that explains what your link does. Finally, if you’re linking to a URL, you can tell
Docs to make the link open in a new browser window (circled).
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— Email address. Create a “mail to” link so that when someone clicks the link,
his email program opens a new message with the To email address already
filled in.

— Give Docs the info it needs to create the kind of link you chose:

— URL. Type the address of the Web page you want to link to. (You can most
easily do this by opening the page in another browser window, coping what’s
in the address bar, and then pasting it in this box.)

— Document/Bookmark. When you choose either of these options, the text
box changes to a drop-down list with any bookmarks in your document.
Click the drop-down list, and then select the bookmark you want to link to.

— Email address. Type in the email address you want mail to go to when
someone clicks the link.

• Link Display. This section also has two parts:

— Text. This shows the text that will be linked. If you selected some text in your
document before you opened the Insert Link box, then that text appears here
automatically. In Figure 2-13, for example, the words Google Account are linked,
and appear in your document as blue, underlined text. When a reader clicks
anywhere on that phrase, the Web page specified in the URL text box opens.

If you didn’t select any text, type some here, and Docs inserts it (with its asso-
ciated link) into your document wherever the cursor is. If you leave this box
blank, then Docs inserts the URL you typed in the Link To section directly into
your document. So, for example, instead of the linked words “Google Account”,
the reader would see the link http://www.google.com/accounts in your docu-
ment.

— Flyover. Flyover text appears when a viewer hovers her cursor over a link. A
flyover might be an explanation of where the link goes or a nudge to click the
link. For example, if your link is a bookmark to, say, something called Table
4.7, the flyover might give that table’s title. Or, if your sales letter has links to
various products, your flyover might say, “On sale!” or “Click now! Going fast!”
Flyovers are optional; if you want one, type it here, and then check carefully for
typos—Docs doesn’t spell check flyovers.

• Open link in new window. This checkbox appears only if you’re linking to a Web
page or another document. It’s a good idea to turn it on, because opening the link
in a new window means that, after clicking the link, your reader doesn’t have to
navigate back to your document to keep reading.

Once you’ve provided the necessary info and clicked Insert, Docs puts the link in your
document. Back in the text editor, you can see what the link looks like (and check to
make sure it works); click the upper-right Share button, and then select “View as web
page (Preview)”. Now you see how your formatted document will look published on
the Web (page 88).
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TIP
You can most easily remove a link by deleting the text that holds the link. You can
also delete a link by right-clicking (control-clicking) the linked text, choosing “Re-
move link” from the menu that appears, and then, in the confirmation box, clicking
OK.

Insert a comment

Put your cursor where you want the comment to appear, and then click the In-
sert→Comment. (You can also right-click [control-click] where you want the comment,
and then, from the menu that appears, choose Insert Comment.) Docs inserts a com-
ment at the point you chose, as shown in Figure 2-14. Start typing to have your say.

NOTE
Comments are really handy when you’re collaborating on a document; the section
“Sharing and Collaborating on Documents” (page 86) goes into more detail about
them, including how to change a comment’s color or make it part of the document’s
text.

Figure 2-14. When you click Insert→Comment, Docs inserts a highlighted comment (circled) wherever
the cursor was. Docs puts the insertion point in the comment, so you can just start typing. Comments
show the name of the commenter, and when the comment was made.
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Insert a table

Position the cursor where you want the table, and then click Insert→Table. Alterna-
tively, you can click Table→Insert Table, which brings up the box shown in Figure 2-15.

You’ve got to set up your table before you can insert it, and do this setup in the Insert
Table box. You don’t have to get everything perfect here; you can edit your table later
—adding a column here, deleting a row there, removing a border, and so on. To create
your table, give Docs the following info in the Insert Table box:

• Number of rows.

• Number of columns.

• The table’s width. Your choices here are:

— Full width. The table will take up the entire width of a page.

— Size to content. The table will be as wide as required to fit its cells’ contents.

— Width in pixels. This is a precise way to specify how wide you want the table
to be.

— Width as a percentage. If you type 50 here, the table will stretch halfway across
the page; if you enter 67, it will stretch across two-thirds of the page, and so on.

• Columns of equal width. Turn on this checkbox if you want all your columns to
be the same width, no matter how much content a particular cell holds.

Figure 2-15. Here’s where you tell Docs how to format the table you want to insert.
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• The table’s height. This drop-down list gives you the same choices as in Width
menu (above), except they determine how tall or short your table is.

• Padding. In a table, adding padding puts a little space between the content of a
cell and the cell’s border, making the table easier to read. Raise or lower the number
here to increase or decrease the amount of space. You’ll probably find that Docs’
suggested 3-pixel padding works just fine in most cases.

• Alignment. You can make the text within each cell centered or left- or right-
aligned.

• Spacing. Adding spacing sets the distance between cells.

• Float. Floating a table lets you wrap text around it. Choose None, Left, or Right .

• Border size. If you want your table to have a border, type a number to determine
how thick it is. (If you don’t want a border, then leave this setting at 0).

• Border color. Click this box to choose a color for your border.

• Background color. Click this box to select a color for the table’s cells.

When you’ve set up your table, click Insert. Docs puts the table into your document.
Simply click a cell, and then start typing. If you decide you want to tweak how your
new table looks, turn to page 71 for tips on formatting tables.

TIP
If you’ve just inserted a table and changed your mind, clicking Undo doesn’t uninsert
it. If you want to take the table out of your document, then right-click (control-click)
the table. From the menu that appears, select “Delete table”.

Insert a bookmark

A bookmark is a special kind of link that lets you link to a particular place within your
document (as opposed to, say, a Web page). Bookmarks are helpful when you want a
one-click-away cross-reference or when you’re creating a table of contents or an index.

Using bookmarks in Docs takes two steps:

1. Create a bookmark.

To do this, select the text, image, or other element you want to bookmark; this
could be a table, a chapter title, a figure caption—whatever. Then, click In-
sert→Bookmark (or right-click [control-click] and choose “Insert Bookmark” from
the menu that appears) to open the Insert Bookmark box, shown in Figure 2-16.
In the New Bookmark text box, type a name for your bookmark (so you can find
it to link to later), and then click OK.

2. Link to the bookmark.

After you’ve created a bookmark, next up is linking to it. Say you want to put in a
cross-reference to an upcoming section, so that readers can jump ahead to that
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section with one click. After bookmarking the target section (as described in step
1), select the text you want to link to that bookmark, and then click Insert→Link.
In the Insert Link box (Figure 2-13), select Bookmark as the type of link you’re
creating, and then use the Bookmark drop-down list to find the bookmark you
want to link to. Now, when folks click on the linked text, they’ll hop right to that
bookmarked section.

When you create a new bookmark, you don’t see any changes to the text. Instead of
showing your bookmarks in the text editor, Docs adds them to your Bookmarks list,
which is where you look for them when you link to a bookmark.

TIP
After you’ve created a few bookmarks, you can manage them by clicking In-
sert→Bookmark. When the Insert Bookmark box (Figure 2-16) opens, it lists existing
bookmarks, so you can create a new bookmark or remove an existing one (select a
bookmark from the list, and then click Remove).

Insert a separator

Docs offers two ways to separate your document into different sections:

• Page break. This forces a new page to start after the break. Page breaks are helpful
when you’re working on a document that’s divided into chapters—you can insert
page breaks to make sure each chapter starts on a new page.

If you've selected some text to become a
bookmark, it automatically appears here.

Existing bookmarks in this document (if any)
appear in a list here.

Figure 2-16. Be sure to give your bookmark a descriptive name so you can easily find it—
especially important if you have lots of bookmarks in your document. If you want to remove a
bookmark, in the Other Bookmarks list, click its name, and then click the Remove button
(circled).
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• Horizontal line. This inserts a horizontal line in the document, which is a good
way to make clear distinctions between different sections.

Whichever kind of separator you want to insert, position your cursor where you want
to put the separator. Then click Insert→ “Page break (for printing)” to insert a page
break, or Insert→ “Horizontal line” to insert a line. Docs inserts the separator where
you want it.

TIP
If you want to delete a page break or horizontal line, put your cursor just after the
separator, and then hit the Backspace key.

Insert a special character

Google Docs’ set of special characters is small compared to other word processors, but
it has a lot of the accents and diacriticals that you can use to add a soupçon of interna-
tional flair to your writing. To insert a special character (like the ç in soupçon), put your
cursor where you want the character to go. Click Insert→“Special characters”, and then,
in the Insert Special Character box, click one of the offerings (shown in Figure 2-17).
Voilà!—Docs inserts the character into your document.

Figure 2-17. Here’s where you choose a special character for Docs to insert. In addition to the ones
shown here, Docs also has a set of Asian characters. If you’re geeky enough to know the Unicode
name for the character you want to insert, turn on the Advanced radio button, and then type in the
code.
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Insert a header or footer

If you want specific text to appear at the top of each page, such as your name or the
document’s title, then click Insert→Header. At the top of the first page of the document,
Docs opens up a space; in that space, type whatever you want for your header.

Footers work the exact same way, except the box appears at the end of the last page of
the document. Click Insert→Footer, and then get typing.

TIP
You can also right-click (control-click) to insert a header or footer. Then, from the
menu that appears, simply choose the one you want.

You can edit your header or footer whenever you like. Just click inside the header or
footer (which is surrounded by a dotted gray line), and then make your changes. To
delete a header or footer, right-click (control-click) it, and then select Delete Header or
Delete Footer.

NOTE
When this book went to press, Google Docs was still having a little trouble getting
headers and footers to export correctly into Word. If you’re exporting a Google doc
as a Word doc (page 55), then you don’t see a header or footer on each page of the
Word doc, the way you expect headers and footers to work. Instead, Word displays
a header only on the first page and a footer only on the last page. Google is working
to fix this problem, but it’s worth watching out for if you export into Word.

Working with Tables
On page 67 you learned how to insert a table into a document. But what do you do
when it’s time to modify an existing table? Read on.

Add or delete a row or column

As you work with a table, you may find you need more room—or you’ve got some
empty rows or columns you don’t need. To adjust the rows or columns in a table, click
the table near the place that needs adjusting, and then click Table in the blue bar above
the formatting buttons. (Alternatively, you can right-click [control-click] the table.)
From the menu that appears, shown in Figure 2-18, choose one of these options:

• Insert row above

• Insert row below

• Insert column on the left

• Insert column on the right
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• Delete row

• Delete column

P O W E R  U S E R S '  C L I N I C

Firefox Table Shortcuts
If you use Firefox as your Web browser, then you have an easy way to adjust a table’s
rows and columns. After you’ve created a table, and you click one of its cells, you may
notice the symbols that appear on its vertical and horizontal borders: two arrows and
a circle with an X inside (you can see them in Figure 2-18). You can use these controls
to make quick adjustments to the number of rows and columns in your table:

• Add a row above this one. On the horizontal border, click the upward-pointing
arrow.

• Add a row below this one. On the horizontal border, click the downward-point-
ing arrow.

Right-click a table to see
this list of options.

Figure 2-18. This menu gives you all kinds of ways to work with your table—just take your pick.
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• Add a column to the left of this one. On the vertical border, click the left-pointing
arrow.

• Add a column to the right of this one. On the vertical border, click the right-
pointing arrow.

• Delete this row. On the horizontal border, click the circled x.

• Delete this column. On the vertical border, click the circled x.

If you make a mistake, just click the Undo button (page 58), and Docs reverses your
last action.

Move a row

To move a row, right-click (control-click) the row you want to move, or click that row,
and then click Table. From the menu that appears (Figure 2-18), select “Move row up”
or “Move row down”, depending on where you want to put it.

TIP
If you use Firefox, you may find that right-clicking a table displays two menus: one
for Docs and one for Firefox. The frustrating thing is that the Firefox menu obscures
the Docs one, so you can’t see all its options.

To get the Firefox menu out of the way and view your table-editing options, you need
to change your Firefox settings. Click Tools→Options→Content tab. On the Content
tab, find Enable JavaScript, and then click the Advanced button to its right. In the
box that opens, turn on the “Disable or replace context menus” checkbox. Click OK,
and then click OK again. Now, you should be able to see Docs-specific context menus
without Firefox’s menu getting in the way.

Add, change, or remove a border

When you first insert a table (page 67), Docs asks whether you want a border for it.
You can always change your mind later. To add a border to your table, right-click
(control-click) the table. From the menu that pops up (Figure 2-18), select “Change
table”. (If you prefer, you can click Table→“Modify table properties”.) This opens the
Change Table box, which is pretty much identical to the Insert Table box (Fig-
ure 2-15) you used to create the table. To make changes to the table’s border, pick one
of these options:

• To add or change a border. In the Change Table box’s Borders section, select a
size and a color for the border. (Just to give you an idea, the table shown in Fig-
ure 2-18 uses 3 for the border size.) Don’t forget to select a color—if the color box
is blank, the border will be invisible.

• To remove a border. In the Change Table box’s Borders section, set Size to 0, and
the border disappears.
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NOTE
When you remove a border from a table, Docs still shows the gridlines between cells
in the text editor. To make sure the table is border-free (and that you like the way
that looks), click the upper-right Share button, and then select “View as web page
(Preview)”.

Change a row, column, or cell

You can apply changes to a specific row, column, or even individual cell in your table. 
For example, you might want to center the column headings, but have all the other
rows left-aligned. Or, for a column that holds dollar amounts, you might want that
column right-aligned, while the others are centered or left-aligned.

When you want to make changes to a row, column, or cell, click the appropriate spot
in your table, and then select Table→“Modify row properties”, “Modify column prop-
erties”, or “Modify cell properties”. Or you can right-click (control-click) the spot you
want, and then, from the menu that appears, select “Change row”, “Change column”,
or “Change cell”. Whether you’re altering a row, column, or cell, you have these
options:

• Size. You can adjust a column’s width, for example, if it holds a lot of text that’s
getting squeezed into a fixed-width cell that’s too narrow to hold it.

• Alignment. These settings adjust the horizontal and vertical alignment of text
inside the cell, row, or column. If you want your headings centered, for example,
click the headings’ row, select “Change row”, and then set Horizontal alignment
to Center.

• Background color. Changing the background color of a particular cell, row, or
column is a great way to call attention to it. You can also alternate colors between
rows or columns to make the table more readable.

Delete a table

If your table didn’t work out as you’d planned, you can delete it in three clicks: Right-
click (control-click) the table, select “Delete table”, and then click OK to confirm. Or
use this trio of clicks: Table→“Delete table”, and then OK to confirm.

W O R K A R O U N D  W O R K S H O P

Creating Columns of Text
Google Docs doesn’t let you select some text and, with the click of a button, reformat
that text into columns (think newspaper layout). But with a little bit of creative fiddling,
you can still achieve the column look.

Imagine that a page with multiple columns is really just one page-size table with only
one row: When you reach the bottom of the first column, you start typing in the second,
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and so on. In other words, you’re using a full-page table with invisible gridlines between
the columns.

To compose your columns of text, first insert a table (page 67). In the Insert Table box,
set the table to have one row and at least two columns. Create the table, and then start
typing in the first column. To see how your columns look, click Preview. To increase
the amount of space between columns, right-click (control-click) the table, select
“Change table”, and then increase the padding, the spacing, or both (see page 68).

When you use this method to create columns, make sure your table doesn’t have any
borders (in the Border section of the Insert Table box, Size should be 0). Although you
see the table’s gridlines as you type, they don’t show up when you preview, print
(page 75), or publish (page 88) the document.

The end result is columns of text—and no one will ever know it’s actually a table.

Printing a Document
Printing from Google Docs is as simple as printing from any other word processor.
Open the document you want to print, and your hard copy is just a hop, skip, and click
away:

1. You’ve got two ways to print: Click the upper-left Print button (it has a picture of
a tiny printer on it) or select File→Print.

Whichever one you choose, the Print Settings box, shown in Figure 2-19, opens.

Figure 2-19. Here’s where you tell Docs what you want your printed document to look like.

2. Make sure the settings are what you want: paper orientation (portrait or land-
scape), paper size, margin widths, and page numbering on or off. When everything
looks good, click OK.
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Docs saves your settings, and then creates a PDF file of your document, which
opens in Adobe Reader, to show you what the printed page(s) will look like. At the
same time, you get a Print box like the one in Figure 2-20.

3. Check the settings in the Print box, make any necessary changes, and then click OK.

Your computer sends the PDF to your printer, and you get a copy of your document
that you can hold in your hands.

TIP
If you’re working on a computer that doesn’t have Adobe Reader, and you need to
print your document, click Share→“View as web page (Preview)” to open the for-
matted document as a Web page. In the browser window that shows your document,
select File→Print, and then click OK to print the document. If you print a document
this way, the formatting isn’t quite as good as in the PDF—and you probably have
the browser’s header and footer—but all the content is there.

Figure 2-20. Adobe Reader shows you how your document will look when it’s printed. The Print
box also shows a preview and a bunch of settings you can tweak. Click OK to send the document
to the printer.
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Deleting a Document
When you want to get rid of a document, you have two options: Delete it when you’re
viewing it in the text editor, or nix it from the Docs list. If you delete a document and
then change your mind, you can retrieve it from the Trash (as long as you haven’t
emptied the Trash). The following sections explain how.

Delete a document from the text editor

When you’re viewing a document and decide you don’t want it any more, delete it by
clicking File→Delete. A confirmation box opens; click OK. Docs moves the document
to the Trash.

NOTE
When you return to the Docs home page, you may have to click your browser’s
Refresh button to make the deleted file disappear from your Docs list.

Delete a document from the Docs list

In the Docs home page’s Docs list, select a document by turning on its checkbox. Click
the Delete button (the one with a picture of a trash can), and Docs dumps the file in
the Trash.

If you mistakenly deleted the wrong file, at the top of the page, click Undo in the yellow
box to get it back. Or read the next section to learn how to fish a document out of the
Trash.

Retrieve a deleted document

Goodbye doesn’t always mean forever. If you get rid of a document by mistake, or you
just change your mind, you can find it in the Trash, and then restore it to the Docs list
or a folder:

1. In the Docs home page’s left-hand menu, make sure All Items is expanded (click
the + sign next to it, if necessary). Then select Trash.

Docs displays your Trash folder’s contents.

2. Select the file you want to restore (turn on its checkbox), and then click Undelete.
You can select and restore more than one file at a time.

Docs removes the file from the Trash, and puts it back where it came from. If you
deleted it from the Docs list, then it’s back there now. If you deleted it from a folder,
then it’s back in that folder, too.
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Empty the Trash folder

There’s really no need to empty the Trash in Google Docs—you can store up to 5,000
documents, spreadsheets, and presentations in your account. But if you’re in the mood
for a little housecleaning, just open the Trash folder, and then click the “Empty trash”
button. Docs asks whether you’re sure, since files deleted from the Trash are gone for
good. Click OK, and your Trash folder is empty.

Change a document’s ownership

When you create a document, you own it. And if you share that document with other
people (page 86), you still own it. When you delete a shared document that you own,
Google trashes it for everyone, not just you. Sometimes, though, you might not want
that to happen. For example, you might change jobs, and you don’t need documents
related to the old job any more, but the coworkers you’re leaving behind sure do. If
you want to delete a document from your Docs list while leaving it intact for those with
whom you share, then you can transfer ownership of that document to somebody else.

On the Docs home page, find the document you want to transfer, turn on its checkbox,
and then click Delete. Docs opens the box shown in Figure 2-21, asking whether you
want to transfer ownership to somebody else. Click “Choose new owner”, and Docs
opens the box in Figure 2-22 to let you pick the document’s lucky new owner.

You can transfer ownership to anyone who has a Google Account, even if he’s never
shared the document before. Type in the new owner’s email address or choose from
your Contacts list. If you want, customize the notification email that Google sends to
let the new owner know about the transfer. Then click “Change owner” to transfer
ownership.

When you transfer ownership of a document, you become a collaborator on the docu-
ment (page 93 explains the difference between owners and collaborators). Now, you

Figure 2-21. When you’re about to delete a shared document that you own, Google asks whether
you’d rather transfer ownership to someone else or put the document in the Trash folders of everyone
with whom you share it.
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can delete the document from your Docs list without moving everyone else’s copy to
the Trash at the same time.

NOTE
The new owner can’t refuse ownership of the document but can transfer ownership
to somebody else.

Editing Documents Offline
Since Google’s computers store your documents, you can access those documents from
anywhere you can connect to the Internet. But what about times when you’re not on-
line, but you still need access to your stuff? Like when you’re on a plane and you need
to work on a presentation or in a hotel room with spotty Internet access. No problem.
This section tells you how to set up your computer so you can edit and save documents
offline.

NOTE
At this writing, you can view and edit word processor documents offline, and view
(but not edit) spreadsheets offline. You can’t work with presentations offline at all.
And even though you can edit any existing word processing documents while you’re
offline, you have to be connected to the Internet to create a new document.

Figure 2-22. To transfer ownership of a document, tell Google the email address of the new owner.

Editing Documents Offline | 79



Install Google Gears
Before you can edit your documents offline, you need to download and install Google
Gears. Gears works with your Web browser to let you open, read, edit, and save docu-
ments even when you’re not online. (The documents get stored on your computer.)
The next time you connect to the Internet (using the same computer and browser) and
sign into Google Docs, Google automatically syncs the documents in your Docs ac-
count with the work you did offline.

To install Google Gears, your computer and browser must be one of these combina-
tions:

• Mac OS X 10.2 or higher, with Firefox 1.5 or higher

• Windows XP or Vista with Firefox 1.5 or higher

• Windows XP or Vista with Internet Explorer 6 or higher

• Linux with Firefox 1.5 or higher

• Windows Mobile 5 or higher with Internet Explorer 4.01 or higher

If your computer meets these requirements, point your Web browser to http://gears.goo
gle.com. (If you’re on your Google Docs home page, you can click the upper-right
Offline link; in the dialog box that opens, click “Get Google Gears now”.) On the main
Google Gears page, click the big blue Install Google Gears button.

Google opens a page that shows its Terms of Service and Privacy Policy (see the box
on page 38 for the highlights). If you want, turn on the checkbox that lets Google collect
anonymous information about how you use Google Gears. If you’d rather not share
that info, leave the checkbox turned off. Then click the Agree and Download button.

Google opens the page shown in Figure 2-23, and your computer asks for your okay
to download the file. Click Save File to start the super-quick download. When you’ve
got the file on your computer (it’s called GoogleGearsSetup.exe), open it to start the
installation. (Since you’ve downloaded a program, your computer may ask for your
approval before running it. If that happens, click OK.)

The setup program installs Google Gears on your computer. You need to close your
Web browser, and then restart it to finish the installation.

Set up Docs to Work with Google Gears
When you return to the Google Docs home page, you see the security warning shown
in Figure 2-24. This warning tells you that the site you’re on wants to use Google Gears
to access and store information on your computer. The site is Google Docs, so that’s
what you want. Turn on the checkbox that says, “I trust this site”, and then click Allow.
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Figure 2-23. Before you can edit documents offline, you have to download and install Google Gears.
Click Save File to download the Google Gears installer. After Gears is installed, you have to restart
your Web browser to make it work.

Figure 2-24. Google Gears checks to make sure that you trust a site before it syncs the site with your
computer. If you’re using your own computer and the site you’re signing into is your own Docs account,
you can safely click Allow, and then continue.
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Next, Gears asks if you want to create a Google Docs shortcut on your computer’s
desktop. Clicking this shortcut launches Google Docs when you’re offline. Choose Yes
if you want the shortcut, No if you don’t (you can always create a shortcut later—
page 85 shows you how).

WARNING
Using Google Gears to sync your Docs account with a public computer (at a library,
for example) could give other people access to your documents. To make sure your
private documents stay private, don’t edit offline on a public or shared computer. If
you’re using a public computer and you see a message asking you to turn on Gears,
like the one in Figure 2-24, then click Cancel.

Google synchronizes the documents on your computer with the ones in your Google
Docs account. Syncing means that Google’s making sure the documents are the same
in your account and on your computer, so you can open and work on the same docu-
ments whether you’re connected to the Internet or not. As Google syncs your docu-
ments, it shows a yellow bar at the top of your screen, and a status box in the upper
right, both shown in Figure 2-25, to indicate the sync’s progress. This process might
take a few minutes. When the status box says Synchronized, you’re all set to work
offline.

Activation message Online indicator Status box

Figure 2-25. Here, Google has just finished synchronizing documents between Google Docs and a
computer, so you can work offline. The checkmark in a green circle (circled) means that you’re
currently online. When you’re offline, this symbol changes to a gray No symbol (a circle with a
diagonal line through it).
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Work Offline
After you’ve installed Google Gears and synched your documents, you’re ready to work
offline. The next time you’re working offline on the computer where you installed
Google Gears, either click the Google Docs shortcut on your Desktop (if you created
one) or open your Web browser and then, in the address bar, type docs.google.com.
Even though you’re not connected to the Internet, your browser opens the page shown
in Figure 2-26. This page tells you that you’re signing in offline and asks for the email
address you use to sign into Docs—no password’s necessary for offline editing.

After you’ve signed in, your browser opens the Docs home page. This page looks just
like it does when you work online, except that, next to your email address, in the upper-
right part of the screen, is a gray No symbol: a circle with a diagonal line through it.
This symbol’s the offline indicator, showing that you’re not connected to the Internet.
When the offline indicator appears, you can edit documents just as you normally would
in Docs: From the Docs home page, click any document to open it in a new window
for editing. Google lets you know that you’re editing in offline mode, as Figure 2-26
shows. When you’re done editing, click “Save & close”. Back on the Docs home page,
your edited document is labeled “Edited offline”.

Figure 2-26. When you open your browser and go to http://docs.google.com while you’re not connected
to the Internet, you see this page. Sign in with the email address you use to sign into your Google
Account.
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WARNING
If the offline indicator changes from a gray No symbol to a red circle with an excla-
mation mark inside, Gears is warning you that your offline edits aren’t being saved.
If you see this symbol, stop working on the document. If possible, don’t turn off your
computer or close the browser window that holds the document, or your changes
will be lost. As soon as you can, reconnect to the Internet so Google can sync the
work you’ve done with Docs.

The next time you connect to the Internet (using the computer you edited on) and sign
into Google Docs, Google synchronizes your documents automatically—you don’t
have to lift a finger. You know a sync is happening when the upper-right green circle
shows two arrows chasing each other around in a circle. When the circle changes to a
checkmark, your documents are synched, meaning that Google has uploaded the
changes you made offline. After a sync, Google removes the “Edited offline” label from
your document.

NOTE
To sync your documents, you have to connect to the Internet, and then sign into
Google Docs using the same computer and the same browser you used while editing
offline.

Offline Editing and Collaborating
As page 86 explains, Docs lets you share documents and work on them simultane-
ously with other people. When you collaborate online, changes you make to a docu-
ment show up in the document right away. When you work offline, however, any edits
you make are stored on your computer until you connect to the Internet again, and
then sign into Docs—your collaborators don’t see the changes you made until Google
syncs the documents on your computer with Google Docs.

But what happens if you’re editing a document offline and someone else is working on
it at the same time, creating a conflict between the two versions? In that case, you see
a box like the one in Figure 2-27. This notice appears when you open the document
that contains the conflicting edits.

Google notifies you that it’s tossed out your recent changes, showing you the affected
edits. In the background is the current version of the document (the one without your
changes). If you want to paste your changes into the current version, select them, press
Ctrl+C (⌘-C) to copy them, click OK, and the notice box disappears. Click the docu-
ment where you want to paste your changes back in, then press Ctrl+V (⌘-V) to paste.
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TIP
Google uploads your offline edits and saves them as a version of the document before
it checks for a conflict and discards them. So you can also find your changes by
checking the document’s revision history, and comparing the version you edited off-
line with the current version (page 105 tells you how to compare two documents in
the revision history).

Adjust Your Offline Access Settings
Google offers a couple of options for your offline settings. To tweak them, click the
online/offline status indicator (the upper-right checkmark or No symbol next to your
email address). In the box that opens, click Settings to open the Offline Access Settings
box shown in Figure 2-28, where you can change these settings:

• Create desktop shortcut. If you want fast access to Google Docs from your com-
puter’s Desktop (whether you’re online or off), click this button. The shortcut is a

Figure 2-27. When edits you made offline conflict with the current version of a shared document,
Google lets you know. Because you edited an older version of the document, Google discards your
changes. You can copy them and paste them back in, or find your edits in the document’s revision
history (page 102).
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little picture of a pencil and some paper; click it to go straight to Google Docs in a
new browser window or tab.

• Reset and disable offline access. If you decide you’d rather be connected to the
Internet and signed into your Google Account as you work, then you can turn off
your computer’s ability to work offline. Click this button, and Google disables 
Google Gears on your computer.

TIP
When you disable offline editing, the status indicator on the Google Docs home page
is replaced by the word Offline. If you change your mind and want to edit offline
again, click Offline. In the box that appears, click “Enable offline access”, and Docs
turns Google Gears back on, and syncs your documents.

Sharing and Collaborating on Documents
When Google Docs first appeared, the thing that really got everybody talking was how
easy it is to share documents and collaborate on them in real time. Not only can you
share a Google doc, you can invite other people to work on it with you. For example,
imagine planning the guest list for a wedding—when the bride lives in Chicago, her
parents live in Boston, the groom is in Berlin on a business trip, and his parents live in
Phoenix. It’s not like everyone can gather around a table and finalize the list. But with
Google Docs, they can all work on the same guest list (despite being in different time
zones) by adding and deleting names, making comments, and getting everything set in
time to order the invitations.

Figure 2-28. Offline Access Settings are limited to creating a desktop shortcut to Docs or disabling
Google Gears.
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This section explains the different ways you can share a Google doc with others, from
emailing it to inviting folks to roll up their sleeves and work on it with you.

NOTE
If you use Google Docs through your organization’s Google Apps account (you sign
in through a company Web site instead of going to www.docs.google.com (http://
www.docs.google.com)), your domain administrator can limit your ability to share
documents with people who don’t work for your organization. (See Chapter 10 for
details.) In that case, you might find that you can’t invite someone from outside your
organization to share documents or receive sharing invitations from people who don’t
work with you. You can still send and receive documents as attachments, though,
but you can’t edit them together in real time.

Emailing a Document
Perhaps the most obvious way to share a document is to email it as an attachment. In
Google Docs, you can put the finishing touches on your document, and then share it
with the world (or maybe just a friend or two) via email. Unlike inviting collaborators
to work on a document with you, emailing gives the recipient his own copy, so he can
work on it in Word or another word processing program.

To email a document from the Google Docs text editor, follow these steps:

1. Open the document you want to email, and then click Share→“Email as
attachment”.

Docs opens the Email Document box shown in Figure 2-29.

2. Enter the info Google needs to send your email:

• The email address(es) you want it sent to. You can choose these addresses from
your Gmail Contacts list (page 273). (If you’re sending to more than one person,
put a comma between addresses.)

• How you want the document sent (in the body of the email or as an attachment).

• A Subject line (prefilled with your document’s title).

• An optional message.

• Whether you want a copy of the email sent to you.

When you’ve got all that set, click Send, and Docs emails your document.

Email to collaborators

If you’ve invited other people to view a document or collaborate with you on it
(page 95), you can send the document to everyone you’ve shared it with in one easy
step. This is a handy way to distribute a final copy before a sign-off meeting, for
example.
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If you’ve shared a document, then when you click the Email link, the Email Document
box looks like the one in Figure 2-30. The names of the people you’ve shared with
appear in the To area. Add or remove recipients by turning the checkboxes by their
names on or off. Fill out the rest of the box as necessary, and then click Send to dispatch
your document in a flurry of emails.

Publishing a Document on the Web
You can also share a document by publishing it on the Web. Because Google docs are
actual Web pages, this is super easy to do. You can publish a Google doc as a Web page
or post it directly on your blog. You do both those things from the Publish This Docu-
ment page, shown in Figure 2-31 (click the upper-right Share button, and then select
“Publish as web page” to get there).

Publish a document as a Web page

When you publish a Google doc as a Web page, Google creates a home on the Web
just for your document, giving it a unique URL. From there, you can create links to the
document or send the URL to others so they can see it.

You won’t believe how easy it is to publish a document as a Web page:

Google automatically fills in the title of
your document as the Subject line,

but you can change this line if you want.

Figure 2-29. Type in the addresses of recipients, or (if you have a Gmail account) choose them from
your Contacts list (page 273). You can email a document either as the body of the email or as an
attachment.
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1. Open the document you want to publish, and go to Share→“Publish as web page”.

Docs opens the page shown in Figure 2-31.

2. If you want the Web page you’re about to create to reflect changes you make to
the document, then turn on the “Automatically republish when changes are made”
checkbox.

If you tend to write several drafts between publishable versions, leave this checkbox
turned off, or else those not-quite-there drafts will get published, too. (When you’re
ready to publish changes, come back here and follow these steps.)

3. Click the “Publish document” button.

Google publishes your document to the Web ,and opens a page like the one shown
in Figure 2-32. This page shows you the address, in the form of a link to your new
Web page. Click the link to check out your masterpiece. On your Docs home page,
in your Docs list (page 44), Google marks the document as “published”.

Now you can link to the page where your document lives, and share it with others. Just
send them the Web address Google created, and they can view your document.

People you’ve shared this document with

Figure 2-30. Docs makes it easy to send a document to everyone who’s been collaborating on it. You
can tailor the To list by turning checkboxes on or off.
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Publish a document as a blog post

If you’re one of the dozen or so Earthlings who still don’t have a blog, you probably
don’t have a lot of interest in publishing your Google docs this way. (If you want to
start a blog, go to www.blogger.com (http://www.blogger.com), sign in using your Goo-
gle Account login info, and complete the brief registration process.)

You can create, edit, and save documents in Google Docs, and then post them straight
to your blog when you’re ready to take them live. Before you can do that, though, you
have to tell Google Docs about your blog. (You do that on your Google Docs Settings
page, as explained on page 48.)

TIP
If you want to publish a document to your blog but you haven’t yet put your blog
info in Google Docs, then click Share→“Publish as web page”, anyway. If you click
the “Post to blog” button and Docs doesn’t have any info about your blog, then the
Blog Site Settings window opens so you can get your blog all set up.

After Google Docs has the info it needs, here’s all you have to do to publish a document
as a blog post:

1. Open the document you want to publish, and then click Share→“Publish as web
page” to see the page shown in Figure 2-31.

For publishing a
document as a
Web page

For converting a
document into
a blog entry

Figure 2-31. When you’re ready to share a document with the world, in the upper-right, click
Share→“Publish as web page” to open this page. The top half of the page is for publishing the document
as a Web page; the bottom half is for publishing it as a blog post.
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2. Click the “Post to blog” button.

A confirmation box appears.

3. Click OK.

Docs adds the document as a post on your blog.

Couldn’t get much simpler, could it?

NOTE
Documents you publish to a blog aren’t marked “published” in your Docs list. Google
reserves that label for documents published as Web pages.

Update a published document or blog post

After you’ve published a document on the Web, you can edit it, and then update the
published version. Whether you’re updating a Web page or a blog post, the process is
pretty much the same:

1. Open the document, make any necessary changes, and then click Share→“Publish
as web page”.

Docs opens the Publish This Document page. Since you’ve already published the
document, the buttons on this page have changed, as shown in Figure 2-33.

Figure 2-32. When you publish a doc on the Web, Google creates a unique address for it (circled).
This is the address you can give to your friends so they can see your document online.
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2. Click the appropriate Republish button: “Republish document” to update the Web
page; “Republish post” to update your blog.

If you’re updating a Web page, you’re all done. If you’re updating a blog post,
you’ve got one more step.

3. For blog posts, Google opens a box asking you to confirm you want to republish
your post; click OK.

Google updates your blog.

TIP
If you’ve published a document as a Web page, you can update it automatically, so
you don’t have to go back to the Publish This Document page and click Republish
every time you make a change. Click Share→“Publish as web page”, and then turn
on the “Automatically republish when changes are made” checkbox. Now, when you
edit the document, the published version changes, too. You don’t have to lift a finger.

Figure 2-33. This document has been published as both a Web page and a blog post, so both sets
of buttons (circled) have changed. After you’ve published a document, your options on the Publish
This Document page are to republish (update) the document, or to stop publishing it on a Web
page, or remove the post from your blog.
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Remove a published document or blog post

When you want to remove a published document from the Web or erase a post from
your blog, open the document, and then click Share→“Publish as web page” to get to
the Publish This Document page, shown in Figure 2-33. Then do one of the following:

• For a document. Click the “Stop publishing” button. Google removes the Web
page. Now, if someone follows that URL, she lands on the Google Docs sign-in
page.

• For a blog post. Click the “Remove from blog” button. In the box that opens,
click OK to confirm, and Google takes the post off your blog.

Collaborating with Others
Collaborating is one of the best reasons for using Google Docs. If you’ve used a docu-
ment repository like SharePoint—where one person checks out a document, works on
it a bit, and then has to check it back in before somebody else can edit it—get ready to
change the way you think about collaboration. With Google Docs, you and your col-
laborators can edit a document simultaneously. Yup, you and up to nine of your closest
friends can all work on the same document at the same time, from any computer (or
Web-ready phone, for that matter) with Internet access.

For example, imagine a group of college students working on a report. Each student is
responsible for one section of the report. Jenna is at a computer terminal in the library,
typing up a summary of her research. Across town in his apartment, Luke inserts a
chart. At the campus coffee shop, Lisa edits Ben’s section on her laptop, while Ben—
who’s visiting his parents—uses Dad’s computer to edit Lisa’s section. When Google
Docs saves a version of the document (which it does every couple of minutes—see
page 54), each student sees the edits and additions all the others have made.

Real-time collaboration means your work gets done faster, because you can see changes
as they’re made, and respond to them immediately. And you don’t have to wait around
for other people to do their work before you can do yours.

Types of sharing

When you create a document, you own it. And that means you can do pretty much
anything you want to with it, like edit, delete, or share it with others. If you’re in the
mood to share, Google Docs lets you pick between two ways of sharing with each
person:

• Viewers. These folks can read your document, and export it to their computers.
They can’t, however, edit the document in Google Docs or invite anyone else to
work on the document.

• Collaborators. These people can both read and edit the document. They can also
export a copy of the document to their computers as, say, a Word or OpenOffice
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document (see page 55). And—if you give them permission to do so—they can
invite more people to collaborate.

Whether you invite someone as a collaborator or a viewer depends on your purpose in
sharing your document. If you want to share the first chapter of your Great American
Novel but you don’t want anyone messing with your immortal prose, invite people as
viewers. If you’re soliciting comments on the agenda for next week’s budget meeting,
invite them as collaborators. The next few sections explain how.

The Share This Document page

Mom always said it’s nice to share. In a Google document, you do that by clicking the
right-hand Share button, and then clicking “Share with others”. This opens the Share
This Document page, shown in Figure 2-34.

Figure 2-34. In the Share This Document page’s three main sections, you can invite others to share
your document, set permissions, and view sharing status. When you’ve added an email address (or
several) to the “Invite people” text box, click the Invite button (circled). The exact label on this button
reflects the kind of sharing you chose: collaborating or viewing.

The Share This Document page has several sections:

• Invite people. No big mystery what this section’s about—it’s where you select the
people with whom you want to share the document. These people can be viewers
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(who can read the document but not change it) or collaborators (who can both
read and edit the document). Type in email addresses for the folks you want to
share with (separate multiple addresses with commas) or, if you have Gmail, select
people from your Contacts list (page 273).

TIP
If you choose viewers or collaborators from your Gmail Contacts list (page 273), you
get the chance to create a group (page 278) containing those contacts. Saving them
as a group lets you email the whole list of collaborators or viewers directly from Gmail.

• Advanced permissions. If you don’t mind if collaborators invite even more people
to the party, leave the “Collaborators may invite others” checkbox turned on; if
you want to share only with those you invite, turn it off. If you’ve got a single
mailing list with lots of names, and you want to invite everyone on it, then turn on
the “Invitations may be used by anyone” checkbox. For example, say you belong
to a knitting group, and sending an email to the address
knitters@knitmadness.com results in every person in the group getting email sent
to his personal email account. This is a mailing list—one email address that actually
sends to a bunch of different people. If you send a Docs-sharing invitation to a
mailing list, leave this checkbox turned on so everyone who receives the invitation
can see your document.

NOTE
Even in Google Docs, collaboration has its limits: You can invite up to 200 viewers,
collaborators, or a combination of the two. And no more than 10 of those people can
look at or work on a document at any given time.

• Sharing information. If you haven’t shared a document with anyone yet, the right
side of the Share This Document page announces, “This document is not
shared” (as shown in Figure 2-34). If the document is shared, it says, “This docu-
ment is currently shared”, and lists whom it’s shared with. You can manage your
viewers and collaborators here, as Figure 2-35 shows.

Invite collaborators or viewers

Now that you’re familiar with the Share This Document page, you can use it to quickly
and easily invite others to view your document or work on it with you. On the Share
This Document page, enter the email addresses of the people with whom you want to
share. Since viewers and collaborators have different access permissions (see page 93),
Docs treats them as different groups, and you have to issue separate invitations for each
group. When you click the Invite Collaborators (or Invite Viewers) button, you see the
box shown in Figure 2-36.
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TIP
To see how your document will look to the viewers you’re about to invite (those
people who can read the document but not edit it), click the Share This Document
page’s “Preview document as a viewer” link. If the preview doesn’t look quite right
to you, then go back and edit the document before you share it.

In the box, compose a message (if you want to). Docs automatically inserts a link to
the document into the email it sends, so you don’t have to worry about telling others
where to find the document. You can paste a copy of the document right into the body
of the email (just turn on the first checkbox). And if you want a copy of the invitation,
then turn on the “CC me” checkbox. Click Send to invite the people you’ve chosen to
share your document with. When you share a document with other Google Docs users,
that document appears on their Docs lists.

View and manage current viewers
and collaborators here.

Figure 2-35. After you’ve shared the document with others, information about them appears here.
From here, you can email all your collaborators, all your viewers, or everyone; schedule an event for
you and those you’re sharing with using Google Calendar (Chapter 7); or stop sharing with certain
people (see page 100).
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NOTE
Not everyone requires a formal invitation. For example, maybe you announced to
your colleagues at the last meeting that everyone would be working on the CHAOS
project this week, so everyone already knows about it. Your company uses Google
Apps (Chapter 10), so you know everyone has her own Docs account. If you want to
skip the invitation email and just add collaborators or viewers to your document,
then click “Skip sending invitation”. Your collaborators won’t get an invitation email,
but they will find the document in their Docs list the next time they sign in.

Work with collaborators

When you’ve invited someone to work with you on a document, that person can get
started on it right away. Google automatically adds it to the Docs list on her Docs home
page, so she can open it and get to work. If you’re working on a document at the same
time as one of your collaborators, the other person’s name appears in a little box at the
bottom of the screen. (And your name appears on that person’s screen, as well.) Take
a peek at Figure 2-37 to see what this looks like.

When Google Docs saves the document, creating a new revision (page 102), it incor-
porates all the changes made by you and your collaborator(s), updating the document
in real time.

Figure 2-36. Customize Google’s invitation email so the recipients will know what you’re inviting
them to view or collaborate on. The email’s Subject field automatically shows your document’s title.
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TIP
If you’re working on a document with a collaborator, use Google Talk to communi-
cate via instant messaging as you work. Chapter 6 tells you all about Google Talk.

Docs’ comments feature is a good way to collaborate. You insert comments (page 66)
by clicking Insert→Comment, or by right-clicking (control-clicking) in your document,
and then, from the menu that appears, choosing Insert Comment. When you insert a
comment, Docs stamps it with your name, the date, and the time. After you’ve created
a comment, you can work with it in various ways. Click a comment to edit it. (Collab-
orators can edit each others’ comments.) Clicking a comment opens the menu shown
in Figure 2-37, which has these options:

• Close this menu. Clicking anywhere outside the menu also closes it, so this option
is kind of an unnecessary waste of mouse-pointing.

• Delete comment. When a comment is no longer apropos, choosing this option
gets rid of it.

Figure 2-37. Click a comment to edit it. You can edit any part of the comment (including the
commenter’s name and the date/time stamp), or choose one of the menu options. If someone else is
editing the document at the same time, your collaborator’s name appears in a box at the bottom of
the screen (circled).
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• Insert comment text into document. Sometimes a comment is so good it ought
to be in the document itself. This option changes the comment into regular text,
which you can then edit as part of the document. Doing this inserts the whole
comment—including the commenter’s name and the time stamp—so be sure to
delete anything you don’t want in the final document.

• Comment color. Comments are highlighted to call attention to them. Change the
highlight color by selecting from this list: yellow (used automatically), orange,
pink, green, blue, or purple. When you’ve got several collaborators working on a
document, it’s helpful to assign each person a comment color so you can tell at a
glance who made each comment.

TIP
Comments appear in Docs’ text editor, but not in a printed document. If you want
comments to appear in the printed document, convert them to text, and then high-
light them to mark them as comments.

Real-time, simultaneous editing is a great feature that can really speed up your work-
flow. Some people might get a little nervous, though, at the thought of too many cooks
spoiling your Google Docs broth. Don’t worry: If a collaborator makes changes you
don’t like, you can roll back the document to a previous version. See page 104 to find
out how.

When more than one person works on the same section at the same time, Docs tries
to merge their edits. For example, say you and your coworker Laura are setting up the
schedule for a conference. You’re both editing the schedule at the same time, and you
both jumped in to work on the first item. You type 8:00–10:00 Registration and Laura
types 8:00 Coffee and pastries. (You know Laura typed that because Docs shows her
name in the lower-right part of the screen as you both work; your name is in the same
spot on her screen.) Google checks every few seconds to refresh the document as you
both work. When Google refreshes, you’ll see something like this on your screen: 8:00–
10:00 Registration Coffee and pastries, combining your text with Laura’s.

If your edits conflict with the work someone else is doing, you can give that person a
call or send her an instant message using Google Talk (Chapter 6) to straighten out
who should be working on what. Or you can just work on another part of the document
until Laura is done with her edits (you’ll know she’s finished when her name disappears
from your screen), and then go back and make whatever changes you want. When you
save the document, your edits become the current version.
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TIP
When you’ve got several collaborators editing the same document all at once, it’s a
good idea to have each collaborator choose a different color for his text to help sort
out who made what changes. (The simplest thing is to have each person use the same
text and highlight color.) Then, when you finalize the document, simply select all
(Ctrl+A [⌘-A]), and then click the “Text color” button to change the rainbow of text
colors to basic black.

Remove a collaborator

One bad apple can spoil the whole barrel—and one bad collaborator can do similarly
nasty things to your document. There are lots of reasons why you might want to remove
a collaborator from your Google doc: That person’s phase of the project is over, or a
colleague left your organization, or somebody’s spelling is so atrocious that even the
best spell checker isn’t up to the task. Whatever your reasons, you can easily remove
any viewer or collaborator from your document.

Open the document, and then click Share→“Share with others” to get to the page shown
back in Figure 2-35. Collaborators and viewers are listed on the right side of the page.
To remove all the collaborators you’ve invited, find the Collaborators heading, and
then click the “remove all” link to its right. (The Viewers section has its own “remove
all” link.) To remove an individual collaborator or viewer, find that person’s name in
the Collaborators or Viewers list, and then click the X to the right of his name; the
person disappears from the list.

After you’ve removed a collaborator or viewer from your document, that person no
longer has any access at all to the document. Say Fred has been taken off the CHAOS
project, so he won’t need to edit the CHAOS prospectus. You remove Fred from the
Collaborators list, and the next time he signs in to Google Docs, the CHAOS prospectus
is no longer in his Docs list. (If he exported a copy of the prospectus, he still has that
copy on his computer, but he can’t work on your version in Google Docs.)

F R E Q U E N T L Y  A S K E D  Q U E S T I O N

Who’s That Collaborator?
I invited some people to share my document, but there’s a name in the Collaborators list
that I don’t recognize. How did it get there? And should I remove the stranger at once?

Occasionally, you may see a name you don’t recognize pop up in a document’s Col-
laborators list. Don’t panic: It doesn’t necessarily mean somebody’s hacked your
Google Account. When an unfamiliar name—or the name of someone you know but
swear you didn’t invite—shows up on your collaborator’s list, ask yourself these
questions:

• When you shared your document, did you turn on the “Collaborators may
invite others” checkbox? This setting lets anyone you share with send out her
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own invitations to collaborate. So the unfamiliar name may have been invited by
someone you invited. If you don’t want collaborators to bring guests along, then
turn off this checkbox when you send out sharing invitations.

• Did you share using a mailing list? If you used a mailing list (page 95) to send
multiple invitations at once, there’s a good chance that the unfamiliar name is
someone from that list. If the list is big, you can easily forget precisely who’s on it.
To make sure you know precisely whom you’ve invited, turn off the Share This
Document page’s “Invitations may be used by anyone” checkbox. This way, entire
mailing lists can’t be invited.

• Is the same person listed twice? Either you’re seeing double or your friend has
mastered the art of cloning, right? Fortunately, there’s a third explanation: This
can happen if you sent the invitation to one email address, but the recipient used
your invitation to sign in with another Google Account user name and password.
(This can happen if your friend uses email forwarding.) So the same person may
appear twice in your Collaborators or Viewers list: once with the email address
you sent the invitation to (bob@yahoo.com, say), and again with a different address
—the one he used to sign into Google (like bob@gmail.com). If you’re not sure
which is which, send your friend an email to the original address and ask which
address he uses to sign in. Then remove the other address from your Collaborators
or Viewers list to keep things tidy.

• Could it be someone you actually invited? This question isn’t as dumb as it may
sound. It’s possible that, after accepting your invitation, your collaborator changed
his Docs display name. (Anyone can do that on the Settings page [see page 48].)
If Joe Smith wakes up one morning and decides to distinguish himself in the world
by being henceforth known as Starshine Snugglebunny, he can change to his new
name in Docs. When he does, Starshine Snugglebunny suddenly appears on your
Collaborators list. Contact Joe (er, Starshine) to make sure the name is really his.
(And while you’re at it, ask him if he’s been working too hard.)

View a document’s RSS feed

As page 50 explains, RSS feeds summarize and provide links to Web site and blog
content, regularly updating these content snippets in real time. In Google Docs, you
can view an RSS feed that shows changes to a particular document. First, make sure
your Docs account is set up to allow RSS feeds (page 50). Then, open the document,
and click Share→“Share with others”. On the right-hand side of the page, click “View
RSS feed of document changes” link. This opens a page like the one in Figure 2-38.

Subscribe to a document’s RSS feed

When you view a document’s RSS feed, you can subscribe to that feed. It’s as easy as
clicking a button. Open the document, and then click Share→“Share with oth-
ers”→“View RSS feed of document changes”. What you do next depends on your
browser:
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• Firefox. Choose the newsreader you want, and then click the Subscribe Now but-
ton (shown in Figure 2-38). Firefox adds the feed to your Bookmarks toolbar.

• Internet Explorer. Click the “Subscribe to this feed” link. IE opens a box where
you can name the link and choose a reader. Do that, and then click Subscribe. IE
adds the document to your Feeds.

Turn Back Time: Your Doc’s Revision History
Whether you collaborate with others or work alone, you can view and compare dif-
ferent versions of your evolving document. Whenever Google saves one of your docs
(which it does automatically every couple of minutes), it creates a new revision of that
doc. A revision is a snapshot of the document as it exists at a particular moment in time.

Click File→“Revision history” to see the versions of your document that Docs has been
quietly amassing while you work, as shown in Figure 2-39.

Subscribe to this document’s feed here.

View the document’s feed here.

Figure 2-38. You can view an RSS feed of changes to any document in your Google Docs account. To
subscribe to a document’s feed (so you can check for recent changes from your Bookmarks toolbar),
click Subscribe Now (circled). This figure shows the RSS feed in Firefox. If you use Internet Explorer,
then the screen has the same information, it’s just arranged slightly differently.
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View a document’s revision history

When you click File→“Revision history”, you see your document’s track record: Every
time you save a change (and every time Docs does an autosave), Docs creates a new
revision and adds it to the top of the Revision history list. As you might imagine, these
versions can pile up fast, so the Revisions list focuses on the most recent ones. It gathers
older revisions into links, displayed on the right-hand side of the page (for example,
Figure 2-39 shows a link to “Revisions 7–19”.) Click the link to display those revisions.

The Revisions list has three columns:

• Revision. Every time Docs creates a new revision, it gives that revision a number;
the higher the number, the more recent the revision.

• Last Edited. This column gives the date of the last revision, and the name of the
person who edited it. (If you’re the only one working on a document—you haven’t
shared it with any collaborators—this column just lists “Me”.)

• Changes. Look here for a clue about the changes made in a particular revision.
You could have a document open and not make any changes to it for a while—say
you forget to close the document before you head out for lunch. Docs still autosaves
it, creating a new revision every few minutes and adding it to the list. If a saved
revision doesn’t have any changes from the previous version, the Changes column
says “no text added”.

Figure 2-39. Click File→“Revision history” to see how your document has changed over time. Each
item on the list is a separate version of the document. The list’s three columns (circled) help you keep
track of what changed by numbering each saved revision, noting who edited that version and when,
and giving an idea of the changes made, if any.
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If you want to look at a particular revision, click its name, and Docs displays it, as
shown in Figure 2-40.

Revert to a previous version

When you click a revision in your Revisions list to view it, what you see is a read-only
version of the document, which means you can’t edit it. To edit that revision, you have
to make it the primary version of the document by reverting to it.

Reverting simply means making an older version of the document into the current
version. Here’s the coolest part: Reverting to a previous version does not destroy sub-
sequent revisions; it simply makes the previous version the current, editable one, and
moves it to the top of the Revisions list as a brand-new version. So if you revert to a
previous version, and then change your mind—maybe you shouldn’t have chucked all
of Uncle Danny’s suggestions from the family reunion schedule—no sweat. Just click
File→“Revision history”, find the version of the document with Uncle Danny’s sugges-
tions, and then revert to that one.

To revert to a previous version of a document, follow these steps:

Figure 2-40. You can view, but not edit, a revision in this window. Above the document you see some
links and buttons (circled) that let you jump to other revisions or make this version the current one
(click “Revert to this one”).

104 | Chapter 2: Word Processing with Google Docs



1. Open the current version of the document, and then click File→“Revision history”
to get to the page shown back in Figure 2-39. On the Revisions list, find the version
you want, and then click its Revision Number on the left.

Docs opens a page showing the revision, like the one in Figure 2-40.

2. Make sure this is the revision you want to use as the current version. Then click
the upper-right “Revert to this one” button.

Docs displays a confirmation box asking whether you really want to make the
change.

3. Click OK.

Docs makes this revision the current version of the document, and then opens the
document in the text editor.

Compare revisions

When you’ve got a long list of revisions, it can be confusing to figure out which revision
holds what. And if you’ve got several people collaborating on a document and making
changes to it, you might want to see at a glance who did what from one version to
another.

Docs can help you sort it all out by letting you compare two revisions to a document.
First, open the document, and click File→“Revision history”. Then, turn on the check-
boxes of the two versions you want to compare, and then click the Compare Checked
button. Docs displays the two revisions, as shown in Figure 2-41. Each contributor
who’s worked on the document appears in the upper right, assigned a unique color to
indicate who made which change. Deletions appear as strikethrough text, additions as
highlighted text. Whether deleted or added, the text matches the color belonging to
the person who made the change.

NOTE
You can compare only two revisions at a time.

If you compare two versions of a document and want to revert to one of them, click
the Back to Revision History link. The Revisions list displays the two revisions you just
compared. Turn on the checkbox of the one you want to revert to, and then follow the
steps on page 104.

Organizing and Finding Documents
It doesn’t take very long to accumulate a long list of files in your Google Docs account.
And just as it’s hard to put your hands on one particular memo when your desk is
overflowing with papers, it can be difficult to find the document you want on your
Google Docs home page. (The words needle and haystack may come to mind.) To be
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efficient, you’ve got to be organized. Fortunately, Google Docs makes that easy. And
however you organize your documents, you’ve got Google’s searching power to help
you find them.

Organizing Your Docs List
The Docs list on your Docs home page (page 44) displays documents according to how
recently you or a collaborator has worked on them. Without any effort from you, this
list offers a great organizational tool because it groups documents according to when
they were opened: today, yesterday, earlier the week, and so on. If you know you last
looked at a document a couple of weeks ago, you don’t have to waste time scanning
today’s or yesterday’s files.

You can also use the home page’s left-hand menu to display only certain groups of
documents. For example, if you’ve created any folders (page 107), use the left-hand
menu to show only the documents in a particular folder. You can also display only docs
you’ve shared with a particular collaborator, or just spreadsheet files. The left-hand
menu offers lots of options for sorting your files; page 44 explains them all.

Deleted text

Added text

Figure 2-41. When you compare two versions of a document, collaborators (Google calls them
Authors) appear in the upper-right part of the page (circled). Changes from one version to another
are color-coded to the collaborator who made them.
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Mark important documents

In elementary school, if you did a good job on your paper, the teacher gave you a gold
star. In Google Docs, you’re in charge of distributing the gold stars. If there’s a docu-
ment you want to mark as urgent or otherwise important, find it in the Docs list, and
then click the star to the left of its name. The star turns gold to call attention to that
document. To turn a star off, just click it again.

TIP
You can easily find all your starred documents: On the bar above the Docs list, click
the Star button—it’s just to the left of the word “Name”.

Hide a document

You probably have some documents that you don’t want to throw in the Trash, but
you also don’t want them crowding your Docs list. In that case, hide them. Turn on
the checkbox next to any document you want to hide (you can select more than one),
and then click the Hide button. Like magic, the document disappears.

Google tucks it out of the way in the appropriately named Hidden list. To make a
hidden file reappear, find All Items in the left-hand menu (it should be at the top of the
list) and, if necessary, click its + sign to expand it. Then click Hidden to see your hidden
files; select the file you want, and then click Unhide. Google moves the document back
to your main Docs list.

Create a folder

Just as folders and a filing cabinet keep you from drowning in paper at the office, Google
Docs folders keep your Docs list organized by grouping related documents together.
To create a new folder, click the upper-left New button, and then click Folder. The
page changes to look like Figure 2-42. Name your folder and, if you like, fill in a de-
scription. (Descriptions appear above the list of documents in the folder.) You can also
assign a color to the folder, which makes documents belonging to a folder easy to spot
in the Docs list. Click “Choose color”, and then pick a color from the box that appears.

Docs adds the folder to the left-hand menu. After you’ve added some documents to the
folder (next section), click its name in the left-hand menu to see its contents.

TIP
You can also create subfolders. In the left-hand menu, click the folder you want to
hold the subfolder; that folder’s contents appear in the Docs list. Now, click
New→Folder. Docs creates the new folder inside the folder you chose.
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Put documents in a folder

After you’ve created a folder, it’s ready to store your documents. To do so, comb
through the Docs list for the documents you want to move, and then turn on their
checkboxes. Then, in the blue bar above the Docs list, click “Move to”. A box opens
with a list of existing folders. Select the folder you want, and then click “Move to folder”.

Docs doesn’t really move the file; it’s still right there in All Items. Instead, Docs places
a link to the file in the folder. At the same time, it labels the file with the folder’s name
(Figure 2-43). You can scan the Docs list or open the relevant folder to find documents
in that folder. And since Docs puts a copy of the file in the folder and not the original,
you can store the same document in more than one folder. For example, say you travel
a lot, and you have a folder called Hotels that contains lists of your favorite hotels in
different cities. As you plan a trip to Paris, you create another folder called Paris Trip.
You can find your list of Paris hotels in the Hotels folder and store a copy in the Paris
Trip folder, too. Storing the same document in multiple folders can make the document
easier to find—you don’t have to wrack your brain trying to remember where you filed
it.

Type the name of your new folder here.

Figure 2-42. In the text box, give your new folder a descriptive name. (If you don’t name the folder,
then Docs calls it New Folder.) You can also add a description to the folder or choose a color to label
it by clicking one of the circled links.
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NOTE
When Docs puts a copy in a folder, it’s not a static, unchanging copy. Any changes
you make to the document apply to all copies: the one in All Items of the Docs list
and those in any folders. So you never have to worry about which copy in which
folder is the current one—they all are.

Change a folder’s color

Docs’ folder colors work a lot like labels in Gmail (page 262). When you assign a color
to a folder, that color appears in the Docs list, with the folder’s name, on any documents
that belong in that folder. So folder colors can help you find the document you want
with a quick glance at the Docs list.

Sometimes, you might want to change a folder’s color—red for documents in the folder
of a project that’s approaching a deadline, for example. To change a color, in the Docs
home page’s left-hand menu, click the folder’s name. (You may have to click the + sign
next to All Folders to find it.) When you click the folder’s name, the Docs list displays
all the documents in that folder. Above the list, click “Choose color”. A box displaying
folder colors pops up; click the color you want. You can also choose Docs’ default color
(green letters on a light-green background) or “Remove color”, which makes the folder
label black letters on a gray background.

Figure 2-43. Documents in folders still appear in All Items in the Docs list, but they have a label
(circled) that shows which folder(s) they’re in (also circled).
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TIP
For a shortcut to picking a folder color, in the left-hand menu, right-click (control-
click) the folder, and then, from the color palette, choose a color.

Remove documents from a folder

To take a document out of a folder, in the left-hand menu, click the folder’s name to
open it. Next, find the document you want to pluck out, turn on its checkbox, and then
select “Move to”→“Remove from current folder” (it’s at the top of the list of folders).
Finally, click “Remove from folder”; Docs removes the copy from the folder and strips
off the file’s label.

Hide or delete a folder

If you use lots of folders, the complete folder list can get pretty long. To hide a folder,
right-click (control-click) it, and then, from the shortcut menu, select Hide. (Even when
a folder is hidden, you still see its name in the Docs list next to any files it holds.)

To delete a folder (but not the files it contains), right-click (control-click) the folder,
and then, from the shortcut menu that appears, select Delete. Docs moves the folder
to the Trash, and removes the folder’s name from the files it held (in the Docs list).
Those files still appear in All Items in the Docs list, unless you explicitly delete them.

TIP
If you use Firefox and can’t see the Docs shortcut menu when you right-click (because
the Firefox menu gets in the way), see the Tip on page 73 to fix the problem.

Searching for Documents
Because this is Google Docs, you know it’s got to be good at helping you find what
you’re looking for. When you search your Docs list, Google searches titles and body
text to find matches.

To perform a search, at the top of the Google Docs home page, use the Search box.
When you start typing the Search box, Google starts searching, as Figure 2-44 shows.
Google tries to guess the words you have in mind, and suggests the most likely match.
If Google finds what you’re looking for, click the suggestion to open the file. Otherwise,
click the Search Docs button to open a list of all results for your Search term. Click any
result to open the corresponding document in the text editor.

You can also do an advanced search of your documents, which is really handy when
you want to narrow down a long list of search results. To the right of the search box,
click “Show search options” to expand the page so it looks like Figure 2-45. The ad-
vanced search options let you specify any combination of these criteria:
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• Has the words. Search for a word or phrase inside a document. If you know that
the document you want had the word urgent in it, type urgent in this box. When
Google searches, it combs through all your documents in search of that word.

• Named. Remember the document’s title—or just a word from it? Type it into this
box, and Google scans all your documents’ titles to find it.

• Type. Tell Google to search all your files, or restrict the search to only documents,
spreadsheets, presentations, or folders.

• Search. Google usually searches all items, but you can narrow things down by
telling it to search only documents that you own, starred documents, hidden docu-
ments, or those lurking in the Trash.

• Search folders. Click this button, and then select a folder if you want to search
only within a specific folder.

• Sharing. If you created the document you’re looking for and never shared it with
anyone, use this list to search only those documents that are “Private (not shared)”.
Other options are Any, “Shared by me”, “Shared with me”, and Published.

• Shared With. Type in a name or email address here. (If you use Gmail, then Google
checks your Contacts list as you type, and tries to guess the person you want.)

• Owner is. Start typing, and Google offers suggestions. You can also search for
documents you created and own by typing me in this box.

• Date. Your choices here are Modified (when someone last changed the document)
or “Opened by me” (if you recall the last time you looked at it).

• Within. Pick a time period from 1 day to 1 year from the choices on the drop-down
list, and then give Google a date to work with. This section might look like this:
Within 2 weeks of today or Within 3 days of March 2, 2008 or Within 1 year of
5/24/09. (Google’s good at reading dates, so you have flexibility in the date format.)

Figure 2-44. Google likes to guess what you’re searching for. If it’s right, then click the suggestion to
open that document. Otherwise, click Search Docs, and then check the full list of results.
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When you’ve set your search criteria, click Search Docs. Google scours your files and
shows the results in the Docs list.

TIP
When you do an advanced search, you can save the results so you don’t have to do
the search all over again, which is handy if you frequently need to look at the same
group of documents. Click the “Save this search” link just under the Search Docs
button (it’s circled in Figure 2-45), and Google asks you to name the search. Type in
a name, and then click OK. Google saves the search results and adds them to the left-
hand menu, making them easy to find. Just click a saved search’s name to see the
documents it found.

P O W E R  U S E R S '  C L I N I C

Go Mobile with Google Docs
Way back in the Dark Ages, people used telephones for making phone calls, and that
was about it. Nowadays, when you’re not busy using your cellphone to take photos,
shoot video clips, or read text messages, you can use it to access your Google Docs.

Figure 2-45. Google gives you a lot of options for narrowing down a search. You can also save
your search results. Click “Save this search” (circled right), give the search a name, and Google
adds the search results to the “Saved searches” in the left-hand menu (circled left).
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First, make sure you’ve got the right kind of phone. If you’ve got a BlackBerry or an
iPhone, you’re good. But any phone that has a good mobile Web browser will probably
work. Because cellphone technology is improving all the time, the more recent your
phone, the more likely it is to work with Google Docs.

Fire up your phone, and then point its browser to http://docs.google.com/m. Or, if you
use Google Docs through your organization’s Google Apps account (Chapter 10), use
this address: https://docs.google.com/a/yourdomain/m (replace yourdomain with your
organization’s domain name). This gets you to a mobile version of your Docs list. From
the list, you can open documents and spreadsheets to read. At the time of this writing,
you couldn’t edit docs using your cellphone, and you could see your presentations only
if you’re on an iPhone. (Google’s updating its apps all the time, though, so it never
hurts to check back and see if things have changed.)
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CHAPTER 3

Working with Docs Spreadsheets

Start spreadin’ the news: Google Docs spreadsheets let you and up to 50—count ’em,
50—of your colleagues collaborate on a single spreadsheet simultaneously. It’s a great,
timesaving way to speed up group projects and actually get things done.

The program’s popularity has been spreading like wildfire. In the first year after its
launch in 2006, Google Docs (originally called Google Docs and Spreadsheets) grew
by 84 percent, to more than 1.6 million users—that’s a lot of number crunching! And
its growth is sure to continue, thanks to Google’s clever, highly addictive invite-and-
share system. When somebody accepts an invitation to view or work on a spreadsheet,
that person sees how easy-to-use, secure, and accessible these spreadsheets are. That’s
convinced a lot of people to switch to Google Docs as their primary spreadsheet
program.

If you’re a spreadsheet maven, you might find Docs spreadsheets a little on the basic
side. Right now, for example, you can’t use autofilters like you can in Excel. On the
other hand, Docs spreadsheets offer everything that most people need: You can sort
your data in various ways, work with formulas and functions, name cell ranges, create
forms and charts, apply formatting rules, and a whole lot more. Add the bonuses of
easy collaboration and a central location for all your spreadsheets, and Google’s take
on the spreadsheet is definitely worth a try.

Getting Started with Google Docs Spreadsheets
Before you can dive in, you need a Google Account. Chapter 2 has the full story on
signing up for Google Docs (page 42) and getting familiar with the Docs home page
(page 44).

On the Docs home page, shown in Figure 3-1, spreadsheets appear in the Docs list
along with documents (Chapter 2) and presentations (Chapter 4). Click a spread-
sheet’s name to open it. (If there aren’t any spreadsheets listed, you can create a new
one—the next section tells you how.)
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TIP
Chapter 2 gives a lot of info about organizing (page 105) and searching (page 110)
your files in Google Docs. The tips there apply to spreadsheets as well as word pro-
cessing documents.

Creating a Spreadsheet
Google Docs makes it easy to either create a brand-new spreadsheet or import an ex-
isting one. This section shows you how to do both, and then covers the basics of
entering data and saving your spreadsheet.

Starting from Scratch
Google Docs gives you two ways to create a new spreadsheet:

• From the Docs home page. In the blue bar above the Docs list, select
New→Spreadsheet. Docs opens the spreadsheet editor in a new window (Fig-
ure 3-2).

Select Spreadsheet here to display just
spreadsheets in the Docs list.

Figure 3-1. In the Docs list, the spreadsheet icon (circled) is an easy way to spot which files are
spreadsheets. To display just your spreadsheet files, under the left-hand pane’s “Items by type” section,
click Spreadsheet (you may have to click the + sign next to “Items by type” to expand the section).

116 | Chapter 3: Working with Docs Spreadsheets



• From the spreadsheet editor. If you’re already working with a spreadsheet and
need to start a whole new one, in the upper left, click File→New. Docs opens a new
window with a nice, empty spreadsheet for you to play with.

Importing an Existing Spreadsheet
You’ve probably got some spreadsheets on your computer that you work with regularly.
You can easily import them into Google Docs so you can work on them from any
computer with an Internet connection. But first you need to know about some
limitations:

• Google Docs can only import spreadsheets in certain file formats:

— Excel spreadsheets (.xls)

— OpenOffice Calc spreadsheets (.ods)

— Text files (.txt)

— Comma-separated values (.csv)

— Tab-separated values (.tsv)

— TSB files (.tsb)

Edit tab toolbar

Figure 3-2. When you create a new spreadsheet, Docs opens it with the spreadsheet editor’s Edit tab
selected. To enter data, click a cell, and then start typing. The toolbar above the spreadsheet offers
common editing and formatting tools. The tabs across the top of the page let you view and work with
the spreadsheet in different ways. The ones on the left—Edit, Sort, Formulas, and Revisions—are all
for working with this spreadsheet. The ones on the right—Discuss, Share, and Publish—are for taking
your spreadsheet public. This chapter explains all your options.
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• Google Docs also has some size limitations for spreadsheets:

— You can import only files that are 1 MB or smaller.

— A Google Docs spreadsheet can hold up to 10,000 rows, 256 columns, 100,000
cells, or 40 sheets. When your spreadsheet reaches one of those limits (which-
ever comes first), that’s it.

— A spreadsheet can’t have more than 20,000 cells containing formulas.

— Your Google Docs account can hold only 1,000 spreadsheets. (If you actively
work with more than that, call the folks at Guinness—you’re in the running for
some kind of world record.)

Import from Excel or another spreadsheet program

If you want to transfer a spreadsheet that lives on your computer into Google Docs,
you can do so from the Google Docs home page or from the spreadsheet editor (shown
in Figure 3-2).

• From the Docs home page. In the upper left, click the Upload button. On the
Upload a File page that appears, click the Browse button to open a window where
you can find the file you want. Select the file, click Open, and then click Upload
File. Docs adds the file to your Docs list, and then opens the file.

• From the spreadsheet editor. If you’re working on an open spreadsheet, in the
upper left of your screen, select File→Import to open the Import File box. Click
Browse to open a window where you can pinpoint the spreadsheet you want to
import. Click the file’s name, and then click Open. Docs imports the file (adding
it to your Docs list), and changes the Import File box to look like the one in
Figure 3-3. Click “Open now” if you want to work on the file now. If you’d rather
save it for later, click Cancel (you’re not canceling the import—you’re just telling
Google you don’t want to view it right now). Later on you can find the imported
file in the Docs list on your Docs home page (page 44).

TIP
The box on page 133 teaches you how to import a spreadsheet into Google Docs,
and add it to an existing Docs spreadsheet as a new sheet (page 131).

Email a spreadsheet to Google Docs

You can email yourself a spreadsheet and have Google add it to your Docs list. This
way, you can quickly upload several spreadsheets at once.

Click the Docs home page’s Upload button; the page that opens contains an email
address that’s unique to your Docs account. Use this address to send yourself an email
with a spreadsheet attached. When Docs gets the email, it adds the attachment to your
Docs list. You can send more than one attachment per email, but Docs can only handle
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up to ten attachments at a time, so don’t get carried away. (If you need more info on
how to email a file to Google Docs, page 53 has details—just attach a spreadsheet
instead of a text document.)

TIP
If the spreadsheet you’re importing has a chart in it, the chart doesn’t import with
your data. Import the spreadsheet, and then recreate the chart in Docs (page 156
tells you how to turn spreadsheet data into a chart).

Spreadsheet Basics: Entering Data, Selecting Cells, Navigating, and More
A brand-new spreadsheet looks pristine and full of potential, or intimidatingly empty,
depending on your point of view. To start entering data into a cell, just click the cell,
and then type. To move rightward, to the next cell in the row, hit Tab. To move down-
ward, to the next cell in the column, hit Enter (Return). You can also use the arrow
keys to hop from one cell to another.

To select a range of cells, click the cell where you want the range to begin, hold down
the Shift key, and then click the last cell in the range. To select a whole row, click its
number on the left side of your screen; to select a whole column, click its letter at the
top of the spreadsheet. And to select the entire spreadsheet, click the blank square that’s
above row 1 and to the left of column A.

Figure 3-3. When you import a file while you’re in the spreadsheet editor, you may or may not want
to work on the new file right away. After Docs imports the file, you can view it by clicking the “Open
now” link (circled). If you don’t want to work on it just yet, click Cancel to stay in the current
spreadsheet. The imported file gets added to your Docs list, so you can open it anytime.
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If you need to enter the same piece of information several times, Docs tries to help you
out by guessing what you’re typing. For example, if you enter transportation in a
spreadsheet of travel expenses, and then type tra in a new cell, Docs fills in the rest of
the word for you. (Note that this works only for cells that are in the same column.) If
you want Docs to enter transportation in that cell, just hit Enter (Return). If you don’t
want to accept what Docs suggests, just keep typing to ignore the suggestion.

As you work on your spreadsheet, you can use the upper-left File button to do lots of
useful stuff:

• New opens a brand-new spreadsheet in a brand-new window.

• Import uploads a file (page 117) from your computer into Google Docs.

• Open brings up a box that displays all your spreadsheets; choose one to open it.

• Save lets you name and save a new spreadsheet. (When you create a new spread-
sheet, Docs calls it Unsaved spreadsheet until you give it a different name.) After
you’ve done that, Docs automatically saves your spreadsheet every 10 minutes.
(For more about saving spreadsheets, see page 122.)

• Copy spreadsheet creates a new spreadsheet that’s an exact copy of the one you’re
working on. When you choose this option, Docs opens a box that lets you name
and save the new spreadsheet.

• Print starts the process of printing the current spreadsheet. This is one of two ways
to print—the other is the upper-right Print link. For more about printing, scoot
over to page 163.

• Export lets you save a spreadsheet to your computer or open it in an offline
spreadsheet program like Excel, as page 123 explains.

• Upload new version imports a version of the same spreadsheet from your com-
puter and replaces the contents of the current Docs spreadsheet with the new
version’s data. (See the Tip on page 124.)

• Rename gives the current file a new name.

TIP
You can also rename an open spreadsheet by clicking its title in the page’s upper left.

• Spreadsheet settings lets you change the locale and time zone for the current
spreadsheet. (In general, these settings are the same for your spreadsheets as they
are for your Docs account; page 47 walks you through the Google Docs Settings
page.) This ability is handy if you’re working on a spreadsheet while traveling.

• Close closes the current spreadsheet. If you’ve started working on a new spread-
sheet and haven’t saved it yet, Docs reminds you to save before you close.

As you can see back in Figure 3-2, the Docs spreadsheet editor has a toolbar at the top
that puts various formatting and data entry tasks at your fingertips. From left to right,
here’s what’s on it:
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• Undo. Made a mistake? This button erases it.

• Redo. If you’re having second thoughts about what you just undid with the Undo
button, click this button.

• Cut. Copies the contents of the selected cells to your clipboard, and removes the
content from your spreadsheet.

• Copy. Copies the contents of the selected cells to your clipboard, but leaves the
content in your spreadsheet.

• Paste. When you click this button, you can paste values only (the actual info inside
the cells), format only (the way the cells’ content is formatted, including stuff like
alignment and date or currency formats, minus the actual content), or both values
and content.

TIP
To speed up your data entry, use the Google Docs keyboard shortcuts listed in
Appendix A.

• Format. Clicking this button gives you a range of options: You can have Docs
round up to whole numbers or show two decimal places for numeric data (whether
your spreadsheet contains financial info, percentages, or plain ol’ numbers),
choose a currency, pick a format for dates and times, or use plain text (to treat
numbers as text, rather than numeric data). Choose Normal to go back to the
default format (page 126 tells you more about formatting data).

• Bold.

• Italic.

• Underline.

• Strikethrough. 

• Font style. You don’t have a lot of choices here compared to the options in Excel,
but nobody’s looking at your spreadsheet to admire its fancy fonts.

• Font size. You can choose from a range of 6 to 36 points.

• Text color. You’ve got 40 to choose from.

• Background color. Make a row, column, or cell stand out by colorizing its back-
ground.

TIP
You can create rules to apply a text or background color automatically under cir-
cumstances you specify—page 127 tells you how.

• Borders. You can choose from borders around every cell, no borders at all, and
just about everything in between.
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• Clear format. If you’ve made a formatting choice that doesn’t look right, undo it
with a click of this button. (Unlike the Undo button, which only undoes your last
action, this button works even if you’ve made changes to your spreadsheet between
now and when you originally applied the formatting.)

• Align. Here’s where you choose a horizontal or vertical alignment (or both) for
the contents of cells.

• Insert. Use this button to insert a row above or below the current one. It also lets
you insert a chart (page 156), a comment (page 176), a gadget (page 161), or an
image (page 139).

• Delete. Here you can choose to delete a specific row or column or clear the contents
of the currently selected cell. You can also delete any comments added to a cell.

• Wrap text. Leave this checkbox turned on to make text wrap so it fits the width
of the cell it’s in; turn it off to prohibit wrapping. When wrap text is turned off,
you see a normal-sized cell, but you have to click the cell to expand it and read all
the text it contains.

• Add. This button let you create a chart (page 156) or a gadget (page 161) from
the spreadsheet’s data.

• Merge across. If you want one cell to stretch across several columns (this works
well for subheadings, for example), select the cells, and then click this button to
merge them into one. Break up a merged cell by clicking this button again (its name
has changed to “Break apart”).

Saving a Spreadsheet in Google Docs
Saving a Docs spreadsheet is a little different from saving a Docs word processing
document. When you open a new spreadsheet, you have to save it manually the first
time. After that, Docs takes over with its usual autosaving every 10 minutes. To make
sure you name and save a new spreadsheet, Docs puts up a warning box when you start
entering data, as shown in Figure 3-4.

You have several ways to name and save your new spreadsheet:

• Click the left-hand File button, and then choose Save.

• Click the upper-right Save button.

• If you’re done with the file for now, then click the upper-right Save & Close button.

Whichever way you choose, Docs opens a box where you can name the spreadsheet.
Enter a name, and then click OK; Docs saves the spreadsheet with its new name. If you
clicked Save & Close, then it also closes the spreadsheet.

After you’ve saved a new spreadsheet for the first time, your options for saving change.
On both the File menu and the upper-right Save button, the Save option changes to
Automatically Saved and gets grayed out so you can’t click it. This is Google’s way of
saying, “Leave the saving to me.”
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Of the three options for saving a new file manually, the only one left is Save & Close.
When you’ve finished editing a spreadsheet, click this button to save any changes
Google hasn’t caught yet with an autosave, and go back to the Docs home page.

WARNING
Make sure you click Save & Close when you’re done working on a spreadsheet. If
you just exit the spreadsheet by closing its window, Google may not save all your
changes.

Exporting a Spreadsheet
In Google Docs, exporting a spreadsheet means downloading it to your computer,
where you can save it and work on it in a PC-based program like Excel. When you
export a spreadsheet, you can save it in one of these file formats:

• ODS (OpenOffice Calc)

• XLS (Microsoft Excel)

• CSV (comma-separated values)

• HTML (hypertext markup language, used to create most Web pages)

You can save a new spreadsheet
using the File menu.

When you start working on a new
spreadsheet, Docs reminds you
to save it.

Figure 3-4. When you create a new spreadsheet, it’s up to you to save it the very first time (as Docs
reminds you when you start entering data). You can save a new file by choosing File→Save, or by
clicking one of the upper-right Save buttons (circled).
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• TXT (a text file; tabs separate the values)

• PDF (portable document format, compatible with Adobe Reader)

Start by opening the spreadsheet you want to export, and then selecting File→Export.
From there, the process varies a bit, depending on what kind of file you’re exporting,
as explained in the next three sections.

TIP
Thanks to Google Gears, you can view Google spreadsheets even when you're not
connected to the Internet. See page 79 to learn about Google Gears.

Export a spreadsheet to Excel or OpenOffice Calc

When you export to either the OpenOffice Calc or Excel formats, you can either open
the file right away or save it to work on later. Here’s how:

1. After you’ve opened the file and clicked File→Export, choose either .ods (for Calc)
or .xls (for Excel) as the file type.

Your Web browser asks how you want to handle this file: Save it to your computer
or open it with the appropriate program.

2. Make your selection, and then click OK.

Your computer downloads the spreadsheet and either saves it or opens it, depend-
ing on your choice.

TIP
After you’ve done some offline editing of the spreadsheet, you can import your revi-
sions back into Google Docs by uploading the revised copy. Open the Docs spread-
sheet you want to update, and then select File→“Upload new version”. Find the
updated file, and then upload it into Google Docs.

Export a spreadsheet as a CSV, HTML, or text file

When you export a file in one of these formats, Docs converts the file, and then opens
it in a new browser window. From there, you can use your Web browser’s File menu
to save the file and reopen it in your spreadsheet program. Nearly all spreadsheet and
database programs understand the CSV format, making it a handy way to get your data
out of Docs.
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NOTE
When you export as a CSV, HTML, or TXT file, you export only the current sheet
—Docs can’t export multiple sheets in these formats. If you need to export multiple
sheets into one file, you have to export them separately, and then copy and paste
each sheet into a single document.

Export as a PDF

PDF, which stands for portable document format, preserves a document’s formatting
and lets people view or print it on nearly any computer that’s running today (Windows,
Mac, Linux, whatever). When you select File→Export→.pdf, Docs opens the box shown
in Figure 3-5, which is where you make decisions about how the PDF will look:

• What parts? Tell Docs whether to convert just the currently open sheet or all the
sheets (if the spreadsheet has more than one sheet).

• How big? Do you want to adjust the spreadsheet to fit the page (which can scrunch
down the sheet and make it hard to read) or leave it actual size?

Figure 3-5. Here’s where you tell Docs how to format the PDF you’re about to export. If you select
“Fit to width”, Google shrinks your spreadsheet if necessary to make sure it fits across the page.
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• Repeat row headers on each page. Turn on this checkbox if your spreadsheet
occupies several printed pages—this way viewers will know what the data in each
column refers to.

• Which way? Choose landscape (horizontal orientation) or portrait (vertical ori-
entation).

• What paper size? Your choices here are letter (8.5" × 11"), legal (8.5" × 14"), or
A4 (210 mm × 297 mm).

After you’ve chosen your settings, click Export. Google converts the file to a PDF, and
opens a window asking whether you want to save or open the PDF. Make your choice,
and then click OK to export the PDF.

Formatting a Spreadsheet
When a spreadsheet is nothing but a gaping expanse of rows and columns, it can be
tough to read. With a few quick formatting tricks, though, you can snazz up your
spreadsheet, making it easier on the eyes—and its data easier to read.

Format Text
To format text, select the cell or range of cells to which you want to apply formatting
(see page 119 for tips on selecting ranges of cells), and then choose a formatting option
from the Edit toolbar (page 120 explains what the various toolbar buttons do).

Format Numbers
When you start a new spreadsheet, all cells use the Normal format—which treats
numbers as just plain numbers, not percentages or currencies or anything special—
until you tell Google Docs to use some other kind of formatting. If you’ve got a column
holding a particular kind of numeric data, such as dollar amounts or percentages, then
you can tell Docs to give those numbers dollar signs or percent symbols. You can also
specify whether you want numbers to show decimal places, or you can round your
figures to whole numbers.

You can also change numbers from one numeric format to another. For example, if a
column contains decimals (.10, .05, .74, 1.26, and so on) and you think those numbers
would be easier to understand as percentages, select the column, and then click For-
mat→Percent. The numbers change to 10%, 5%, 74%, 126%. Pretty nifty.

To format all the numbers in a column, select the column you want by clicking the
letter cell at the top of the column (A, B, C, and so on), and then click the Format
button. The top part of its menu gives you the formatting options shown in Ta-
ble 3-1 (date formatting is explained in the next section).
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Table 3-1. Numeric Formats in Spreadsheets

Format Example

Rounded 1,500

2 Decimals 1,500.00

Financial rounded (1,500)

Financial (1,500.00)

Currency rounded $1,500

Currency $1,500.00

Percent rounded 99%

Percent 99.00%

TIP
To change from dollars to another currency, select the cells you want to format, and
then click Format→“More currencies” to choose from a whole treasure chest of cur-
rencies: euro, pound, yuan, zloty, ruble, baht, peso, rupee—more than two dozen in
all. In the unlikely event that your currency isn’t on the list, you can add it. Type it
into the list’s “Another currency” box, and then click OK.

Format Dates and Times
Organizations can be pretty picky about how to format dates. Should it be mm/dd/
yyyy or dd/mm/yy? Or does it have to be spelled out, like this: August 24, 2008? Maybe
dates and times need to go together. And do you run on a 12-hour clock (4:15 P.M.)
or a 24-hour clock (16:15)?

However you want to format dates and times, Docs can do it. When you select a cell
or range of cells and click the Format button, the bottom part of its menu shows three
common date formatting options. But if those won’t do, click “More formats”. Another
menu flies out, giving you even more choices. You’re sure to find one you can work with.

Create and Apply Formatting Rules
Formatting is great, but who wants to take the time to apply it row by row or column
by column? Luckily, you don’t have to. Instead, you can create formatting rules
that Docs applies to cells or cell ranges that meet the criteria you specify. Formatting 
rules let you change the text and/or background color of a cell (or range of cells)
automatically.

For example, say you’re managing a project and you create a spreadsheet to assign and
track tasks. You might organize the spreadsheet with a section headed by each team
member’s name, followed by their assigned tasks, and highlight those section headings
to make it easy to check out a particular person’s responsibilities. Then, to make sure
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everyone’s paying attention to deadlines, you could format columns containing dates
with an eye-catching color. Whatever you want to call attention to, formatting rules
help you do that—automatically.

To create a formatting rule, open the spreadsheet where you want to apply the rule,
and then follow these steps:

1. Select the cell or range of cells you want to format. (If you want to apply formatting
rules to the whole spreadsheet, click inside the box above row 1 and to the left of
column A.) Click either the Text color or the Background color button (it doesn’t
matter which), and then turn on the “Change with rules” checkbox.

Docs opens the “Change colors based on rules” box shown in Figure 3-6.

Figure 3-6. The drop-down menus on the left let you choose the different triggers for the rules, which
can be based on text, whether a cell is empty, dates, or numeric data. Select a trigger, such as “Text
contains” or “Date is after”, and then specify the criteria. Here, the rules apply to text containing the
word phase (case doesn’t matter) and dates later than today. To create another rule, click the “Add
another rule” link (circled). To delete a rule, click the X to its far right.

2. Create a rule. Rules follow this syntax: When a cell’s contents do/do not meet a
specific criterion, apply/do not apply this text color and/or background color. Here
are a couple of examples of how that might play out in real life: “When text in a
cell contains the word phase, give the cell a dark blue background and yellow
lettering.” Or “When a cell contains a date after today’s date, show that date in
red.” If you want to create another rule, click the “Add another rule” link, and the
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box expands so you can do just that (for up to five rules total). When you’re all
set, click the “Save rules” button.

Docs applies the rules you created. Now, when you enter data that meets a rule’s
criteria, Docs applies the rule’s formatting automatically.

A few things to keep in mind about formatting rules:

• Formatting rules apply only to the range of cells you selected. If you add rows or
columns later, you have to specifically apply the rules to those new cell ranges.
(You do this by either selecting the new cells and recreating the rule used elsewhere,
or selecting the original cells and the new ones, and then turning the “Change with
rules” checkbox [see step 1 above] off, then back on, and then clicking the “Save
rules” button.)

• If you copy a range of cells, and then paste them elsewhere in the same spreadsheet,
the formatting travels with them—Docs applies the formatting rules to the pasted
cells. If, however, you paste those cells into a new spreadsheet, your formatting
rules don’t apply (you have to create fresh rules for each new spreadsheet).

• You can have up to five formatting rules for one spreadsheet.

• If you create more than one formatting rule, Docs applies them in the order you
created them (in other words, it gives priority to the top one in the list).

Adding and Deleting Rows and Columns
Spreadsheets have a tendency to get bigger and bigger (maybe that’s why they call them
spreadsheets). If your data is growing and you need more cells to contain it, you’ve got
a couple of different ways to add new rows or columns. First, select a row or column
that will be next to the new row or column. To select, click the row’s number on the
left of the column’s letter at the top of your spreadsheet. Then, either right-click (con-
trol-click) or on the toolbar, click Insert. If you selected a row, then you can insert a
new row above or below the selected one. If you selected a column, then you can insert
the new column to its left or right.

Want to add multiple rows or columns? Select the number of rows or columns you
want to add (by holding down the Shift key as you click the rows or columns), and then
right-click (control-click) or click the Insert button and make your choice from the
menu; Docs inserts a group of blank rows or columns identical to the number you
selected. So if you need to add 10 new rows to the bottom of your spreadsheet, select
the last 10 rows, right-click (control-click) or click Insert, and select “10 rows below”.
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TIP
To double the size of your spreadsheet, select the whole thing by clicking in the square
that’s above row 1 and to the left of column A, and then click Insert. If your spread-
sheet is 100 rows long and 15 columns wide, for example, the Insert menu has options
for adding 100 new rows or 15 new columns.

Move Rows or Columns
You can move rows or columns by cutting and pasting them, but Docs has a faster,
easier way. To move a row or column (or any cell or range of cells, for that matter),
first select what you want to move. Then, move your cursor to an edge of the selection
so that it changes to a pointing hand. Drag the cells to their new location. Release the
mouse button, and the cells jump from their old location to their new home. Easy, huh?

TIP
When you’re moving a row or column, make sure there’s a place to move it to: Create
an empty row or column first. Otherwise, you may lose data. If you move, say, a row
on top of an existing row, then Docs pastes the moved data over what was already
there.

Hide a Row or Column
A Google Docs spreadsheet can hold up to 100,000 cells—that’s a lot of data. And you
probably won’t need to display it all at once. Or maybe you want to print out the part
of a spreadsheet that lists employee names, job titles, and phone extensions, but not
sensitive info like Social Security numbers and salaries. You can easily hide any rows
or columns that you don’t want showing in the spreadsheet.

To hide a row or column, just select the one you want, and then right-click (control-
click) to bring up the shortcut menu. From there, select “Hide row” or “Hide column”,
as appropriate. Docs hides the row or column, making your spreadsheet look like the
example in Figure 3-7. You can hide a whole range of rows or columns all at once by
selecting several by Shift-clicking each one.

Delete Rows or Columns
To get rid of a row or column, select it, either right-click (control-click) or click Delete
in the toolbar, and then, from the menu that appears, choose what you want to delete.
Docs deletes the row or column and all its contents.
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NOTE
If you want to clear a row or column—which gets rid of the cells’ data but leaves the
row or column in place—you can do so by right-clicking (control-clicking) or by
clicking the Delete button in the toolbar. Then, choose Clear instead of Delete.

Working with Multiple Sheets
Often, you have related data in separate spreadsheets that you want to keep together
in one file. For example, if you plan a lot of events, you might have one spreadsheet for
venues, one for caterers, and another for entertainment. It would be chaos to try to mix
these together into a single spreadsheet, but it would be great to keep a spreadsheet for
each category in the same file.

Figure 3-7. When you hide rows or columns, small tabs appear (circled) to show that something isn’t
on display. In this example, column F is hidden and so are rows 8 and 15. To bring a hidden row or
column out of hiding, just click its tab.
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You can keep all these spreadsheets together in the same file using sheets, which let you
stack spreadsheets on top of each other so you can hop between them without opening
a new file. With just one click, you can add a new sheet to an existing spreadsheet.
With the spreadsheet open, click the lower-left Add Sheet button, shown in Fig-
ure 3-8. Docs creates and opens the new sheet. Below the sheet in the lower left are
links where you can click back and forth between sheets. The current sheet displays as
a button with a drop-down arrow. Click it to choose among these options:

• Delete

• Duplicate

• Rename

• Move left/right

Sheets start out with names like “Sheet 1” and “Sheet 2,” so it’s a good idea to give
them descriptive names using the Rename option. The Move option lets you change a
sheets place in the stack of spreadsheets.

Figure 3-8. The Add Sheet button does just what it promises—adds and opens a new sheet to your
spreadsheet. When a sheet is open, click the down arrow next to its name to choose one of the options
shown here: delete, duplicate, rename, or move.
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TIP
When you add new sheets to an existing spreadsheet, you probably want the new-
comers to have the same formatting as the original. Here’s how to make that happen:
Click the name of the current sheet in the lower left, and then select Duplicate. This
creates an exact copy of the original sheet. Rename the copy, select all its cells (click
the square above row 1 and to the left of column A), and then clear the data by
selecting Delete→“Clear selection”. The data disappears, but the formatting remains.

F R E Q U E N T L Y  A S K E D  Q U E S T I O N

Importing New Sheets
How do I add an Excel spreadsheet to an existing Docs spreadsheet?

If you’ve got an existing Google Docs spreadsheet, you can import another spreadsheet
and tack it onto your Docs spreadsheet as a new sheet. Say you’ve been tracking on-
the-road business expenses in Google Docs (a great idea, since Docs is so accessible).
At home on your personal computer, you have a different spreadsheet that tracks non-
travel business expenses in Excel. To make things easier at tax time, you want all that
info in one big Docs spreadsheet, with one sheet named Travel Expenses and a second
named Other Expenses.

You can’t import a spreadsheet from your computer directly into a Google Docs
spreadsheet as a new sheet, but you can get the same result by following these steps:

1. Open the Google Docs spreadsheet that will hold the imported info. Then click
File→Import to upload the new spreadsheet into Google Docs (page 118). Find the
file you want to upload, and then click “Open now”.

Docs opens the imported file in a new window.

2. In the imported spreadsheet, select its contents. (Click in the top-left cell, and then,
while holding down the Shift key, click in the bottom-right cell. You can also select
the whole sheet by clicking in the upper-left box that’s above the 1 and to the left
of the A.) Right-click (control-click), and then, from the pop-up menu, select Copy.

Docs copies your selection.

3. Go back to the widow with the spreadsheet where you want to add the copied info,
and then click the bottom-left “Add sheet” button.

Docs adds a new sheet and opens it.

4. Click cell A1 (the upper-left cell) to put the cursor there. Right-click (control-click),
and then, from the pop-up menu, select Paste.

Voilà! Docs adds the info you imported to the new sheet.

From there, you can give the new sheet a name (page 132), and delete the imported
spreadsheet (page 166)—you’ve got its data where you want it, so you don’t need a
whole extra spreadsheet hanging around.
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NOTE
No matter how much work you have to do, you can’t have more than 11 spreadsheets
open at once in Google Docs. (This number doesn’t include sheets—page 131—just
individual spreadsheet files.)

Adjusting Cell Sizes
If you’ve ever squinted at a jam-packed spreadsheet, you know that adjusting the height
of a row or the width of a column can make the spreadsheet a whole lot easier to read.
To do this in Docs, move your cursor to the part of the spreadsheet that labels the
columns or rows—the light blue area just above or to the left of the spreadsheet’s cells.
Place your cursor on the border between two columns or rows. A thick bar appears on
the border, and the cursor changes to a double-headed arrow, as shown in Fig-
ure 3-9. Now you can drag to adjust the position of the border (and with it the size of
the row or column). If you double-click while the cursor is a thick bar, the row or
column automatically resizes to fit the longest entry in that selected row or column.

TIP
To resize all the rows or columns in a sheet, select the entire sheet, and then resize.

Figure 3-9. When you position your cursor as shown here (circled), you can resize rows or in your
spreadsheet. Move it to the top of your spreadsheet to resize columns.
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Timesaving Data Entry Tricks
There’s a lot more to working with spreadsheets than typing in a cell, hitting Tab, and
then typing in the next cell. The following sections show you different ways to work
with data more efficiently.

Auto-Fill
Entering data in a spreadsheet can get repetitive. Auto-Fill cuts down on the drudgery
with one-click copying and pasting, so you don’t have to type the same content over
and over a million times. For example, imagine you use a spreadsheet to schedule
employees’ hours, one sheet per month. When a new week rolls around, you don’t
want to have to type in everyone’s name in column A all over again. That’s where Auto-
Fill comes in. Auto-Fill lets you select a range of cells, and pop their content right into
a group of adjacent cells. Here’s how:

1. Select the range of cells whose contents you want to copy. For example, in the
employees’ name example, you’d copy everyone’s name.

As Figure 3-10 shows, a teensy blue box appears in the selection range’s lower-
right corner.

2. Position your cursor over the little blue box, so the cursor turns into crosshairs.
Then, drag the selection box to encompass the cells you want to Auto-Fill. When
you’ve expanded the selection box to whatever size you want to fill in, let go of the
mouse button.

Docs fills the blank cells with the text you selected, in the same order as the original.
If you selected fewer cells than are in the range whose contents you copied, Docs
fills in as many new cells as you selected, and leaves off any Auto-Fill text that it
doesn’t have room for. If you selected more cells than the original range, Docs fills
in the Auto-Fill text from beginning to end, and then starts over again.

You can Auto-Fill cell ranges adjacent to the cells in your selection range—above, be-
low, to the left, or to the right—but you can’t use Auto-Fill to skip over cells.

TIP
If Google recognizes a pattern in the cells you’re copying, it completes the pattern
automatically. For example, if you want to Auto-Fill 3 years’ worth of months down
column A, then you don’t have to type in the names of all 12 months before you can
Auto-Fill. Type enough to make the pattern recognizable, such as January in A1,
February in A2, and March in A3. Select those 3 months for Auto-Filling (so the little
blue box appears in the March cell’s bottom-right corner), and then stretch the Auto-
Fill area down to A36. Docs fills in 3 years’ worth of months—not just those you
typed but also April, May, June, and so on—all the way down the column.
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Copy Data
Auto-Fill is a super-simple way to copy data from one range of cells to an adjacent
range. But if you want to copy a range of cells and paste their data somewhere else—a
new sheet, a different spreadsheet, a non-adjacent section of this spreadsheet, whatever
—copying data is almost as easy: Select the range of cells you want to copy, and then
right-click (control-click) to bring up a menu. Select Copy, and then go to the sheet or
location where you want the copied cells to appear. Select a range the same size as you
copied from (for example, if you copied five rows by three columns, select five rows
and three columns in the new location). Right-click (control-click), and then from the
context menu, select Paste. Docs pastes in your data.

Here are three other ways to copy data:

• Copy from one cell to multiple adjacent cells. Select the cell that holds the
content you want to copy. Then select the range of cells that you want to copy the
content to. (To select the cells, hold down the Shift key while using the down and
right arrow keys to determine the size of the range.) After you’ve selected the target
range, press Ctrl+D (⌘-D) to copy down or Ctrl+R (⌘-R) to copy right. You can
only use this trick to copy down or to the right, but if you copy down and then to

Figure 3-10. The shaded area in column A is the area selected as the Auto-Fill source. Click and
drag the little box in its lower-right corner (circled) to where you want to copy the selected text,
as indicated by the dotted line.
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the right (or vice versa), you can fill in a large range of cells with just a couple
keystrokes.

• Copy a sheet within an existing spreadsheet file. Find the sheet you want to
copy. In the bottom part of the page, click the down arrow next to the current
sheet’s name. From the menu that pops up, select Duplicate. Docs copies the sheet
and inserts it, with the name “Copy of [current sheet’s name]”, into your spread-
sheet.

• Copy an existing spreadsheet to create a new one. This one’s simple. Open the
spreadsheet you want to copy, and then select File→“Copy spreadsheet”. Docs
opens a box where you can name the copy. Name it, and then click OK. Docs opens
the new copy, and adds it to the Docs list on your Docs home page.

NOTE
If the spreadsheet you’re copying has multiple sheets, then the new copy has those
sheets, too.

Clear Data
When you want to delete data—whether it’s the contents of one cell or of an entire
spreadsheet—select the range of cells whose data you want to flush. Then right-click
(control-click) or, on the toolbar, click Delete, and then choose “Clear selection”. Docs
zaps the contents of all the cells in the range.

NOTE
Clearing the contents of cells doesn’t get rid of their formatting. To unformat a cell
or range of cells, on the toolbar, click the “Clear format” button.

Summing Up a List of Numbers
When you’ve got a long column filled with numbers, you really need the ability to add
all or some of them quickly. Google Docs has a Quick Sum feature that lets you do just
that.

To add up the contents of a column, select a range of cells. Quick Sum adds up their
contents and displays the total in the spreadsheet’s lower-right corner, as shown in
Figure 3-11. Click the sum to see more info about the numbers in the selected range.

NOTE
Quick Sum doesn’t just work on individual columns or rows. You can select a larger
range of cells—say 10 rows and three columns—and Quick Sum works its magic on
the whole range.
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W O R K A R O U N D  W O R K S H O P

When Quick Sum Won’t Sum
If Quick Sum doesn’t add up the numbers you selected, the first thing to check is how
many cells you’re trying to add. Quick Sum doesn’t work on more than 1,000 cells.

If that’s not the problem, you may need to tinker with your spreadsheet’s settings.
Quick Sum works most reliably when the spreadsheet’s location is set to the United
States. If your locale is something other than the U.S. (or if you’re not sure what country
the spreadsheet is set to), then click File→“Spreadsheet settings”. In the Spreadsheet
Settings box, check the drop-down menu under Locale. If it says anything besides Uni-
ted States, click the arrow and choose United States from the list. Changing the locale
for a particular spreadsheet doesn’t affect the settings of other spreadsheets in Google
Docs or of your Google Account (page 7).

Select a range of cells… …and QuickSum totals
them here.

Figure 3-11. Quick Sum adds the numbers you select, displaying the total in the lower-right corner
of the spreadsheet. Click the sum to see more about the selected range, including its average, count
(how many numbers are in the range), and smallest and largest numbers.
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Still have trouble getting Quick Sum to work? If the numbers you’re trying to add are
currency amounts, select the column, and then click Format→“More currencies”→dol-
lar, and then try Quick Sum again. If it’s still not working, you’re probably using a
language other than English to interact with Google Docs. Go to the upper-right part
of the spreadsheet, and then click Docs Home→Settings. On the Settings page’s General
tab (page 48), change the language to English (US).

Quick Sum works based on your location, and Google began by making it work for
people in the U.S. But Google realizes that people all over the world use spreadsheets,
and they’re improving Docs all the time, rolling out Quick Sum for other locations as
well. If Quick Sum doesn’t work right for your locale, it should before long. In the
meantime, try this workaround.

Checking Your Spelling
Unlike the Docs text editor, the spreadsheet editor doesn’t have built-in spell checking.
But you have a couple of ways to check the spelling of the words in your spreadsheet.
If you use Firefox as your Web browser, Firefox 2 and later has a built-in spell checker.
To turn it on (if it’s not already), open Firefox for Windows, click Tools→Op-
tions→Advanced, and then click the General tab. If you’re using a Mac, click Fire-
fox→Preferences→Advanced. In the Browsing section, turn on the checkbox labeled
“Check my spelling as I type”, and then click OK. With spell checking turned on,
Firefox puts a dotted red line under words it doesn’t recognize as you type in your
spreadsheet. (Once you move to a different cell, you don’t see an underline even if a
word is spelled wrong—Firefox checks spelling only while you’re typing in a cell.)

TIP
Download or upgrade to the latest version of Firefox at www.firefox.com (http://
www.firefox.com).

If you’ve installed the Google Toolbar (page 20), then you can use that to check your
spelling in Google Docs spreadsheets; a spell check button comes with the standard
buttons. The Toolbar’s spell checker doesn’t check your spelling as you type (which
can be kind of distracting, anyway), but one click checks spelling throughout your
spreadsheet.

Inserting Images
When you import a spreadsheet into Google Docs (page 117), any charts contained in
the spreadsheet don’t join your data for the import ride. Bummer. But you can use a
workaround (though it’s clumsy): To get charts into Docs, you have to save each chart
as an image, and then insert the image into your spreadsheet. More encouragingly, you
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can also insert other kinds of images, such as a company logo or photos of your toddler
as you update her height and weight.

Before you insert an image into a Docs spreadsheet, you should know a few things:

• The image has to live somewhere on the Web. Docs needs a Web address for
any image it inserts into a spreadsheet. If it can’t find it on the Web, it can’t display
the image—so you can’t insert images that are saved only on your computer.

TIP
You can easily store images on the Web by opening a free account with a photo-
sharing site such as Flickr, Snapfish, Photobucket, or Google’s own Picasa Web
Albums. When you upload an image file (it doesn’t have to be a photo) to one of
these sites, the site stores the image for you and gives it a unique URL, which you
can copy and use to insert the image into a Google spreadsheet or other Google doc.

• There’s a size limit. The image can’t be bigger than 500 pixels in width or height.
If yours is bigger than that, edit it to make it smaller before you try to insert it.

• You can’t insert an image just anywhere. If you’ve frozen some rows or columns
in your spreadsheet (page 144), you can’t insert the image into the frozen section.

Once you’ve got the Web address for the image you want to upload, you’re ready to
insert it into a spreadsheet. Just follow these steps:

1. Open the spreadsheet into which you want to insert the image. Then, on the tool-
bar, click Insert→Image.

Docs opens the box shown in Figure 3-12.

2. Tell Docs where to find the image by putting its Web address in the text box. The
easiest way is to open the image in another browser window, copy its URL, and
then, back in Docs, paste the URL into the text box.

3. Click OK.

Docs inserts the image into your spreadsheet.

Edit or Resize an Image
Once you’ve got an image in your spreadsheet, you can work with it in various ways.
Click the image to bring up the Image menu, shown in Figure 3-13. When the word
“Image” appears in the upper-left corner of your image, you can click and drag it to
move it in your spreadsheet. You can resize the image by positioning your cursor on a
border so it becomes a double-headed arrow, and then dragging to make the image
larger or smaller. If you don’t like the new size, click the Image menu, and then select
“Reset size” to return it to its original size.
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If you’ve edited the chart outside of Docs (in Excel, say) and want to replace it, then
click Image→“Edit image” to open the Insert Image box shown in Figure 3-12. From
there, you can upload the edited image to replace the current one.

Delete an Image
If an image becomes obsolete or just doesn’t work out as part of your spreadsheet, click
the image so that the upper-left Image menu appears. Click Image→Delete Image, and
the image disappears. (You can click Undo to get it back.)

Sorting Data
Data doesn’t necessarily march into your spreadsheet in a nice, orderly fashion; you
have to input data as it arrives. As your spreadsheet grows, the rows can seem disor-
ganized, making it difficult to spot trends or find a particular piece of data. Sorting lets
you organize the spreadsheet in different ways, whether you want to find out which of
your customers live in Chicago, who’s spending the most money on business trips, or
all the Mozart CDs in your collection.

Google Docs offers two ways of sorting a spreadsheet’s data: the Sort tab and the
Sortbar.

Figure 3-12. Docs can’t insert images stored on your computer—you have to give it the image’s
Web address.
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Use the Sort Tab
When you enter and edit data on a spreadsheet, you do all that on the Edit tab. Sitting
right next to it, in the left part of your screen, is the Sort tab. When you click Sort, the
toolbar above the spreadsheet changes to the one shown in Figure 3-14.

Here’s what’s on the Sort tab’s toolbar:

• Sort sheet by column [x]. This is informational rather than an action item. This
text tells you which column will be the basis for the sort. Select a different column,
and the letter here changes.

• Sort alphabetically from A to Z. Puts things into nice, neat A-B-C order or 1-2-3
order, depending on the contents of the column you’ve chosen for the sort. (Nu-
merical data sorts from lowest to highest number.)

Figure 3-13. After you’ve inserted an image into a spreadsheet, click the image to bring up the upper-
left Image menu, which has the options shown here.
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• Sort alphabetically from Z to A. Helpful when you want to find, for example,
Martin Yzringa out of several thousand names or the priciest item in a price list
(it’ll appear at the top).

• Freeze header rows. Keeps your headers from being sorted with everything else
in the spreadsheet. For example, if the first row of your spreadsheet contains head-
ings that name each column—such as Name, Address, City, State, and so on—you
don’t want that row ending up in the middle of the N’s in your sort. Freeze the first
row to keep that from happening. (You can freeze up to five rows using this button.)

• Freeze columns. Keeps the leftmost column or columns—you can freeze up to
five—from being part of the sort.

When you freeze a row or column, you tell Docs not to move it around in the sort.
Frozen rows and columns get set off from the rest of the data in the spreadsheet, as
Figure 3-15 shows.

TIP
Need to freeze more than five rows? The next section clues you in on how to use the
Sortbar to freeze up to 10.

Sort toolbar

Figure 3-14. The toolbar on the Sort tab (circled) lets you display a spreadsheet’s data in various ways.
In this spreadsheet, which catalogs a book collection, Docs is about to sort the data based on column
E (Value) from most valuable to least valuable (that’s descending, or Z→A, order).
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Use the Sortbar
The Sortbar lives at the top of your spreadsheet and lets you do a quick sort without
leaving the Edit tab. Open a spreadsheet in the Edit tab, and then click anywhere inside
the light blue box at the top of a column (the box that holds the letter that labels the
column). Then move the cursor down just a bit until it’s pointing at the bar separating
the label box from the first row of cells—this is the Sortbar. Hovering your cursor over
the Sortbar “wakes it up,” as shown in Figure 3-16, and turns it orange. Click the arrow
on the right side of the Sortbar, and then choose whether you want an ascending or
descending sort. Docs sorts your column accordingly.

TIP
If you’re just using the Sortbar for a quick sort, click the Undo button to restore the
previous, unsorted order.

You can also use the Sortbar to freeze several rows without leaving the Edit tab. At the
extreme left end of the Sortbar is a shaded box with diagonal lines on it, shown in
Figure 3-17. When you put your cursor over the box, the cursor changes to a four-way

Frozen row

Frozen column

Figure 3-15. The top row and leftmost column of this spreadsheet are frozen—you can tell because
they’re separated from the rest of the spreadsheet by gray dividers. When you scroll through a
spreadsheet, frozen rows and columns don’t move.
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arrow (if you’re using Firefox on a Mac, it changes to a grasping hand). Drag the Sortbar
to place it between two rows. Now, when you use the Sortbar, it sorts only the rows
beneath it, leaving any rows above it alone. You can position the Sortbar anywhere
between rows 1 and 11.

Formulas and Functions
The data in your spreadsheet won’t do you much good if it just sits there. If you’ve got
a column of numbers, for example, you probably want to work with those numbers in
some way: Add ‘em up, find their average, find a percentage to figure sales tax, or make
other calculations. In a Docs spreadsheet, you make those calculations using formu-
las. (Actually, once you’ve written a formula, you don’t make the calculation—the
spreadsheet makes it for you. Nice!) Formulas tell the spreadsheet what operation to
perform on a specific set of data. This section teaches you all about formulas and how
to use them.

Formula Basics
Here’s a simple example of a spreadsheet formula (you insert a formula into a cell in
your spreadsheet). If you want to write a formula to add cells B2 and B3, it would look
like this:

Figure 3-16. The Sortbar (which the cursor is pointing to here) lets you sort while you’re on the Edit
tab.
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=B2+B3

Take a look at the parts of that formula:

• The equal sign (=) marks the beginning of the formula, letting Docs know: “Hey!
This cell holds a formula and not regular text or numbers.”

• The cell identifiers B2 and B3 tell Docs which cells to work with.

NOTE
Cell identifiers are like street addresses—they help you find specific cells. If you see
the cell identifier F4, that’s pointing to the data in the fourth cell down in column F.

• The operator (in this case, the + sign) tells Docs what to do with those cells.

Although formulas can get pretty complicated, all formulas build on these basic
elements.

Figure 3-17. To move the Sortbar, drag the box at the left end of the Sortbar (circled with four-way
arrow cursor). There’s no vertical Sortbar, but you can freeze columns by dragging the shaded gray
box at the border of the leftmost sortable column (also circled). You can freeze up to five columns this
way.
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NOTE
You can also use numbers in formulas, not just cell identifiers. For example,
=E20*2 tells Google to multiply the contents of cell E20 by 2.

If you’re fluent in spreadsheet-ese, you can write formulas from scratch using the
mathematical operators shown in Table 3-2.

Table 3-2. Mathematical Operators You Can Use in Google Docs Spreadsheets

Operator What It Does

+ Addition

– Subtraction

* Multiplication

/ Division

% Percentage

= Is equal to

> Is greater than

< Is less than

>= Is greater than or equal to

<= Is less than or equal to

<> Does not equal

^ Exponentiation (raised to the power of)

You can also use advanced formulas, called functions (which are built right into Google
Docs), as building blocks for formulas. How’s a function different from a regular for-
mula? Well, in a function you supply the values, but the function supplies the operators.
In other words, the function tells your spreadsheet what to do; you just tell it what data
to work with. Functions range from the basic (Sum to add a column of numbers) to
the ridiculously complex (Google Finance, which looks up current stock prices).

To start working with formulas, click the Formulas tab, shown in Figure 3-18. Once
there, click an empty cell; this cell will hold your formula and display its result. Select
a function from the upper-right part of the page. If you don’t see the function you want,
click “more” and look for it in the “Insert a Function” box, shown in Figure 3-19.
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TIP
The functions in the “more” menu show functions’ names, but no description of
what each function does. To find out, on the right side of the “Insert a Function”
box, click a function to select it, and then, in the box’s lower-right corner, click the
“more” link. In a new window, Google opens a page that describes what the function
does. (For a comprehensive list of functions and what they do, go to www.docs.goo-
gle.com/support/spreadsheets (http://www.docs.google.com/support/spreadsheets),
and then click Advanced Editing→Functions.)

When you select a function, Google inserts it into the cell where you’re building your
formula. The function tells Docs what to do; now you just have to tell Docs which data
to use. Say you want the formula to find the average of a particular cell range: E2 through
E45. On the Formulas tab, select Average, and then Docs inserts this function into the
cell:

=Average(

From here, your job is to tell Docs which cells you want it to find the average of. To do
that, type the identifier of the first cell in the range, then a colon, and then the identifier
of the last cell followed by a close parenthesis (to show that you’re done writing your
formula). Your formula now looks like this:

=Average(E2:E45)

When you hit Enter (Return), Docs averages the contents of cells E2 through E45, and
then shows the result in the cell where you entered the formula.

Click this button to create a range
name to use in your formulas.

Figure 3-18. Not surprisingly, the Formulas tab (circled) is where you create formulas to use in a
spreadsheet. Common functions appear as links on the right side of the page (circled). Click “more”
to browse through a longer list of functions.
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TIP
To make your formulas easier to write, use range names (page 152) in place of cell
ranges.

The GoogleLookup function
Google being Google, it wants to help you find the info you need as you work on your
spreadsheet. In fact, you don’t even need to leave your spreadsheet to look things up.
The GoogleLookup function lets you write a formula that retrieves information from
the Web and pops it right into your spreadsheet. Here’s the basic formula:

=GoogleLookup(“entity”; “attribute”)

Replace the word entity with what you want to look up, and attribute with what you
want to find out about it. Here are some examples (note the quotation marks around
the entity and the attribute, and the space after the semi-colon):

=GoogleLookup(“London”; “population”)

Select a function… …and Google inserts it in
the cell you choose.

Figure 3-19. Docs has dozens of functions you can use to create your formulas. From the left side of
the box, choose a category, such as Math or Text, and the right side changes to show you all the
functions in that category. Click a function to insert it in your cell and build your formula.
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=GoogleLookup(“Giuseppe Verdi”; “birth date”)

=GoogleLookup(“Alabama”; “capital”)

These formulas ask:

• What’s the population of London?

• On what date was Giuseppe Verdi born?

• What’s the capital of Alabama?

For these formulas, Google returns 7.5 million (2005), 9-Oct-1813, and Montgomery,
respectively. Google also inserts a comment (page 176) telling you where it got its
information. The comment includes a link so you can check out the source for yourself
(always a good idea).

The GoogleLookup function can fetch a lot of info, but it’s not all-knowing. If it can’t
find what you’re looking for, it returns “#N/A” to let you know it drew a blank. Still,
it’s fun to play with, whether you need some info or you just want to see if you’re
smarter than a Google function.

NOTE
You can insert a maximum of 250 GoogleLookups into a single spreadsheet. And,
for the moment anyway, the GoogleLookup function works only in English.

The GoogleFinance function
Another cool feature of Docs spreadsheets is the GoogleFinance function, which looks
up stock market quotes and other financial info, and slots it right into your spreadsheet.
If you want to track your stock portfolio, this is a great way to do it. Create a spreadsheet
that lists your stocks in one column and inserts the function in another, and Google
automatically updates the stocks’ current values every minute or so. It’s like having
your own personalized stock ticker on your desktop.

Here’s what the GoogleFinance function looks like:

=GoogleFinance(“symbol”; “attribute”)

To make this function work, replace symbol with an actual stock symbol, and attrib-
ute with the type of information you want about that stock. Here are a couple of
examples:

=GoogleFinance(“AAPL”; “price”)

=GoogleFinance(“GOOG”; “volume”)

They ask:

• What’s the current price of Apple Computer shares?

• What’s the current trading volume of Google shares?
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Google returns the answers based on current stock market data, although the data may
be as much as 20 minutes old (which doesn’t seem like much, but things change quickly
on Wall Street).

If you’ve got a spreadsheet that lists stocks in one column, and you want the next
column to display the current price of those stocks, you could write a GoogleFinance
formula that looks something like this (as shown in Figure 3-20), which tells Google
to use the contents of two cells for the symbol and the attribute:

=GoogleFinance(A2; A1)

Translated into English, this formula says, “Hey, Google! See what’s in cell A1? Look
that up for the contents of cell A2, and then plant the result here.”

TIP
Use a dollar sign ($) to make it easy to copy a formula into adjacent cells. In formulas,
the dollar sign indicates an absolute reference, which tells the spreadsheet that a value
doesn’t change, no matter which cell it’s in. For example, if the formula is =Google-
Finance(A2; A$1), you can drag that formula down to fill all the cells in column B.
For each cell, the attribute remains the same: the contents of cell A1.

Formula using GoogleFinance
function

Figure 3-20. In this example, the formula that’s in cell B2 means, “For the contents of cell A2 (AAPL)
find the contents of cell A1 (price).” All the cells in column B use a variation of this formula to display
the prices of various stocks.
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NOTE
The GoogleFinance function currently works only in English—and it doesn’t deal
with most non-U.S. market data, although you might be able to use a couple of
international symbols. Google’s working to make this function support more mar-
kets, so if you’re interested in international finance, give GoogleFinance a try and see
if your formula works.

Labeling Cells and Columns with Range Names
Naming ranges of cells can really simplify your formula writing. Instead of trying to
remember exactly which cells define the range, you can create a descriptive, easy-to-
remember name, and then insert that name into the formulas you write, which saves
you a lot of work. This section explains how to use range names.

Create a Range Name
Ready to name a range of cells? Here’s all you have to do:

1. Open your spreadsheet, and then select a range of cells. (You can also specify the
range later in the process—see step 2.) Then click the Formulas tab.

The Formulas tab opens, as shown back in Figure 3-18.

2. Click “Range names”→“Define new”.

Docs opens the Range Names box, shown in Figure 3-21. If you selected a range
of cells in step 1, then they appear in the cell range text box, to the right of the
Nickname text box.

3. In the Nickname box, give the range a name. (For example, if you’re a teacher
working on a spreadsheet that tracks grades, you could select all your students’
names, and then call the range “Students”.) If you haven’t already chosen a range
of cells, or if you want to edit the range that appears in the box, do so in the cell
range box using the format upper-left cell:lower-right cell (for example, A2:H2).
Then click Save.

Docs adds your new range name to the list in the Range Names box. If you want,
you can click the “Add another” link at the bottom of the box to name a different
range by repeating step 3.

4. When you’re finished, click Done.

Docs returns you to your spreadsheet.

Now, you can work with range names in your spreadsheet formulas (explained next)
instead of always typing individual cell indicators to define ranges. And when you click
the Formulas tab’s “Range names” button, your new range name appears on its menu.
Click the range name to select its cells.
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TIP
If you want to publish a range of cells (page 167), use a range name to tell Google
which cells to publish.

Use a Range Name in a Formula
Now that you’ve created a range name, you can use it in your formulas. If you’re like
most people and tend to think in words more than numbers, this ability can save you
a lot of time.

Here’s a quick example: The spreadsheet in Figure 3-21 contains a list of stocks and
their current prices. The prices, cells B2–B7, are a named range called price. If you want
to find the average price and display it in the cell below the individual stock prices, then
you could double-click cell B8 and write this formula in it:

=Average(price)

This formula tells Docs to calculate the average of the values in the cells whose range
is named price (that is, cells B2–B7).

Figure 3-21. Using a range name lets you gives an easy-to-remember name to a range of cells.
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Change a Named Range
You manage range names from the same place you created them: the Formulas tab’s
Range Names box. If you want to alter a range—to include more cells or cut a few out
—click the Formulas tab→Range names→Manage. This action opens the Range Names
box shown in Figure 3-21. Click the name of the range you want to open for editing,
and then, in the cell range box, make your edits. Click Save, and then click Done, and
Docs saves your changes.

Delete a Range Name
If you no longer need a range that you’ve named and you want to remove it from the
list, click Formulas→Range names→Manage to open the Range Names box. Scan the
list to find the range name you want to delete, and then click the X to its right. Docs
removes the name from that range of cells and the range names list.

NOTE
When you delete a range name, any existing formulas that use the range name won’t
work anymore. So double-check that you’re not using a range name before you delete
it.

Working with Charts
Spreadsheets are great at holding and organizing all kinds of complex information, but
staring at row after row and column after column can make viewers go cross-eyed.
When you want to emphasize certain information or illustrate a trend—like an unex-
pected rise in monthly household expenses or skyrocketing sales—a chart is the best
way to get your point across. Charts have a strong impact and are easy to interpret.
When you create a chart in Google Docs, you can keep it with your spreadsheet or
insert it into a separate word processing document, such as a quarterly report.

Docs can create the following kinds of charts from your spreadsheet data:

• Column charts display your data in vertical columns. Different columns of equal
width vary in height to compare data. Figure 3-22 shows an example. (The “Add”
button on the Edit toolbar also shows a tiny column chart.)

• Bar charts display your data in horizontal bars. (That’s why this kind of chart is
sometimes called a horizontal bar chart.) The length of the bars as they stretch
across the page shows variations in data. Figure 3-22 illustrates the difference be-
tween a bar chart and a column chart.
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NOTE
Docs can make regular or stacked bar and column charts. The regular column chart
in Figure 3-22 (left) shows one column for each category of data; because there are
several categories, multiple columns cluster together in each month. A stacked col-
umn chart stacks these expenses into a single, thicker column per month, with a
different color representing each type of data. Figure 3-23 compares a regular column
chart with a stacked column chart.

• Pie charts represent data in a circle divided into different-colored pieces. Each
piece is proportionate to the amount data it depicts.

Column chart Bar chart

Figure 3-22. These two charts illustrate the same data: household expenses over the course of a
year. The column chart (on the left) shows months along the x-axis and expenses along the y-
axis. The bar chart (on the right) reverses the axes: months are on the y-axis and expenses on
the x-axis.

Column chart Stacked column chart

Figure 3-23. When you have multiple categories of data (here, categories of household expenses),
a regular column chart (left) can look a bit crowded. Stacking the categories into a single column
(right) makes the chart easier to read.
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• Line charts show data as a series of points connected by a line. As Figure 3-24
shows, line charts are great for showing trends over time.

• Area charts are line charts all dressed up. They emphasize changes in values by
shading the part of the chart that’s below the line connecting the data points.
Figure 3-24 compares an area chart with a line chart.

• Scatter charts (sometimes called XY charts) display your data as a set of points.
In a scatter chart, both axes represent numbers: The x-axis holds one set of nu-
merical data, and the y-axis holds the other set. The chart combines x and y values
into single data points, and shows them in clusters. Scientists and engineers often
use scatter charts to show and compare numeric values, such as statistical data.
Figure 3-25 gives an example of a scatter chart.

TIP
Confused about when to use a line chart versus when to use a scatter chart? The
answer lies in the x-axis. If the x-axis shows categories, like months or sales regions,
use a line chart. But if the x-axis contains numerical values, use a scatter chart.

As Figure 3-26 shows, each of these chart types has subtypes you can play around with.
Column, bar, and pie charts even let you go 3-D to give your chart extra visual impact.

Create a Chart
Charts pack a mighty visual punch, and Google Docs makes it easy to transform
spreadsheet data into a chart or two. Here’s how:

Line chart Area chart

Figure 3-24. Both of these charts show trends in various household expenses, by month, over the
course of a year. The line chart (left) connects data points with lines. The area chart (right) takes the
line chart and shades the area beneath each line.

156 | Chapter 3: Working with Docs Spreadsheets



1. Open your spreadsheet (make sure it’s on the Edit tab), and select the range of cells
you want to convert into a chart. Click the “Add chart” button on the toolbar, or
click Insert→Chart.

Docs opens the Create Chart box, shown in Figure 3-26, which gives you a bunch
of options:

• What type? Select the kind of chart you want to create. When you do, available
subtypes appear in the next row—pick the one you want.

• What data? If you selected a range of cells to get started, they appear in the text
box here. You can edit the cell range: Use the A1:M6 format—range names
(page 152) don’t work here. Then tell Docs whether to group the data by rows
or columns (if you’re not sure, click a radio button, and then, in the right-hand
Preview section, check out the effect), and whether you want to use spreadsheet
content as labels.

• Labels. If you want your chart to have a title at the top, in the “Chart title” box,
type the title. You can also create labels for the axes and move the legend to a 
different location on the chart (or take it out altogether). The “Reverse catego-
ries” checkbox flips the order of the categories your chart shows. For example,
if you have days of the week across the x-axis, starting with Monday and ending
with Friday, Docs changes the order from Friday to Monday.

• Preview. Nothing to select here; this section shows the effect of your choices
as you make them. What you see here is what you get in your chart.

Figure 3-25. Scatter charts are great for helping to make sense out of statistical data. This chart shows
a correlation between temperature and an air pollution index; the higher the air temperature, the
more pollution.
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2. Make your selections, checking out their effects in the Preview section, and then
click “Save chart”.

Docs creates your chart and inserts it in your spreadsheet.

Edit a Chart
After you’ve created a chart, you might discover that you need to fix a typo in a label
or adjust the cell range that’s included. To make changes in your chart, click it. Docs
puts a box around the chart and brings up the Chart menu in the box’s upper-left corner,
as shown in Figure 3-27.

To make changes to the chart, click Chart→Edit. This action opens the Create Chart
box, with the info for the chart in its current incarnation already filled in. Make what-
ever changes you want, and then click “Save chart”. Docs revises your chart to reflect
the changes.

See how your selections will
affect your chart here.

Select a chart type here… …and Docs shows available subtypes here.

Figure 3-26. As you create a chart, Docs gives you a preview of how the finished chart will look. So
you know what you’re getting before you click “Save chart”.
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Move or Resize a Chart
You don’t have to leave your new chart where Docs inserted it. To move a chart, click
it, and then put your cursor in the top part of the gray box that surrounds the chart.
When the cursor changes to a pointing hand, click and drag the chart to where you
want it.

You can also change the size of a chart. Click the chart, and then move your cursor to
one of the outer edges (left, right, or bottom) of the box that contains it. The cursor
changes to a double-headed arrow, which means you can click and drag the border to
resize the chart. If you change your mind about resizing, just click Undo.

Figure 3-27. When you click a chart, a Chart button appears in its upper-left corner. Click it to open
the Chart menu (circled), where you can edit, delete, or publish your chart, or save it as an image to
insert into a document (see page 62).
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Save a Chart As an Image
After you’ve made a great-looking chart, you probably want to share it by inserting it
into a report or tacking it up by the water cooler to impress your colleagues. Before you
can get a chart into a word processing document or presentation slide, you need to save
it as an image—which you can do in just a couple of steps:

1. Click the chart, and then, in the chart’s upper-left corner, click Chart→“Save
image”.

A download window opens, asking what you want to do with the file: Open it or
save it to disk.

2. Turn on the “Save to disk” radio button, and then click OK.

Your computer saves the file to your Desktop as a PNG file (a type of image file).

From there, you can insert the PNG file into a document as you would any other image.
If you want to insert the chart into a Google document, flip back to page 62 for the
super-easy how-to.

NOTE
After you’ve transformed a chart into an image, its data no longer changes when
spreadsheet data does.

Publish a Chart
In Google Docs, publishing a chart means putting it on a Web page. To do that, click
the chart, and then click Chart→“Publish chart”. Google opens a box like the one shown
in Figure 3-28. The box contains some HTML code—don’t worry, you don’t need to
understand what it means. You just have to copy the code and paste it into a Web
page’s code to insert your chart in that Web page. (Ask a geeky friend if you need help,
or check out Creating Web Sites: The Missing Manual.)

Figure 3-28. To insert a chart into a Web page, copy the HTML code in the Publish Chart box (shown
here), and then paste that code into the Web page’s code. Click Done to close this box.
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Delete a Chart
Charts can outlive their usefulness as the data in a spreadsheet changes. To delete a
chart, click it, and then click Chart→“Delete chart”, and the chart disappears.

TIP
There’s no confirmation box to make sure you really want to delete the chart—as
soon as you select “Delete chart”, the chart is history. If you delete a chart by mistake,
though, you can get it back. Either click the Undo button, or, if you deleted the chart
a while back, click the Revisions tab (page 182), find an older version of the spread-
sheet that contains the banished chart, and revert (page 183) to that version. If all
else fails, you can always recreate the chart from scratch.

Displaying Data with Gadgets
As Chapter 8 explains, Google gadgets are mini-programs that you can insert into
Web pages. On iGoogle (Chapter 8), for example, gadgets can show local weather
reports or current news headlines. In a spreadsheet, gadgets can show your data in
different ways. For example, one gadget creates a pivot table to quickly summarize long
lists of data. Other gadgets can create a timeline, a tree-style organization chart, and
even a chart that shows dollar amounts as piles of money.

To add a gadget to a spreadsheet:

1. Open the spreadsheet, and then select the range of data you want the gadget to
show. Click Insert→Gadget or the Add button, and then select Gadget.

Google opens the Add a Gadget box, shown in Figure 3-29.

2. Use the categories on the left side of the box to browse. When you find a gadget
you want to use with your spreadsheet, click its “Add to spreadsheet” button.

A new box opens, like the one in Figure 3-30, where you can enter any info needed
to create the gadget. This info varies for each gadget, but typically you can adjust
the cell range and give the gadget a title.

3. Fill in any required info, and then click Save.

The box displays the gadget. If you need to, adjust the gadget’s settings.

4. When the gadget is looking good, click “Save & close”.

Google inserts the gadget into your spreadsheet—Figure 3-31shows an example.
As your data changes, so does the gadget.

After you’ve inserted a gadget in a spreadsheet, you can edit it by clicking the gadget
(so a gray frame appears around it), and then clicking the gadget’s upper-left Edit
button. Docs opens a box like the one you used to create the gadget (Figure 3-30),
where you can make adjustments to its settings. Click “Save & close” when you’re done.
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You can also work with gadgets in other ways. Click the gadget, and then click its upper-
right arrow for these options:

• Publish Gadget generates HTML that you can copy and paste into an HTML file
to embed the gadget in a Web page. (See page 469 for more about embedding
gadgets in Web pages.)

• Add to iGoogle puts the gadget on your iGoogle page (see Chapter 8).

• Delete Gadget removes the gadget from your spreadsheet.

NOTE
Deleting a gadget from a spreadsheet doesn’t remove any embedded versions from
iGoogle (Chapter 8) or a Web page.

• Get table query data source url gives you a Web address you can use if you’re
developing your own gadget (see page 432 and page 667).

• About this gadget opens a new window with info about the gadget.

Figure 3-29. Gadgets that work with Google spreadsheets let you display the spreadsheet’s data in
various ways, from dials on a gauge to pivot tables to timelines and org charts. Browse the categories
on the left to see the gadgets on the right. When you see a gadget you like, click “Add to spreadsheet”.
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Printing a Spreadsheet
If you need to put your spreadsheet on paper, you’ve got a couple of different options:
You can print it as a PDF file, or export it as an HTML file, and then print it from your
browser window. And if you want to get really tricky, you can print your spreadsheet
without gridlines. This section explains all your options.

Print as a PDF
A PDF (portable document format) file retains its formatting regardless of what kind
of computer or operating system the viewer is using. So creating a PDF is a good way
to make sure your spreadsheet looks the same to everyone. Printing PDF involves two
steps:

1. Convert the spreadsheet to a PDF file.

2. Print the PDF.

In your spreadsheet, click the upper-right Print link, or click File→Print. Either method
opens the Print Settings box, which looks just like the “Export to PDF” box shown
back in Figure 3-5, except for the different name, and the button at the bottom of the
box now says Print instead of Export. Fill out the Print Settings box according to the
directions on page 125, and then click Print.

Figure 3-30. Fill in any required info, and then click Save to see a preview of the gadget in the bottom
part of the box. If it looks good, click “Save & close” to put the gadget into your spreadsheet.
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A window opens, asking how you want to handle the file. You want to open the file
with Adobe Reader, and then print it from there. So tell Docs to use Adobe Reader to
open the file, and then click OK. Your computer downloads the PDF file and opens it
in Adobe Reader, giving you a preview of how the printed spreadsheet will look. Click
File→Print to open the Reader’s Print window, and then click OK to print your spread-
sheet.

Print from an HTML File
This is a quick ’n’ easy way to print a spreadsheet. As page 124 explains, when you
export a spreadsheet as HTML (File→Export→.html), a new browser window opens to
display the file. Then you can print the spreadsheet directly from the browser window
(just go to your browser’s File menu, and then choose Print).

TIP
You can export only one spreadsheet at a time as an HTML file. If you want to print
multiple pages, print the spreadsheet as a PDF, turning on the Print Settings box’s
“All sheets” radio button.

Figure 3-31. This gadget shows money values as stacks of $100 bills—a nice way to feel rich when
you’re looking at your stock portfolio.
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The only problem with printing from a browser is that the printed page displays stuff
in the header and footer that you might not want there, like a Web address and the
time and date of printing. That may be fine for a draft, but you probably don’t want all
that extraneous info on a spreadsheet you print to distribute to coworkers.

You can tell your browser to clean up headers and footers before it sends the file to
your printer. How you do that depends on your browser and your computer’s operating
system. After the exported HTML file has opened in a new browser window, follow
the appropriate instructions for adjusting headers and footers on the printed page:

• Internet Explorer 6. Select File→Page Setup. In the Page Setup box that opens, in
the Headers and Footers section, make sure that Header and Footer text boxes are
both empty, and then click OK.

• Internet Explorer 7. Click the drop-down arrow next to the Print button (which
looks like a miniature printer), and then select Page Setup. When the Page Setup
box opens, clear anything that’s in the Header and Footer text boxes, and then
click OK.

• Firefox for Macs. Select File→Print. In the box that opens, click the Copies &
Pages drop-down menu, and then select Firefox. At the bottom of the box, check
to make sure that the options for Page Headers and Page Footers are all set to
“blank”, and then click OK.

• Firefox for PCs. Choose File→Page Setup. In the Page Setup box that opens, click
the Margins & Header/Footer tab. In the Headers & Footers section, make sure
all the options are set to “blank”, and then click OK.

Print a Spreadsheet Without Gridlines
If you want your spreadsheet to print as a table without any gridlines, you have to get
tricky and edit its URL just a bit. Here’s how:

1. Publish the spreadsheet (page 167).

When you publish a spreadsheet, Docs assigns it a URL (an online address) and
posts it on the Web.

2. On the spreadsheet’s Publish tab, click the URL for the spreadsheet. (It’s the link
just under the words “Your document is viewable at:”.)

A new browser window opens, displaying the published spreadsheet.

3. Click inside your browser’s address bar. At the end of the URL, add this text:
&gridlines=false. (Don’t include the period.) Then hit Enter.

Your browser displays the spreadsheet with the gridlines erased. From here, you
can print the spreadsheet—minus gridlines—directly from your browser.
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Deleting a Spreadsheet
Google Docs can hold up to a thousand spreadsheets in each Docs account, so you may
never again have to part with one. But if you decide it’s time to make a clean break,
you can easily nix any file you want.

NOTE
Even though the Edit tab’s toolbar has a Delete button, you can’t use it to delete a
whole spreadsheet (just individual rows and columns). Selecting an entire spread-
sheet, and then clicking Delete and trying to delete all rows or all columns just gets
you an oops message telling you that you can’t do that.

On your Docs home page, in the Docs list, find the spreadsheet you want to delete.
Select it by turning on its checkbox, and then click the Delete button to toss it in the
Trash.

If you have a change of heart, you can undelete the spreadsheet by opening the Trash
folder (in the left-hand menu, click Trash), selecting the file, and then clicking Undelete
to restore it to its former location on the Docs list (and in any folders). If, on the other
hand, you really want that spreadsheet to hit the road, just empty the Trash (click the
“Empty trash” button) and it’s gone for good.

TIP
If you encounter an error message when you try to delete a spreadsheet from the Docs
list, it may be because you have that spreadsheet open in another window. Close the
spreadsheet, and then try again.

Sharing and Collaborating on Spreadsheets
People who are Google Docs veterans can’t say it enough—the great thing about Docs
is the ease with which you can share your files, whether you’re publishing a spreadsheet
to the Web or getting your entire far-flung sales team to work on the spreadsheet at the
same time. This section explains how to share your documents and get the most out
of collaboration.

NOTE
If you sign into Google Docs through your organization’s Google Apps account (if,
for example, you sign in at http://docs.mycompany.com), your domain administrator
can restrict your ability to share spreadsheets with people outside your company, and
prevent you from receiving invitations to view spreadsheets that don’t belong to your
domain—page 556 has the details.
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Publishing a Spreadsheet on the Web
If you want to show your spreadsheet onlineto a bunch of people without letting them
make changes to it, the easiest method is to publish it on the Web. When your spread-
sheet is a Web page, you can send its URL (Web address) to anyone who might want
to take a gander at it, or link to it from another Web page or a blog. All people have to
do is follow the link, and there’s your spreadsheet, large as life.

To publish your spreadsheet, open it in Google Docs, click its far-right Publish tab, and
then click the “Publish now” button. Docs puts your spreadsheet on the Web and tells
you its URL, as shown in Figure 3-32. Click the link to see how your spreadsheet looks
as a Web page.

Figure 3-32. After you’ve published a spreadsheet, the Publish tab (circled) looks like this. The top
part of the box contains a clickable URL that you can copy and send to colleagues to share your
published spreadsheet with them. Docs doesn’t automatically update the published version of your
spreadsheet if you make changes to your data (unless you tell it to—see page 168), so use this tab to
republish an edited spreadsheet to make sure the current version is online. You can also click “Stop
publishing” to take your spreadsheet off the Web.
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NOTE
When you publish a spreadsheet, a Published label appears on the spreadsheet on
your home page’s Docs list. This label makes it a cinch to find and manage published
spreadsheets, as explained next.

Manage a published spreadsheet

One of the great things about Web-based publishing (as opposed to paper-based pub-
lishing) is that it’s easy to make tweaks to a document, and then republish the results
right away—not to mention all the acres of trees you save.

If you want to make changes to a spreadsheet you’ve published, open the spreadsheet
and then click the Publish tab to see a screen like the one in Figure 3-32. For an already-
published spreadsheet, the Publish tab has these options:

• Re-publish this document. The published version of your spreadsheet doesn’t
automatically reflect changes you make to your data. If you’ve made some changes
to your data, and you want to update the published version, then click this button.
(The third item in this list explains how to automate this process.)

• Stop publishing. No longer need to share the spreadsheet? Click this button to
take it off the Web.

• Automatically re-publish when changes are made. If you want your published
spreadsheet to reflect up-to-the-minute info, but you don’t want go back and click
the “Re-publish this document” button every single time you update your data,
turn on this checkbox, and Docs does the republishing for you.

• What parts? This drop-down menu lists the different sheets within your spread-
sheet file. You can choose to publish all the sheets, or pick just one. (If you make
a change here, be sure to click “Re-publish this document” so the change takes
effect.)

• Subscribe. Flip to page 50 to learn all about RSS feeds. These feeds work the same
with spreadsheets as they do with documents. To subscribe to a feed of changes
to the spreadsheet, click this link.

• More publishing options. Click this link to open the More Published Formats
box shown in Figure 3-33. In this box, you can change the following settings:

— File format. Click the drop-down menu to choose a different file format for
your published spreadsheet. These formats include all the formats you can use
for exporting (page 123), as well as HTML you can embed in a Web page and
RSS formats.

— What sheets? Choose all of ’em or just one.

— What cells? If you want to publish just a range of cells, enter the range here in
the format A1:G80.
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— Generate URL. Click this button to get the Web address of a page where you
can see the results of the settings you chose in this box.

Sharing a Spreadsheet
As Chapter 2 mentions, one of Google Docs’ best features is that it lets you collaborate
with others simultaneously on the same document. Just as a team can write and edit
the same document, working simultaneously from different locations, several people
can collaborate on a spreadsheet—working on the same file, all at the same time.

Imagine that the Friends of the Library are getting ready to hold their annual week-long
book sale. In the past, scheduling volunteers has been a challenge—people would call
or email the volunteer coordinator with their preferred shift times, but this led to all
kinds of scheduling conflicts, not to mention hours of back-and-forth on the phone.
Using Google Docs, the coordinator can create a spreadsheet that lists shifts and jobs
that need filling, like information desk, cashier, restocker, and so on. Then volunteers
can sign up for shifts in real time, on the actual Schedule spreadsheet. When someone

Figure 3-33. The More Published Formats box lets you choose a format for your published spreadsheet
or select a range of cells. The URL generated here is different from the one listed on the Publish tab.
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signs up for, say, the 9-to-noon shift on Tuesday at the Info Desk, everyone else can
see that that shift’s taken. The other volunteers can scan the schedule to see what else
is available and slot themselves right in—no more phone calls to say, “Well, Tuesday’s
taken—how about Thursday? No? Okay, then how about...?”

With Google Docs, you can invite people to share your spreadsheet in two ways: as
viewers or as collaborators. These roles have different privileges, as page 93 explains.
(Basically, viewers can look at a spreadsheet but not edit it, whereas collaborators can
both edit and view a spreadsheet.) People in either role can download copies of the
spreadsheet to their computers. If you want people to have a look at your spreadsheet
but not touch its data, make them viewers (or publish the spreadsheet online, as de-
scribed on page 167). If, on the other hand, you want a group of people to work on the
spreadsheet with you, make them collaborators.

Invite viewers and collaborators

The Share tab for spreadsheets looks almost exactly like the Share This Document page
for word processing documents, as Figure 3-34 shows. Note the almost—there are a
couple of important differences (explained next). Overall, the process for inviting view-
ers and collaborators to access your spreadsheet is the same as it is for sharing a
document (turn back to page 86 and read up on the process.

But there are a couple of cool ways you can share a spreadsheet that don’t apply to
documents. The big news: Docs now lets you collect data by creating a form for others
to fill out—their responses go straight into your spreadsheet; page 177 tells you all
about it.

In addition, Docs gives you another way to add viewers that’s different than the way
you share documents. For documents, your only option is to invite a viewer first, and
then that person can look at your document. But with spreadsheets, Docs can auto-
matically add new viewers when they view the sheet via a special link: When the person
follows the link, Docs automatically adds him to the spreadsheet’s official Viewers list.
That way, he can go back and take another look at the spreadsheet whenever he wants.

NOTE
Right now, Google places no limits on the number of people with whom you can
share a spreadsheet, so you can go crazy with your invitations. However, no more
than 50 collaborators can work on a spreadsheet simultaneously—but that’s plenty
for most people.

Working with Collaborators
After you’ve sent out the invitations to your spreadsheet party, the people you’ve invited
can get to work on the spreadsheet right away. When you’re working in a spreadsheet
and a collaborator or viewer opens it, Docs pops up a notification box to let you know
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they’re online with you. Click the Discuss tab (Figure 3-35) to see what they’re doing
and have a chat as you work.

Who’s editing what

One thing might seem a bit worrisome about multiple people editing the same spread-
sheet all at once: What happens if several people are trying to edit the same data
simultaneously? Won’t that mess everything up?

Not to worry. Docs makes it clear who’s editing what, right now. When someone else
is working on a spreadsheet at the same time you are, their name appears on the Discuss
tab, as shown in Figure 3-35. Next to each name is a little box, and each box is a different
color. Whatever cell a collaborator is working in gets outlined in the same color as that
collaborator’s box. Google calls this the cell-presence indicator, and because Docs up-
dates in real time, you always know where your collaborators are working. (If some-
body’s working where they’re not supposed to be, you can have it out with them in the
Discuss tab’s chat box—keep reading to learn about that.)

Figure 3-34. If you’ve already shared a document or two in Google Docs, the Share tab for spreadsheets
will look pretty familiar. But note the two differences. Turning on the “to fill out a form” radio button
(circled) lets you invite people to add data to your spreadsheet by filling out a Web-based form. You
can also add people to this spreadsheet’s Viewers list by turning on the “Anyone can view this document
at” checkbox (also circled). When you turn this checkbox on, Google supplies a URL that you can
copy and send to people. Anyone who views the spreadsheet at that address gets added to your Viewers
list.
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Chat about a spreadsheet

If your idea of collaborating on a project brings to mind people clustered around a table,
talking about the project and making changes as they go along, then collaborating on
spreadsheets in Google Docs won’t be that much of an adjustment. When two or more
people are working on a spreadsheet at the same time, the Discuss tab opens a chat box
(shown in Figure 3-35) so you and your coworkers can discuss the spreadsheet as you
work on it.

The Discuss tab tells you who’s online with you and what they’re working on. The
bottom part of this tab has two boxes: Type a comment in the bottom box, hit Enter,
and the comment shows up in the top box, for all your collaborators to read and respond
to. When someone responds, her comment appears in the top box, just below yours.
After a few comments have appeared in the chat box, you can scroll up or down through
all the comments (in case you missed something when you went for a cup of coffee).

Chat too distracting? Maybe your colleagues are talking about last night’s game instead
of how to improve sales figures. To close the chat box, in the Discuss tab’s upper-right
corner, click the x. You can always open it again by clicking the Discuss tab.

Collaborators’
names appear
here.

Your chat
appears in this
box.

Type chat
comments in
this box.

Cell-presence indicator

Figure 3-35. The Discuss tab (right) is where you see who’s working on a spreadsheet with you and
what they’re doing. The cell-presence indicator shows you which cell each collaborator is working on
right now. (If for some reason you don’t want to see these indicators, click the “Hide collaborators’
locations” link, circled.) In the box at the bottom of Discuss tab, type messages to chat with your
collaborators as you work.
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NOTE
If you don’t have the Discuss tab open, then the tab turns orange when a collaborator
makes a comment in the chat box, so you know there’s a message.

Get change notifications

One of the great things about sharing spreadsheets is that any collaborator can work
on it, from anywhere, at any time. Of course, you want to stay on top of the changes
that your coworkers try to sneak into the spreadsheet while you were sleeping. Fortu-
nately, you can have Google notify you whenever someone edits a spreadsheet, so you
never miss a thing.

To tell Google to send you email notifications of changes to a spreadsheet, open the
spreadsheet you want to keep an eye on. Then, above the spreadsheet editor, click Set
Notification Rules. Google opens a dialog box like the one in Figure 3-36. In the box,
tell Google when to notify you by turning on any of the following checkboxes (you can
select more than one):

• Any changes are made. Whenever someone changes the spreadsheet, whether by
adding new values, changing formatting, creating a formula—whatever—Google
lets you know.

• Anything on this sheet is changed. If a worksheet is made up of several individual
sheets, you can keep an eye on just one sheet. (You can choose only one sheet from

Figure 3-36. You can get an email from Google when a collaborator makes changes a spreadsheet
or when collaborators come and go. Emails arrive on an as-it-happens basis, or once a day in
digest form—it’s your call.
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the drop-down list. If you want to watch a couple of sheets in a big spreadsheet,
set up another notification for the second sheet.)

• Any of these cells are changed. If you just want to see what’s happening to a
particular range of cells, click the text box here. Google opens another dialog box,
called “What data?”, where you can specify the cell range. Google then inserts that
range into the Notification Rules box.

• Collaborators are added or removed. It’s good to know when someone joins or
leaves a project, and this notification keeps you informed.

After you’ve specified what to watch for, tell Google how to notify you:

• Email - daily digest. Turn on this checkbox to receive one email from Google per
day, listing all the changes made that day.

• Email - right away. Turn on this checkbox if you want to get an email whenever
changes are saved.

After you’ve made your selections, click Save, and Google creates the notification. Now,
when someone edits the spreadsheet, Google sends you an email to let you know (or
sends you one at the end of the day). The email tells you who made the change and
what kind of change it was (adding values, for example). The email also has a link you
can click to view the spreadsheet with the changes highlighted.

After you’ve created at least one change notification, when you click Set Notification
Rules above the spreadsheet editor, you see a box that looks like the one in Fig-
ure 3-37, listing your notifications. From here, you can do any of the following:

• Add a new notification. Click the “Add another” link in the dialog box’s bottom-
left to create a new notification.

• Edit. To change an existing notification (maybe you’re getting too many emails
and want to switch to a once-a-day digest), click this link, which opens a box that
looks just like the one in Figure 3-36.

• Delete. If you no longer need a notification, click this link. Google asks if you’re
sure; click OK, and the notification is history.

Share a copy as a template

Imagine a coworker comes to you and says, “I really like the way you set up the spread-
sheet for the CHAOS project. Can I use it as a template for Project Blather?” You could
invite him to collaborate on the CHAOS spreadsheet, but maybe you don’t want him
tinkering with its data. A better solution is to invite him as a viewer, which lets him
look at the spreadsheet but not change it. That way, he can download your spreadsheet
to his computer and use it as a template for his own project.

But what if you want to share a template or a form more widely, putting it on your Web
page or blog for anyone to use? Here’s a trick that lets you do just that. It’s like the
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process for sharing a spreadsheet by putting it on a Web page (page 167), but with a
twist: When someone clicks the link to the spreadsheet, an identical—but completely
new and separate—version of it appears in his Docs list.

Follow these steps to create a template link:

1. Open the spreadsheet that others will use as a template, and then click the Share
tab.

Docs opens the Share page, shown back in Figure 3-34.

2. In the Advanced Options section, turn on the “Anyone can view this document
at:” checkbox.

Docs generates a URL for sharing a published version of the spreadsheet, and dis-
plays it just below the “Anyone can view this document at:” checkbox.

3. Copy the URL, and then paste it into the email (or Web page or blog post) that
lets others know about the link. But you’re not done yet! At the end of the URL,
add this text: &newcopy. (Don’t type the period.) This little bit of text instructs
Web browsers to make the link a template link.

4. Send your email or upload the Web page or blog post.

Now, when someone clicks the link you’ve edited, an identical copy of your
spreadsheet appears in his Docs list, one that’s separate from the original, so people
can edit it as much as they like.

Figure 3-37. Any notifications you’ve created are listed here. To create a new notification, click “Add
another” (circled). You can also edit or delete notifications from this box.
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WARNING
Anybody who’s Web-savvy can edit the URL to gain access to your original spread-
sheet by simply removing the text you added (&newcopy). So use this trick with
caution. If your original spreadsheet holds sensitive data, don’t share the link too
widely—somebody could use it to gain unauthorized access to your original spread-
sheet. Template links work best when they link to a spreadsheet that holds just a bit
of sample data.

Insert a comment

Chatting about a spreadsheet lets you discuss it in real time, but you can also insert
comments (notes attached to specific cells) into the spreadsheet. You might want to do
this if you’re the only one working on the spreadsheet at the moment and you want to
leave a note for your collaborators (or even yourself).

To insert a comment, select the cell where you want the comment to appear, and then,
on the Edit toolbar, choose Insert→Comment, or right-click (control-click), and then,
from the menu that appears, choose “Insert comment”. Either way, a box opens where
you can type your comment, as Figure 3-38 shows. Comments show the commenter’s
name and the date and time of creation.

When you’re done typing your comment, click anywhere outside the comment box.
The comment disappears, and the upper-right corner of the cell that holds the comment
shows a small orange dot. To view the comment, just hover your cursor over that dot.

Edit a comment

To edit a comment (either to change your own comment or respond to someone else’s),
hover your cursor over the orange dot that indicates a comment in a cell. When the

Figure 3-38. When you insert a comment, Docs opens a small text box where you can type your
comment. Cells that contain comments have a small orange dot (circled) in their upper-right corners.
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comment appears, click inside the comment box, and then start typing. Click outside
the box when you’re done.

Delete a comment

To delete a comment, hover over the orange comment dot, and then click inside the
comment box. Delete all the text in the box (including the commenter’s name and the
date/time stamp). Then click outside the now-empty comment box, and the comment
indicator disappears.

Creating a Form
A lot of people simply don’t speak spreadsheet. Present them with an array of rows and
columns and say, “Here, edit this,” and they’ll look at you blankly—or jump in and
mess up your data.

But forms are a different matter. People have been filling out forms since they first
learned to write their names back in kindergarten. In Docs, you can create a form and
invite others to fill it out. That way, instead of trying to make sense of rows and columns,
they enter text into text boxes or select from drop-down lists. And the best part is that
when someone completes the form, the data it contains gets added to your spreadsheet
—automatically.

You can create a form from any spreadsheet. To get started, open your spreadsheet,
and then click the Share tab (Figure 3-34). In the “Invite people” section, turn on the
“to fill out a form” radio button, and then click the “Start editing your form” button
to open the “Edit form” window shown in Figure 3-39.

Step 1: Create the form

The “Edit form” window shows the title of your form (it’s the same as the name of your
spreadsheet) and lists the fields that will make up your form (Docs takes these from the
column headers of your spreadsheet). You can change the form’s title and (if you want)
add a description to announce what the form’s all about. You can also move, edit, or
delete any field. When you click the edit link (circled in Figure 3-39) to edit a field,
Docs gives you the following options:

• Question title. This option is the name of the field, like Name or Email Address.

• Help text. If you want, you can add a line of text here to explain the field or
elaborate on your question.

• Question type. This option determines the kind of field that the form presents to
the viewer. Docs can handle these field types:

— Text. A one-line text box.

— Paragraph text. A larger text box for the loquacious.
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— Multiple choice. This option creates radio buttons on the form; viewers can
choose just one.

— Checkboxes. Viewers can select multiple checkboxes (see Figure 3-40).

— Choose from a list. This option lets viewers make one selection from a drop-
down list.

• Add a question. At the bottom of the page is a link you can click to add a brand-
new question (that is, a brand-new field) to your form. When you add a new field
here, Docs also adds it as a column header to your spreadsheet (so it’ll know where
to stow incoming data for that field).

Step 2: Share the form

When you’ve got your questions looking good, at the bottom of the “Edit form” box,
click the “Next, choose recipients” button to save your form and hop to the Preview
and Send page, shown in Figure 3-41.

Figure 3-39. Docs shows you the fields on your form, which it gets from your spreadsheet’s column
headers (the data in row 1). When you click a field, arrows and an edit link (circled) appear to its left.
Use the arrows to move the field up or down on the form. Click the edit link to choose a field type.
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The right side of the Preview and Send page shows what your new form looks like. The
left side is where you tell Docs whom you want to view your form. Type or paste email
addresses into the To box, and Docs sends your form to these people when you click
the Invite People button. (If you have a Gmail account, you can use your Gmail Contacts
list—page 273—to select recipients.) You can also set these preferences:

• Include form in invitation email. Leave this checkbox turned on if you want a
copy of the form to appear inside the invitation email. Recipients can fill out the
form, and then submit it right from their email programs.

Figure 3-40. This example shows a list of checkboxes. Viewers can check more than one to show an
interest in more than one kind of musical instrument.
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NOTE
Not all email programs can read and display the form. Just in case the form doesn’t
display correctly in the email, Docs also includes a link recipients can click (or paste
into a Web browser) to get to a page with a live version of the form.

• Let people see existing responses. Leave this checkbox turned off if you’re col-
lecting personal information or just don’t want respondents to be influenced by
what other folks have entered.

• Custom confirmation message. If you want people to see a personal message
after they fill out your form—something along the lines of “Thanks for helping me
out!”—type it here.

When your list of recipients is complete (or complete enough for now, anyway), click
Invite People. Google sends out your invitations. Now all you have to do is sit back and
wait for their responses to add data to your spreadsheet.

Figure 3-41. The left side of the Preview and Send page is where you list the people you’re inviting to
fill out the form, and where you fine-tune the invitation. The right side shows what your form will
look like.
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View the results

When people fill out and submit the form, their responses go straight into your spread-
sheet, as Figure 3-42 shows. (Docs adds a time-stamp column to the beginning of the
spreadsheet, where it notes the date and time each response arrived.) Then you can
work with the information just like any other data.

Edit a form

As Figure 3-42 shows, a spreadsheet that’s gathering data through a form has a couple
of new links at the top:

• Go to live form takes you to the form itself.

• Edit or resend form takes you back to the Edit Form page.

If you need to make changes to a form—anything from correcting a typo to changing
a field’s type to adding a new field—click “Edit or resend form”. Make your changes
in the same way you did when you created the form (page 177). Click “Next, choose
recipients” to save the revised form.

As when you created the form, you land on the Preview and Send page. If you want to
invite more people to fill out the form, you can do that here. If you don’t want to invite
anyone else for now, you’re done.

Figure 3-42. Information entered by form recipients goes straight into the spreadsheet that generated
the form. Column A, which Docs creates automatically, shows the date and time the info arrived.
When a spreadsheet gets data from forms, two new links appear (circled): click “Go to live form” to
visit the form on the Web, or click “Edit or resend form” to tweak your form or send out more
invitations.
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TIP
You can also edit a form from the Share tab. Click Share→“Edit or resend form” to
open the “Edit form” box.

Turn off a form

If you’ve collected enough data for now, thanks, you can turn off the form so it’s no
longer live. Open the spreadsheet that the form’s based on, and then click its Share tab.
On the right side of the page, you see a button labeled “Turn off form”. Click it, and
your form no longer sends data to your spreadsheet. You can always come back to the
Share tab and turn your form back on.

Track responses on your iGoogle page

When you create a new form, Google sends you a confirmation email. The bottom of
the email has some text that says something like, “Tip: Keep an eye on forms and new
responses using the Forms iGoogle gadget.” The words “Forms iGoogle gadget” are a
link; click it to open a page that lets you add the Forms gadget to your personalized
iGoogle page. Google gadgets (page 417) let you display content from Google Docs
and other apps on your iGoogle page (see Chapter 8). The Forms gadget helps you keep
track of your forms, as Figure 3-43 shows: respondents’ names, the number of respon-
ses, and whether any of those responses are new. As a super-convenient plus, you can
launch the form creation process right from this gadget by clicking the “New form”
link. When you create a form this way, Docs also creates a new spreadsheet to collect
its data.

TIP
Chapter 8 tells you everything you need to know to set up your iGoogle page and put
it to work.

Turn Back Time: Your Spreadsheet’s Revision History
As you work in your spreadsheet, Docs is busy behind the scenes, saving your work.
So busy, in fact, that after you’ve saved once, you don’t have to worry about saving as
you work. Just click Save & Close when you’re done to make sure the very latest changes
get saved, and Docs takes care of the rest.

In Google Docs, each saved version doesn’t replace the previous saved version. Instead,
Docs stamps the time and date on each save and adds it to the list of revisions. You can
see this list by going to the Revisions tab, shown in Figure 3-44. Here, you can choose
a particular version of your file from the Revisions drop-down list; each revision on the
list shows the date and time of a change, who made it, and what kind of change it was.
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Select a revision to see it on the screen. You can easily see what changes were made to
the previous version of the file, because Docs highlights changes in orange. If it’s not
the one you were looking for, you can page through the different versions, one at a
time, by clicking the Older and Newer buttons above your spreadsheet.

NOTE
Clicking the Edit tab while you’re looking at a revision takes you back to the current
version of your spreadsheet.

You can’t edit revisions—they’re just for viewing. That makes sense, since you want
to edit the current version. But say you’ve been working all morning entering changes
that the boss insisted on. Now, as you’re about to take a coffee break, the phone rings.
It’s the boss, blithely telling you to forget about making those changes. There’s no need
to quit on the spot, or even cut your coffee break short. Just find the last version of the
spreadsheet that Docs saved before you started making those boss-mandated changes.
When you find it, you can go back to that earlier version by clicking the “Revert to this
one” button. Docs asks if you’re sure you want to want to switch back to the earlier
version now on the screen; click OK to confirm. And presto changeo—the previous
version becomes the current one, and what was the current version gets saved as a

Figure 3-43. Adding the Forms gadget (circled) to iGoogle lets you keep track of your forms, even
when you’re not in Google Docs. For each form, iGoogle shows you the total number of responses in
parentheses. And when you receive a new response, the gadget lets you know. Click the name of any
form to open its associated spreadsheet. Create a new form (and a spreadsheet to go with it) by clicking
the “New form” link.
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revision (so you can revert back to it if your boss changes his mind again). Go ahead
and take a couple of extra minutes for your break—you’ve earned it.

Figure 3-44. On a spreadsheet’s Revisions tab, the drop-down list shows earlier versions of the
spreadsheet, along with the time the changes were made, who made them, and what kind of changes
they were. You can look at different revisions one by one using the Older and Newer buttons (circled).
If you want to make the version on your screen the current version, click the “Revert to this one”
button (also circled).
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